Redirection http vers https

Bonjour, j’ai réussi à rediriger mon site http en https grâce au fichier ci dessous.
Peut-on aussi rediriger l’adresse ip externe sur le https svp?
merci
Capture14

Lo,

Redirige ton IP vers le port 443,

Au plaisir, bonne soirée,

oui c’est mon problème de rediriger l’adresse ip vers le https. comment procède t’on?
merci

Depuis la box de ton FAI Redirection des ports

oui mais elle est pas redirigé vers le https

Fais un screen de ton écran stp

Bonjour, j’explique mieux. J’ai créé un nom de domaine sur OVH qui renvoi à mon adresse IP externe.
Sur le debian j’ai crée un certificat. donc quand je tape le nom du domaine j’arrive bien sur Jeedom que se soit en http ou https De plus le http renvoi direct en https.
Le problème si je tape l’adresse ip externe 83.xx.xx.xx:443 la il pointe en http et pas en https.
voila
Capture

Merci

Lo,

J’ai cru reconnaître l’interface Free :grin:
Tu dois rediriger les ports 80 et 443 de ta pi
Depuis ton compte ovh tu dois renseigner ton ip externe,

Par contre tu n’avais pas besoin de prendre de nom de domaine chez ovh t’as un nom de domaine par Free,

Au plaisir bonne soirée,

PS tu peux lire ce lien

bonjour,c’est ce que j’ai fait:
Capture

Quand je tape mon adresse Ip: 83.xx.xx.xxx , il veut l’ouvrir en non sécurisé.
Quand je tappe mon adresse IP: 83.xx.xx.xxx:443 , voila le message

Capture1

Bonjour

Non il n’est pas nécessaire d’ouvrir le port 80.
Ensuite retire la redirection udp elle ne sert à rien, il faut juste le tcp.
Enfin, essayes sur un autre port externe, par exemple le 12443, qui redirige vers le 443.
Et dans ton navigateur, tapes l’adresse https://adresse-ip:12443 (avec le https)
Ca donne quoi?

Bonjour,

Rediriger une IP vers http (ou httpS) ne veut rien dire.
Donc pourriez-vous clarifier votre demande au lieu que les personnes ici interprètent / devinent ce que vous voulez dire?

Bien sur, c’est à vous de taper httpS://83.xxx.ccc.yyy comme explicitement écrit dans le message d’erreur.
Il est inutile de rajouter le port 443 derrière étant donné que c’est le port par défaut pour de l’https

Ne faite pas cela, on lit bien sur le message d’erreur que le browser a contacté le serveur mais que celui-ci refuse de dialoguer en http.

Pour rediriger automatiquement un client depuis http vers https, c’est le serveur qui doit avoir spécifié le header hsts et c’est le client qui en tiendra compte (ou pas s’il est trop ancien), qu’importe si c’est l’ip ou le nom de domaine qui ont été utilisés par le browser intialement.

2 J'aimes

bonjour merci pour cette réponse.
Pardon de pas avoir été clair.

j’ai redirigé automatiquement mon nom du domaine http vers https avec ce fichier


<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
RewriteEngine on
RewriteCond %{SERVER_NAME} =xxxxxxx.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

ça fonctionne niquel mais plus avec mon adresse ip. Cela a t’il un lien?

merci

OK je vois, il est effectivement possible de forcer une redirection http au niveau d’un serveur web/reverse proxy ou autre similaire.

Mais en fait vous ne devriez pas mettre comme condition le nom de domaine.
Toute requête http arrivant sur votre serveur, qu’importe comment elle est arrivée, peut (doit ?) être redirigée sur https.

Même remarque que @Mips et sinon tu peux essayer d’ajouter une condition sous la première :

RewriteCond %{HTTP_HOST} 83.x.x.x

je devrai utilisé quelle condition alors?
l’Ip comme le suggère Bison.? j’ai pas réussi avec

La base pour rediriger tout le traffic http vers https c’est :

RewriteEngine On
# This will enable the Rewrite capabilities

RewriteCond %{HTTPS} !=on
# This checks to make sure the connection is not already HTTPS

RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
# This rule will redirect users from their original location, to the same location but using HTTPS.
# i.e.  http://www.example.com/foo/ to https://www.example.com/foo/
# The leading slash is made optional so that this will work either in httpd.conf
# or .htaccess context

Là je nage :sob:

Pourquoi ?

Tu as fait ça :

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
RewriteEngine on
RewriteCond %{SERVER_NAME} =xxxxxxx.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

Et il faudrait faire ça :

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
        RewriteEngine On
        RewriteCond %{HTTPS} !=on
        RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
</VirtualHost>

avec ta partie, le http bascule bien en https mais toujour pas l’IP qui reste en non sécurisé

Tu restart bien le service pour prendre en compte la nouvelle conf ? :wink: