Re lancement d'un scenario au boot

Tags: #<Tag:0x00007f59278bc018>

bonjour,

vu qu’on m’a fermé le sujet avant que je puisse y répondre car j’ai pas réponduassez vite (dernier message hier … désolé d’etre parti en déplacement professonnel …) , je continue donc dans un autre post.

Suite aux explications recues, j’ai donc lancé un scénario au boot en définissant :
mode de scénario = provoqué
Evenement = #start#

ca fonctionne mais la roue dentée du scénario tourne ensuite en permanence.

est ce nomal ?

Salut,
Mets une copie de ton scénario pour qu’on puisse t’aider.
Là, comme ça, c’est compliqué.

1 J'aime

Ps : le sujet se ferme automatiquement après un certain laps de temps sans réponses si je dis pas de bêtises.

Salut,

Seulement si résolu ce qui était bien le cas.

S’agissant d’une autre demande il est de toute façon préférable de créer un nouveau sujet donc tout va parfaitement bien :grinning: :yum:

Pour ta roue dentée as-tu essayé de recharger la page avec F5? Si tu sors et que tu reviens dans le scénario roue crantée à nouveau? Tu peux naviguer dans ton scénario tout de même malgré cette roue?

Enfin, je vois qu’on répond et qu’on n’a pas de réponse aux questions posées.

Heu il a peut-être une vie aussi ! son message a été écrit y’a 2 heures…

Oui enfin, la façon dont le début du message est rédigé est assez vindicative.
Donc,.si on pose des.questions , la.moindre des choses est d’y répondre.

Oui je te l’accorde :innocent: mais du fait d’une mauvaise compréhension de la logique du forum

Ah pis ok t’as raison s’il ne répond pas dans les 5 minutes je ferme le sujet :laughing: :grin: :stuck_out_tongue_winking_eye:

Je suis désolé mais des sujets restent ouverts très longtemps sans qu’aucun message n’y soit posté.
J’ai le cas avec le partage des widgets en V4.
Donc, s’il a été fermé, cela ne s’est pas fait tout seul.

T’as vraiment toujours pas compris le rapport entre la résolution d’un sujet et sa clôture en l’absence de nouveau message dans les 24h ?
Pourtant y’a un message des plus explicite qui apparaît lorsque le sujet passe en résolu:
Sans%20titre

Le sujet est là, résolu et fermé 24h après donc oui ça s’est bien fait tout seul:

1 J'aime

J’ai parfaitement compris le principe du forum et des clôtures, ça fait quand même un moment que je suis dessus, je ne suis pas complétement idiot. En plus, il me semble que seul l’auteur du sujet et les modérateurs peuvent clore un sujet.
Je dis que si le sujet est clos c’est qu’il a été déclaré solutionné auparavant et ça c’est une action volontaire, ça ne se fait pas par l’opération du Saint-Esprit.

Pfffiou j’avais pas compris ça comme ça désolé. Bref là il va être content @lebphi y’a plein de lecture sur son post :smile: à voir si sa roue tourne toujours demain…

Ça c’est sûr, il ne va pas en revenir.

je suis désolé d’avoir créé un tel micmac avec a remarque sur la cloture des posts.

Je ne répond pas immédiatement tout simplement parce que je ne fais pas que du jeedom dans la vie … et il n’est pas rare que je n’en fasse pas pendant 24h d’ou ma remarque sur la cloture que je trouve un peu rapide. Après on va pas en faire un fromage.

Concernant mon scenario il lance un script (plugin) sh qui lance lui meme un script python (un flask server) . Si je lance directement le script ca marche, si je passe par le scenario au boot ca marche de temps en temps. Je vais faire des tests ce week end plus précisement.

pour info le flask server est utilisé pour interfacer jeedom avec un arduino via un protocole maison.
Le server flask lit le port usb en boucle et les transmet à un scénario ou un virtuel jeedom via l’api sur la meme machine.
il permet aussi de recevoir des commandes de jeedom du genre http://localhost:90/cmde/uno/[UR2C] qui sont ensuite transmises à l’arduino.

Il suffit peut-être de mettre une petite temporisation au démarrage un wait ou un sleep ou un Dans 1 minute pour être sûr qu’il ait bien tout chargé au boot pour pouvoir lancer le script ?!