RASBPI 3 - Impossible de lancer le démon openzwave

Salut à tous,

Premier post pour moi, après avoir parcouru de long en large la Community sur mon problème, sans succès je le crains.

Actualité oblige j’ai du temps de libre et me lance dans le projet de domotique pour chez moi.
Sur base de Raspberry Pi 3 B avec contrôleur Z-Wave Plus Z-Stick GEN5, en DIY, je suis le tutos.

Mais voilà, après installation du plugin, impossible d’installer le moindre équipements, j’ai des erreurs sur le démon Z-Wave qui ne se lance pas :

« Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consécutivement »

Et dans la santé du plugin :

« Echec de la requête http : http://127.0.0.1:8083/network?type=info&info=getHealth&apikey=UXnS5WeSX3cIDg6NaNALCBuxEFJkPbAu Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused »

Je joins les logs, si cela peut aider.

Sante_Jeedom

plugin_zwave

Je sollicite de l’aide car les différents tests que j’ai pu faire, basés sur des sujets trouvés ici et là, n’ont rien donnés chez moi :frowning:

Merci d’avance :slight_smile:

openzwave.log (1,9 Ko)

Bonjour.

Le porte-clé zwave, laissez le en auto et testez de nouveau.

J’avais déjà tenté, mais par acquis de conscience je l’ai mis en AUTO, puis redémarré Jeedom, malheureusement sans plus de résultat :confused:

il faudrait mettre le ,niveau de log du demon zwave en mode debug. Relancer le demon et tester de nouveau.
Puis, coller journal de la log ici entre bloc code.

Vous pouvez aussi, vous assurer de ne pas être sur un hub USB externe et changer de port USB pour « voir » si cela ne suffit pas.

Bonjour @Vivitch,

la clé USB Z-Stick Gen5 monte sur du /dev/ttyACM* et non pas du /dev/ttyAMA0 qui correspond a de la carte GPIO.

voir ici : [Présentation] akenad
et ici : https://community.jeedom.com/t/2512

donc d’abord vérifier que la clé monte :

$ lsusb

akenad :slight_smile:

Je suis en direct sur le Pi, j’ai changé de port parmis les 4 dispos mais même combat.
Voici ce que me sortent les logs du zwave en debug :

[2020-04-05 18:35:35][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log
[2020-04-05 18:37:59][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-04-05 18:38:00][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device auto --loglevel debug --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback http://127.0.0.1:80/24/plugins/openzwave/core/php/jeeZwave.php --apikey xxxxxxxxxxxxxxxxxxxxxxxxxxxxu --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
[2020-04-05 17:38:02][INFO] : Start openzwaved
[2020-04-05 17:38:02][INFO] : Log level : debug
[2020-04-05 17:38:02][DEBUG] : PID file : /tmp/jeedom/openzwave/deamon.pid
[2020-04-05 17:38:02][INFO] : Device : auto
[2020-04-05 17:38:02][DEBUG] : Apikey : xxxxxxxxxxxx
[2020-04-05 17:38:02][INFO] : Callback : http://127.0.0.1:80/24/plugins/openzwave/core/php/jeeZwave.php
[2020-04-05 17:38:02][INFO] : Cycle : 0.3
[2020-04-05 17:38:02][DEBUG] : Initial disabled nodes list: []
[2020-04-05 17:38:02][DEBUG] : Init request module v2.21.0
[2020-04-05 17:38:02][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2020-04-05 17:38:02][DEBUG] : http://127.0.0.1:80 "GET /24/plugins/openzwave/core/php/jeeZwave.php?apikey=xxxxxxxx HTTP/1.1" 404 196
[2020-04-05 17:38:02][ERROR] : Callback result as a unknown error: 'Response' object has no attribute 'status'. Please check your network configuration page
[2020-04-05 17:38:02][ERROR] : Network communication issues. Please fixe your Jeedom network configuration.
[2020-04-05 18:38:30][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log

Encore merci pour l’aide, je rame vraiment de mon côté, c’est d’autant plus appréciable :sweat_smile:

Il est indiqué dans cette log (que j’ai remis en forme et j’ai supprimé l’API Key qui était visible), il est indiqué tout en bas que la configuration réseau de Jeedom n’est pas correct.

Allez dans la partie configuration de Jeedom et corrigez le problème réseau.

a oui merci, désolé !

Je ne comprends pas où car, dans la santé de Jeedom j’ai les voyants aux verts sur la partie réseau.
En local sur mon réseau perso j’ai accès à l’interface Jeedom, ainsi que depuis l’extérieure (test sur un smart phone) par routage de ports sur ma box.

Aïe je creuse quand même !

Bonjour @akenad, j’ai modifié dans ce sens, mais pas de résultat.
J’ai regardé tes posts, à priori il faudrait que je mette un hub usb alimenté, si j’ai bien suivi ?

Le Hub autoalimenté c’est pour les Pi4. Je suis en Pi 3B+ avec la même clé que vous.

Dans la partie configuration de Jeedom, puis Réseau. Il n’y a pas de problème d’indiqué ?

que donne ? :

$ lsusb

akenad :slight_smile:

Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

On voit bien la clé ZWave du coup je pense ?

Faite une copie d’écran de la configuration Réseau de Jeedom.

Donc étape 1 -> check

étape 2 :

que donne ? :

$ dmesg | grep ttyACM

akenad :slight_smile:

J’ai ce message :
[ 6.483694] cdc_acm 1-1.5:1.0: ttyACM0: USB ACM device

@Fabrice la copie d’écran ci dessous

reseau jeedom

Pour « voir » supprimez le 80 dans la partie interne et le /24 à la fin.
Puis, décochez la case : Désactiver la gestion du réseau par Jeedom (cette action (la cocher) masque des éventuelles problèmes.

Donc étape 2 -> check

étape 3 :

dans la configuration du plugin Z-Wave,
sélectionner Port clé Z-wave : /dev/ttyACM0
sauvegarder
et redémarrer le démon

akenad :slight_smile:

Merci @Fabrice j’ai fais et redemarré et c’est ok Démon en vert !
MErci @akenad pour les pistes fournis aussi !

Au top les gars !

Merci.

Repassez la log du deamon zwave en valeur par défaut et relancez le service (pour prendre en compte ce changement).

bonne soirée