Problème reseau suite changement infrastructure reseau

Bonjour à tous sur ce nouveau forum d’entre aide, très bonne idée en passant cette community!

Bon voilà j’en ai eu un peu marre des pertes de connexion incessante de ma box non pas qu’elle démérite c’est juste que la famille grandit et que vu le nombre d’objets connectés à notre box “wifi ou Ethernet” c’est pas étonnant qu’elle rende l’âme par moment!

Du coup pour noël je me suis offert un routeur sans fil linksys max-stream ea7500 dual-band.

bon après quelques petits problèmes tout est rentré dans l’ordre et c’est maintenant lui qui gère toutes les adresses du réseau.

Comme vous vous en doutez mon seul problème c’est l’accès à jeedom. Je suis donc sur jeedom dans un docker nas synology.

Jusque là je me connectait avec l’adresse IP de mon nas et port 9080. Donc là je redémarre les conteneurs maria et jeedom au cas où. j’essaye de me connecter avec la nouvelle IP du NAS et 9080 mais rien!

quand je vais sur le market, il me trouve bien ma jeedom avec l’ip en 172.17.0.1 mais ce n’est pas l’ip de connexion.

Comment puis-je accéder à nouveau à mon jeedom?

merci a tous ceux qui pourront m’aider

Salut,
Dans Jeedom tu peux voir les IP dans le menu Configuration> Réseaux. Il devrait te montrer ce qu’il utilise.

Je suppose que tu réussis à te connecter sans problème au NAS ?

Attention lip de la co fig réseau jeedom na rien a voir avec l ip de l os. !!

Le routeur wifi qui bloquerait (firewall) par défaut l’accès à ce port ?

oui je me connecte sans souci au NAS!

Pas du tout penser au port bloqué par le routeur, je regarde cela tout de suite!

bon ben c’est pas le port bloqué par le routeur.

dans jeedom ---->réseaux, c’est effectivement l’ip suivante qu’il y a de renseigner : 192.168.1.30

cela peut poser le problème que je rencontre?

si oui comment changer cela?

j’ai acces en ssh par le conteneur du nas et un ifconfig me donne 172.17.0.3

pas d’autres solutions?

plus rien ne fonctionne et j’ai pas envie de tout réinstaller pour une histoire d’acces à l’interface!

je comprends pas pour quoi cela ne marche plus!

j’ai cela maintenant quand j’essaie d’accéder:

SQLSTATE[HY000] [2002] No route to host

et l’icône de jeedom apparaît bien dans l’onglet du navigateur mais toujours pas d’accès

Je connais pas trop malheureusement le principe de fonctionnement des conteneurs mais j’imagine qu’il y a une sorte de redirection de port entre l’IP du NAS et une IP qui doit être celle du conteneur.

Ça donne l’impression que lors de l’installation initiale Jeedom (ou le système de conteneur) a inscrit quelque part l’IP qui était celle de ton ancien réseau et que du coup il n’écoute pas sur la nouvelle IP du conteneur.

Essaye de regarder dans le fichier /etc/hosts peut être ?

voici ce que j’ai dans le hosts:

127.0.0.1  localhost
::1             localhost ip6-localhost ip6-loopback
fe00::0      ip6-localnet
ff00::0       ip6-mcastprefix
ff02::1       ip6-allnodes
ff02::2       ip6-allrouters
172.17.0.2    manulin-jeedom-strech1

Ton Docker est en mode Bridge (IP 172.17.0.1)
Tu devrais passer en mode Host (IP 192.168.xx.xx)
regarde ici
[Tuto] Installation de Jeedom sur Synology avec docker en mode Host

oui je suis en bridge mais j’ai rien changé à ce niveau là donc pourquoi cela ne marche plus?

j’ai beau regardé j’ai pas vu comment passer du mode bridge au host?

Il va falloir créer un nouveau conteneur
On ne pas modifier le conteneur qui est en bridge

super! du coup tout est à refaire?

pas moyen de recup une sauvegarde avec le terminal?

Pourquoi ne pas monter le reverseproxy du synology, et faire tes redirections avec ca ? ca t’éviterai de tout reprendre, et tu pourrai centraliser sur un seul sous-domaine l’intégralité de tes services Syno… :slight_smile:

A tout hasard, ca serait pas ton router qui distribue du DHCP en 172.17.0.1/24 alors que ta box distribue du 192.168.1.0/24 ?
Il suffirait de mettre le DHCP seulement sur ta box pour régler le souci :wink:

[EDIT]: Je viens de relire… il semblerait que tu l’utilise en tant que routeur et non en AP, donc ma solution tombe à l’eau :wink:

C’est aussi pour ça que jeedom ne supporte pas docker …

N’importe quoi ! C’est dans la doc …

Tu crées un nouveau conteneur et ensuite tu restores une sauvegarde Jeedom