Probleme DNS

Tags: #<Tag:0x00007fcbad47a358>

Hello,
Je suis en train de migrer vers mon syno.
Après avoir suivi ces tuto pour installer jeedom sous docker, avec macvlan puis BLEA:

j’ai un soucis de DNS, je suis sur une erreur 502, j’avais déjà eu ce soucis avec une container jeedom Master mais réglé par ce tutoriel :

mais je sais pas qu’elle port apache mettre ?
si quelqu’un a cette infos?

pour infos le log de openvpn

Sat Nov 21 09:15:26 2020 WARNING: file '/tmp/jeedom/openvpn/openvpn_auth_59G7pylcRcnkj7s6L6utgeEmKRiCZQ.conf' is group or others accessible
Sat Nov 21 09:15:26 2020 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
Sat Nov 21 09:15:26 2020 library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Sat Nov 21 09:15:26 2020 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Sat Nov 21 09:15:26 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]149.202.176.140:1199
Sat Nov 21 09:15:26 2020 UDP link local: (not bound)
Sat Nov 21 09:15:26 2020 UDP link remote: [AF_INET]149.202.176.140:1199
Sat Nov 21 09:15:26 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sat Nov 21 09:15:26 2020 VERIFY OK: depth=1, C=FR, ST=IDF, L=Paris, O=jeedom.com, OU=jeedom.com, CN=jeedom.com CA, name=jeedom, emailAddress=postmaster@jeedom.com
Sat Nov 21 09:15:26 2020 VERIFY OK: depth=0, C=FR, ST=IDF, L=Paris, O=jeedom.com, OU=jeedom.com, CN=server, name=jeedom, emailAddress=postmaster@jeedom.com
Sat Nov 21 09:15:27 2020 Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, 1024 bit RSA
Sat Nov 21 09:15:27 2020 [server] Peer Connection Initiated with [AF_INET]149.202.176.140:1199
Sat Nov 21 09:15:28 2020 Data Channel: using negotiated cipher 'AES-256-GCM'
Sat Nov 21 09:15:28 2020 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Sat Nov 21 09:15:28 2020 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Sat Nov 21 09:15:28 2020 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
Sat Nov 21 09:15:28 2020 Exiting due to fatal error

Merci

Dans ton openvpn il faut saisir une adresse IP ?
si oui laquelle as tu mis ?

Dans le plugin openvpn l’objet ce créé tout seul quand on fait le liens avec market vu que j’ai le pack power.

un petit up?
J’ai toujours pas de solutions

Hello,

Donc j’ai remarque que dans mon jeedom sous docker j’ai pas l’interface « tun0 » dans la configurations réseau.

En plus impossible de contacter le support car il me dit que sur une de mes box j’ai le plugin optimize hors, je l’ai désinstalle il y a un moment
donc ticket assistance impossible

si @loic passe par la ?

Merci

Bonjour,

Même le plugin optimize désinstallé il reste des traces détectées par Jeedom.
Seule solution : fresh install. Ou alors trouver les traces.

Ah ba la fresh install sera prévu sur la Smart pour la revendre une fois passe sur le syno :sweat::sweat:.

Mais tant que le DNS est pas fonctionnel je vais pas migrer --’

Bonjour,
Je crois pas que le DNS puisse marcher sur docker sans faire des bidouille dans tous les sens que nous ne documenterons pas (trop de risque de tout casser)

Merci pour ton retour.

J’avais monte un premier jeedom pour faire des essaie et j’avais bien le DNS de fonctionnel
Mais niveau réseau j’étais en Host de souvenir
Donc j’avais l’IP du Synology et passait par le port 9080

Sur la nouvelle installation je suis en macvlan pour l’utilisation de BLEA
La seul différence

Je sais pas si c’est liée a cela ?

Bonsoir Loic,

Donc je reviens a mon probleme dez DNS

J’ai relance mon premier Jeedom V4 sous docker, celui la qui fonctionnais bien avec le DNS.

Donc mon premier Jeedom fonctionne bien, il est sous le reseau Bridge

J’ai compare les deux container, seul difference c’est le reseau, mon deuxieme jeedom est sous macvlan, mais on est sur un reseau bridge donc ca doit etre pareil?

Sous le market jeedom monn premier jeedom est reconnu sur un hardware docker, alors que mon deuxieme est reconnu sous un hardware diy.

J’arrive pas a comprendre qu’elle différence il y a entre les deux.

Hello,

Pour faire un retour après multiples essaie.

Donc je suis passe sous VM.
Aucun complication comme cela
DNS OK
Cle Zwave fonctionnel.
Cle Bluethoot aussi fonctionnel.

J’ai pris l’image debian donne dans la documentation.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.