Problème Demon avec plugin ESP-EASY

Tags: #<Tag:0x00007f385049f950>

Bonjour,
Je continue de flasher des modules SONOFF. Pour les gérer dans Jeedom, j’ai installé le plugin ESP-EASY.
Hélas, je n’arrive pas à lancer le demon. Une erreur apparait au bout de quelques secondes.
Voici le message d’erreur : Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consécutivement
Puis dans les logs : 2020-06-28 22:57:26][DEBUG] : Lancement démon espeasy : nice -n 19 nodejs /var/www/html/plugins/espeasy/resources/espeasy.js 169.254.50.87 http://127.0.0.1:1980/plugins/espeasy/core/api/jeeEspeasy.php?apikey=AAAAAAAAAAAAAAAAAAAAAAAAAAAAA 100
[2020-06-28 22:57:26][INFO] : Démon espeasy lancé
[2020-06-28 22:57:35][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2020-06-28 22:57:26
[2020-06-28 22:58:35][ERROR] : Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consécutivement
[2020-06-28 22:58:35][INFO] : Arrêt du service espeasy

Est-ce que cela vient de mon module, qui lui fonctionne malgré l’erreur ?
ecran ESP

Hello,
Même si tu utilises un pi tu ferais quand même mieux de poster dans les pages du plugin espeasy, tu aurais probablement des réponses plus adaptées.

Salut @lone , est-ce que je dois modifier quelque chose à mon post ?

Si tu n’as pas de réponse, mets le ici par exemple:
https://community.jeedom.com/c/plugins/protocole-domotique/66

Le Post est transféré ici : Problème Demon NOK avec plugin ESP-EASY

Salut,

Je n’ai pas beaucoup de modules espeasy mais ça fonctionne très bien …
Quelques pistes :

  • Réinstaller des dépendances : fevrier c’est vieux
  • Laisser le plugin se gérer tout seul (gestion automatique) et ne pas le lance 10x de suite à la main
  • Si le plugin crashe, mettre en debug et poster les logs en entier (mais sans la cle api), autrement ça reste de la divination

Salut @naboleo

  • Je viens de réinstaller les dépendances mais la date reste toujours en février 2020.
  • Le plugin est en gestion automatique
  • j’ai mis en debug et voici les logs :
    Server running
    events.js:187
  •  throw er; // Unhandled 'error' event*
    
  •  ^*
    

Error: listen EADDRNOTAVAIL: address not available 169.254.50.87:8121

  • at Server.setupListenHandle [as _listen2] (net.js:1283:19)*
  • at listenInCluster (net.js:1348:12)*
  • at doListen (net.js:1487:7)*
  • at processTicksAndRejections (internal/process/task_queues.js:81:21)*
    Emitted ‹ error › event on Server instance at:
  • at emitErrorNT (net.js:1327:8)*
  • at processTicksAndRejections (internal/process/task_queues.js:80:21) {*
  • code: ‹ EADDRNOTAVAIL ›,*
  • errno: ‹ EADDRNOTAVAIL ›,*
  • syscall: ‹ listen ›,*
  • address: ‹ 169.254.50.87 ›,*
  • port: 8121*
    }

Bonjour.

L’adresse IP n’est pas bonne. Vous avez mi une adresse apipa.
C’est les adresses automatique des équipements qui n’arrivent pas à trouver un serveur DHCP.

Renseignez l’adresse correcte de votre équipement, quand celui-ci est bien connecté à un réseau.

Salut…

ça c’est très bizarre… si l’installation va jusqu’au bout la date s’actualise normalement.
A mon avis, les dépendances sont KO même si le message final indique le contraire… A voir donc après la correction de l’adresse ip si ça ne fonctionne toujours pas

Concernant l’IP 169.254.50.87 ,je me perds.
A quoi correspond cette adresse ? C’est l’adresse de qui ou de quoi ? Je me mélange quand on parle de ESPeasy, entre :

  • le plugin ESPeasy,
  • le firmware des modules Sonoff flashés avec firmware Esp-easy ?
    Est-ce que tu peux éclairer ma lanterne ? Dois-je la modifier et mettre quelle adresse ?

Salut,

Il y a 2 adresses IP :

  • Celle que le plugin connait dans sa configuration, c’est aussi celle de jeedom (visible coté config jeedom)
    image
  • Celle(s) pour le(s) module(s) espeasy par exemple
    image

Dans tous les cas (99%) c’est ta box internet qui l’attribue à tes appareils lors de leur démarrage.
Elles sont tout similaires sauf le dernier chiffre.

L’erreur actuelle semble indiquer la première est incorrecte.

PS : Pour info, la date des dépendances ne se met effectivement pas à jour pour ce plugin…

Merci @naboleo. En effet j’avais dans Jeedom/Système/réseau, une adresse IP pour l’accès interne fantaisiste. Je ne sais comment cette adresse est apparue. Il m’a suffit de redonner l’adresse IP du Raspi en 192.168 xxx.YYY pour que lESPeasy prenne cette même valeur et que le Demon passe en OK.
Ouf …

J’avais supprimé mon message ou je signalais ce truc (adresse APIPA), car comme vous n’aviez l’un et l’autre pas réagit, je me suis à un moment dit : c’est normal pour ce plugin (…)

Je l’ai restauré, car en même temps, j’explique la raison de ce type d’adresse, cela peut servir.

@Fabrice Tu as bien fait de remettre ton message. Le dysfonctionnement provenait bien de cette adresse IP dont je ne connaissais pas l’origine.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.