Probléme de migration depuis MAJ 0.20

Tags: #<Tag:0x00007fa7b0edd708>

Bonjour,
et avant tout merci pour cette superbe application.

Depuis le passage à la version 0.20 sur mon smartphone (samsung S20 FE) et ma tablette (MédiaPad) les deux périphériques m’indiquent un message d’erreur: « Cet équipement utilise un ancien format de configuration. Veuillez effectuer la migration. »
Or la migration a déjà été faite pour la/les version(s) précédente(s) et Jeedom me dit qu’elle est déjà effectuée quand je clique sur le bouton dédié…
Du coup je suis bloqué.
J’ai désinstallé et réinstallé l’appli sur le smartphone.
J’ai désactivé et réactivé le plugin. Je n’ai pas encore essayé de le supprimer et de le réinstaller.

J’ai attendu un peu pour voir si d’autres avaient le souci mais du coup je suis preneur de vos conseils.

Merci d’avance.

hello

en plus de la désintallation de l’application, as tu essayé d’effacer le cache & les données sur l’application ? (clic long sur l’icone, informations sur l’application, stockage, effacer le cache + effacer les données) ?

Merci pour la réponse rapide.
J’essaye tout de suite.

Dans l’ordre :

  1. suppression des données d’appli incluant le cache puis relance de l’appli : echec de connection « migration »

puis

  1. suppression des données incluant le cache, désinstallation de l’appli, reboot du téléphone et enfin réinstallation de l’appli : même résultat, je suis bloqué à la connection cause « migration »

Je crains de devoir désinstaller le plugin ?..

avant ça on a 2 autres tests à faire :slight_smile:

un simple : peux tu redémarrer ton jeedom ?

Fait, même réponse de l’appli.

:thinking: :thinking:

peux-tu :

  1. exporter la configuration de ton équipement (bouton exporter)
  2. créer un nouvel équipement vierge
  3. importer la configuration (de 1.) sur ce nouvel équipement
  4. sauvegarder l’équipemnt, regénérer un QRCode et essayer de te connecter sur l’appli à ce nouvel équipement.

J’ai créé un équipement « essai », j’avais déjà sauvegardé la configuration en cas de réinstallation.
j’ai importé la conf de mon équipement malade sur « essai » et essayé de me connecter via le QRCode.
Toujours le même résultat :worried:

reste plus qu’à jeter le téléphone par la fenêtre !.. :slight_smile:

sur la page de connexion de l’appli, on est bien d’accord c’est bien indiqué Version de l'application : 0.20.0 ?

et sur la page de configuration du plugin, tu peux faire un screenshot de la partie haut/gauche stp ?

oui 0.20.0 et Capture d’écran 2021-04-23 153838

donc version stable en 0.20

l’apk a bien été installée depuis le Play Store ?

oui, stable 0.20.0 et appli installée depuis le Play Store

bon bon bon … :thinking:

dans les logs pas d’info particulière !?

Capture d’écran 2021-04-23 154716

ohh ba ya pleins de choses pas belle la dedans !

sur ton équipement : aller dans l’assistant de configuration, et simplement faire un sauvegarder.
puis retenter la connexion ?

Yesss, trop fort ! ça marche. :grinning:

MERCI

on aurait du commencer par les logs ! :slight_smile:

du coup tu peux refaire la meme manip sur tes autres équipements, et supprimer ton ‹ essaie › :wink:

je vais ajouter un autre petit truc pour éviter de retomber dans ton cas !

Encore merci pour la réactivité et le suivi.

ya pas de quoi !
pense au bouton ‹ solution › ! :wink: