Problème crons

Tags: #<Tag:0x00007fcba662e9d0>

Bonjour
Je ne sais pas vous mais la dernière mise à jour a l’air de bloquer les crons des autres plugin et le scan ne fonctionne plus :face_with_raised_eyebrow:

Cordialement

Même constat mes script http H.S.
j’ai désactiver le plugin en attendant !

Etrange ? Je n’ai pas ce problème de mon côté ?
Vous avez combien de périphériques sur votre réseau ?
Pouvez-vous m’en dire plus ?

Actif > 50

Une trentaine
De plus, je peux pas supprimer les vieux périphériques dans « non enregistrés »
Le plugin bloque par exemple les remontés de ma chatières sureflap
Voici un bout de log en debug

[2021-01-12 19:28:07][DEBUG] : -------------------------------------
[2021-01-12 19:28:07][DEBUG] : CRON :. START
[2021-01-12 19:28:07][DEBUG] : -------------------------------------
[2021-01-12 19:28:07][DEBUG] : cron :. Configuration Minute : 1
[2021-01-12 19:28:07][DEBUG] : ////////////////////////////////////////////////////////////////////
[2021-01-12 19:28:07][DEBUG] : syncScanIp :. Lancement du scan du réseau
[2021-01-12 19:28:07][INFO] : Incident de mise à jour : Synchronisation annulée car les données ne sont pas au format de la version installée. Allez dans la configuration du plugin et activez le mode debug pour corriger le problème.

Bon courage

Beau réseau :laughing:

@zeit Au passage de la version 1 à 1.1 il y a eu une migration des données.

[2021-01-12 19:28:07][INFO] : Incident de mise à jour : Synchronisation annulée car les données ne sont pas au format de la version installée. Allez dans la configuration du plugin et activez le mode debug pour corriger le problème.

Et là, ça ne s’est pas bien déroulé dans ton cas.
Il faut passer en mode debug sur la partie configuration et voir ce qui ne va pas.
Un bouton permettant de réparer le problème devrait apparaitre s’il y a un souci.

Capture d’écran 2021-01-13 à 09.20.35

@olive as-tu le même log ?

Je sais pas, pas regarder j’ai désactiver le plugin car il était dans ma prod il faut que je le passe dans une machine de test …

a suivre

1 J'aime

Voici la le mode debug
image
Malgré la tentative de correction de debug : pas mieux
2021-01-13 21:37:52][INFO] : > Mise à jour manuelle :. Démarrage v1.1.1
[2021-01-13 21:37:52][INFO] : > Désactivation du CRON
[2021-01-13 21:37:52][DEBUG] : getJson :. Lancement
[2021-01-13 21:37:52][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/commentMac.json
[2021-01-13 21:37:52][DEBUG] : getJson :. Lancement
[2021-01-13 21:37:52][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/equipements.json
[2021-01-13 21:37:52][INFO] : > Mise à jour des équipements
[2021-01-13 21:37:52][INFO] : > Réactivation du CRON
[2021-01-13 21:37:52][INFO] : > Mise à jour manuelle :. Fin v1.1.1
[2021-01-13 21:37:52][INFO] : --------------------------------------------
[2021-01-13 21:38:14][DEBUG] : getJson :. Lancement
[2021-01-13 21:38:14][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/equipements.json
[2021-01-13 21:38:21][DEBUG] : getJson :. Lancement
[2021-01-13 21:38:21][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/commentMac.json
[2021-01-13 21:38:21][DEBUG] : getJson :. Lancement
[2021-01-13 21:38:21][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/equipements.json
[2021-01-13 21:38:21][DEBUG] : getJson :. Lancement
[2021-01-13 21:38:21][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/commentMac.json
[2021-01-13 21:38:21][DEBUG] : getJson :. Lancement
[2021-01-13 21:38:21][DEBUG] : getJson :. /var/www/html/plugins/scan_ip/core/class/…/…/…/…/plugins/scan_ip/data/json/equipements.json
[2021-01-13 21:38:23][DEBUG] : printInputSubConfig :. Lancement
[2021-01-13 21:38:23][DEBUG] : scanSubReseau :. Lancement
[2021-01-13 21:38:23][DEBUG] : getIpRoute :. Lancement
[2021-01-13 21:39:13][DEBUG] : -------------------------------------
[2021-01-13 21:39:13][DEBUG] : CRON :. START
[2021-01-13 21:39:13][DEBUG] : -------------------------------------
[2021-01-13 21:39:13][DEBUG] : cron :. Configuration Minute : 1
[2021-01-13 21:39:13][DEBUG] : ////////////////////////////////////////////////////////////////////
[2021-01-13 21:39:13][DEBUG] : syncScanIp :. Lancement du scan du réseau
[2021-01-13 21:39:13][INFO] : Incident de mise à jour : Synchronisation annulée car les données ne sont pas au format de la version installée. Allez dans la configuration du plugin et activez le mode debug pour corriger le problème.

:upside_down_face:

C’est mieux. A priori, il y a un ou plusieurs équipements qui n’ont pas pu se mettre à jour.
Les Json sont bons mais ça bloque sur les équipements.
A priori aucun de tes équipements ne s’est mis à jour … :thinking:
Je ne sais pas pourquoi. Mais, malheureusement, le plus simple est de les supprimer et de les recréer.
Il ne devrait plus y avoir de problème sur les prochaines mises à jour.
Au passage de la v1 à la v1.1 les adresses MAC sont conservées différemments (pour gérer les changements d’adresse MAC avec les répéteurs) mais ça ne devrait plus arriver.

J’ai supprimé un périphérique non activé et maintenant tout est au vert :grin:
J’attends pour voir si tout va bien :crossed_fingers:

1 J'aime

Il suffit, en mode debug, de cliquer sur l’icone debug pour voir les retours de scans et autres. Mais si tout est au vert c’est un bon point.

Apparemment tout fonctionne :cowboy_hat_face:
plus de message d’erreur, les scans, les autres crons :partying_face:
J’espère que ca va résoudre les problèmes d’olive
Merci pour ton/votre aide

1 J'aime