Plugin wes

Tags: #<Tag:0x00007f282d565098>

bonjour je viens de mettre a jour mon WES (passe en version 0.83HB03) j’utilise sur jeedom le plugin wes en version 2.0 jusque la j’avais un scenario qui me recuperait la coleur du lendemain et m’envoyais un sms.
depuis la mise a jour du wes il m’envoie a chaque fois la couleur bleu.
avez vous une idee?
dans quel fichier le plugin va t il chercher les infos?

merci

bonsoir,
personne n’utilise ce plugin?

bonjour,
j’ai suprime le plugin et reinstalle impossible d’etablir la conection pourtant quand je clique sur la petite case de configuation j’accede bien a la page de mon wes !!
qui utilise ce plugin ?

merci

Salut,
moi mise à jour hier sans regarder car avec toute les MAJ de doc en ce moment je fait pas trop attention

ben du coup dashboard casser
équipement existant mais qui apparaît pas dans le plugin
des class qui existe pu

le plugin semble marche après une configuration mais pas de change log
on te prévient pas
doc qui renvoi chez nextdom…

ben je vais retourner à mon ancien système en script je pense cela est plus fiable

Bonne journée

Bonjour,
@Alexandre des informations sur cette MAJ de plugin?

Merci

C’est de la bêta on est en train de le finir pour le passer en stable et en officiel

C’est une bonne nouvelle ça :slight_smile:

J’ai regardé rapidement. Si je comprend bien, refonte du plugin et adaptation pour la V4, c’est bien çà ?

Mais comme on en veut toujours plus :smiley: est ce que l’intégration de nouvelles fonctionnalités comme les switchs virtuels et les variables sont-elles prévues ?

Si besoin de faire des tests, je suis dispo.

En tout cas, merci pour cette mise à jour qui arrive :+1:

Bonjour je suis désolé mais la nouvelle version du plugin Wes ne fonctionne pas . Il ne propose pas de mettre adresse IP du Wes ? Est ce que ça vient de mon serveur ?

Bonsoir,

Il y a quelques soucis avec la dernière version pour ceux faisant une mise à jour depuis l’ancienne version. Cela devrait être corriger rapidement. Pour une nouvelle installation, il ne devrait pas y avoir de soucis.

Afin de pouvoir renseigner l’adresse IP, il faut d’abord compléter le « Dossier du WES » avec « general » puis sauvegarder l’équipement.

Merci Beaucoup ça fonctionne mieux mais maintenant le wes ne répond pas . Je suis en V0.83H bêta . Est ce que je dois changer de version ?

Bonjour,
Pour info, j’ai testé plusieurs versions du plugin qui n’ont jamais fonctionné que ce soit en version 3 ou 4 de Jeedom.
J’ai donc créé des scripts pour extraire les données qui m’intéressent du fichier data.cgx du WES et cela fonctionne parfaitement depuis plus de 6 mois.
@

J’ai poussé un PR sur la version beta pour corriger. Je vous conseille de patienter avant de mettre à jour le plugin en attendant que Jeedom valide le PR.

Ok Oui beaucoup On attend

Bonjour désolé mais ça ne fonctionne toujours pas . J’ai le massage d’erreur le serveur ne répond pas .

Bonjour,

Peux-tu faire une capture d’écran de la page du WES ? Les login/password renseignés sur la page du WES sont-ils les bons ?

Est-ce que tu arrives bien à accéder à la page « data.cgx » de ton WES en dehors de Jeedom : http://IP_WES/data.cgx ?

Oui les mot de passe sont les bon
image
image

Voici les pages demandées Merci beaucoup pour votre aide .

D’après ta capture d’écran et l’erreur, le fichier data.cgx ne semble pas correct ce qui expliquerait le message d’erreur dans Jeedom car celui ci se base sur l’accès au fichier data.cgx pour déterminer l’état du WES

Il devrait ressembler à çà : https://community.jeedom.com/uploads/default/original/3X/3/f/3f6c1d2fdd812aefefdf3c4ad39babb1cf0be6ea.jpeg

Ton WES a-t-il été livré dans cette version (v0.83H B03) ou bien l’as-tu mis à jour ?

Ton problème ressemble à celui-ci : Mise à jour 0.83H beta03

Bonjour, je viens de passer en v083H de aout 2019.

Tout semble bon (j’attend qu’enedis me passe en « standard »)

Mais lorsque j’ouvre le fichier data.cgx, j’ai l’erreur suivante:
<h3>This page contains the following errors:</h3>
<div style= »font-family: monospace; font-size: 12px; »>error on line 1 at column 437: Encoding error</div>
<h3>Below is a rendering of the page up to the first error.</h3>
12/04/2020<time>14:19</time>V0.83H B03HC..25H. Creuses0023200006060600

Et la solution semble être ici