Plugin Sonoff pulse et durée en paramètre non prise en compte

Tags: #<Tag:0x00007f38560ae1d8>

Bonjour à tous,

Merci @sigalou pour ce plugin que je viens de mettre en place avec des Sonoff mini !!!

J’ai une petit question sur la commande « pulse ON », quelque soit la durée indiquée en paramètre elle n’a pas l’air d’être transmise. En lecture le paramètre « Tempo de la fonction pulse » reste à 1000ms…

Je suis le seul à avoir se problème ?

En regardant un peu les logs je vois passer ça :
http://192.168.x.x:8081/zeroconf/pulse {« deviceid »:« xxxxxx »,« data »:{« pulse »:« on »}}

J’ai l’impression qu’il manque un truc du genre { « deviceid »: « xxxx », « data »: {« pulse »: « on », « pulseWidth »: YYYYY} } avec le pulseWidth de renseigné avec la valeur du paramètre de durée ?

En tout cas ça n’enlève rien au plugin qui est efficace pour le reste !

Ludomo

Plugin installé en stable 2020-03-29 09:10:39

Salut @Ludomo

Bien vu, je regarde et fais quelques tests et te dis

Oui, il y a un souci, je suis surpris, j’avais fait cette fonction, surement une erreur de manip, je reprends.

@Ludomo
J’ai fait une petite correction, si tu veux bien tester, tu peux mettre la mise à jour, dis moi.
Merci de l’avoir vu

@sigalou le module refuse le paramètre visiblement : erreur 400

[2020-05-09 22:53:45][INFO] : ║ ════envoi══> http://192.168.xx.xx:8081/zeroconf/pulse {« deviceid »:« 0modifié0 »,« data »:{« pulse »:« on »,« pulseWidth »:600}}
[2020-05-09 22:53:45][INFO] : ║ <══réponse═ {« seq »:46,« error »:400}

Edit: ça ne semble pas être un problème de commande mais plutôt de valeur possible…
J’ai réussis un 1500 et un 2000 par exemple… mais pas un 500

Required when « pulse » is on, pulse time length, positive integer, ms, only supports multiples of 500 in range of 500~36000000

je pense que tu dois avoir un >500 au lieu d’un >= 500 c’est pour ça que je fait avoir lol En plus il faut que ça doit un multiple de 500… Peut être compléter l’information dans l’action Active le mode Pulse (et fixe le nb de ms en paramètre)+multiple de 500 ?

Tu peux peut être intégrer un contrôle du genre if($parameter % 500 == 0)`? pour vérifier si c’est un multiple de 500 ?

ludomo

1 J'aime

Exact, bien vu.
Ma première idée était de mettre le paramètre en seconde et de le x1000 au moment de l’envoi mais comme c’est un pas de 500, j’ai reculé.
Tu as raison >500 n’était pas bon, je m’étais dit que le minimum était 1000 et plus tard, aux tests, je n’avais pas testé 500 en me disant que le minimum était 1000.

Je trouve l’idée extra, je prends, c’est changé.

Donc, corrigé, testé, ça fonctionne donc 500.
Je pousse la mise à jour. Merci pour ton aide.

Mise à jour installée testée et je confirme que ça fonctionne bien !

Merci à toi @sigalou encore une fois pour le suivi de tes plugins ! écoute, recherche, correctifs, rapidité ! :clap:

Un dernier point peut être pour éviter les erreurs entre la chaise et le clavier, comme j’ai pu le faire au début, peut être ajouter un truc sur le descriptif de la commande pour donner l’information du multiple de 500 à l’utilisateur ?

image

Au passage je remercie aussi @juandelavega pour son idée d’utiliser un Sonoff mini sur un carillon et son post détaillé ! :+1:

ludomo

Bonne idée, je vais l’ajouter

Oui, vu, au top ce tuto

Je viens de repousser une mise à jour avec l’info pour le multiple de 500 (pour les prochains devices).
J’ai corrigé le pulse?command=off qui se mettait en erreur, ce devrait être bon.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.