Plugin SMS - Clé USB 3G Huawai E3531i-2

Tags: #<Tag:0x00007fcbbb936370>

Bonjour @akenad.

voici le résultat, toujours rien :unamused:

pi@jeedom:/etc/usb_modeswitch.d $ ls
12d1:157d
pi@jeedom:/etc/usb_modeswitch.d $ cat 12d1:157d
# Huawei E3531
TargetVendor=0x12d1
TargetProduct=0x157d
MessageContent="55534243123456780000000000000011062000000100000000000000000000"
pi@jeedom:/etc/usb_modeswitch.d $
pi@jeedom:/etc/usb_modeswitch.d $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 001 Device 008: ID 12d1:157d Huawei Technologies Co., Ltd.
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@jeedom:/etc/usb_modeswitch.d $ dmesg | grep USB
[    0.400149] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
[    0.403566] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 4.19
[    0.403600] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.404191] hub 1-0:1.0: USB hub found
[    0.404796] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    0.404833] xhci_hcd 0000:01:00.0: Host supports USB 3.0 SuperSpeed
[    0.405210] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 4.19
[    0.405243] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.405804] hub 2-0:1.0: USB hub found
[    0.414751] usbhid: USB HID core driver
[    0.768238] usb 1-1: new high-speed USB device number 2 using xhci_hcd
[    0.950876] usb 1-1: New USB device found, idVendor=2109, idProduct=3431, bcdDevice= 4.21
[    0.950914] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    0.950941] usb 1-1: Product: USB2.0 Hub
[    0.952625] hub 1-1:1.0: USB hub found
[    1.288255] usb 1-1.4: new high-speed USB device number 3 using xhci_hcd
[    1.420714] usb 1-1.4: New USB device found, idVendor=05e3, idProduct=0610, bcdDevice=92.24
[    1.420772] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    1.420816] usb 1-1.4: Product: USB2.0 Hub
[    1.423206] hub 1-1.4:1.0: USB hub found
[    1.748233] usb 1-1.4.1: new full-speed USB device number 4 using xhci_hcd
[    1.885281] usb 1-1.4.1: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[    1.885321] usb 1-1.4.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.338248] usb 1-1.4.4: new high-speed USB device number 6 using xhci_hcd
[    3.469673] usb 1-1.4.4: New USB device found, idVendor=0bda, idProduct=8153, bcdDevice=30.00
[    3.469690] usb 1-1.4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[    3.469703] usb 1-1.4.4: Product: USB 10/100/1000 LAN
[    3.578816] usb 1-1.4.4: reset high-speed USB device number 6 using xhci_hcd
[    4.386194] cdc_acm 1-1.4.1:1.0: ttyACM0: USB ACM device
[    4.387325] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[    5.798279] usb 1-1.4.3: new high-speed USB device number 7 using xhci_hcd
[    5.930398] usb 1-1.4.3: New USB device found, idVendor=12d1, idProduct=157d, bcdDevice= 1.02
[    5.930417] usb 1-1.4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    5.940389] usb-storage 1-1.4.3:1.0: USB Mass Storage device detected
[    6.991257] usb-storage 1-1.4.3:2.2: USB Mass Storage device detected
[    7.282751] usb 1-1.4.3: USB disconnect, device number 7
[   12.438234] usb 1-1.4.3: new high-speed USB device number 8 using xhci_hcd
[   12.570213] usb 1-1.4.3: New USB device found, idVendor=12d1, idProduct=157d, bcdDevice= 1.02
[   12.570227] usb 1-1.4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   12.574666] usb-storage 1-1.4.3:1.0: USB Mass Storage device detected
pi@jeedom:/etc/usb_modeswitch.d $

Est que tu peux voir si mon fichier usb_modeswhich.conf est correct ?

pi@jeedom:/etc/usb_modeswitch.d $ cat /etc/usb_modeswitch.conf
# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# Evaluated by the wrapper script /usr/sbin/usb_modeswitch_dispatcher
#
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0

# Disable check for MBIM module presence and configuration globally (to aid
# special embedded environments). Available as per-device parameter
# 'NoMBIMCheck'

DisableMBIMGlobal=0

# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" and probably others

EnableLogging=0

# Optional increase of "delay_use" for the usb-storage driver; there are hints
# that a recent kernel default change to 1 sec. may lead to problems, particu-
# larly with USB 3.0 ports. Set this to at least 3 (seconds) in that case.
# Does nothing if the current system value is same or higher

#SetStorageDelay=4

# If the configuration for your Huawei modem uses the standard switching method,
# you can globally set an alternative method here which provides a different mode:
# either plain serial PPP (for older modems) or NCM which integrates nicely
# with recent Linux distributions, possibly avoiding configuration through a
# modem built-in web page. All other modems are not affected.
# Available as per-device parameter 'AltHuaweiMode'

HuaweiAltModeGlobal=0

le fichier /etc/usb_modeswitch.conf est par défaut, il n’est pas nécessaire de le modifier.
par contre ce qui est troublant c’est que dans ton premier post tu fournissait un lsusb :

12d1:14dc Huawei Technologies Co., Ltd. E33372 LTE/UMTS/GSM HiLink Modem/Networkcard

alors que je ne vois pas apparaitre 12d1:14dc avec dmesg | grep USB.

je te propose de repartir du début :
-supprimer bien tous les fichiers dans /etc/usb_modeswitch.d/
-enlever toutes les clés du Pi4
-rebooter
-insérer la E3531
-faire un lsusb et un dmesg | grep USB
pour observer l’état initial.

akenad :slight_smile:

Voici le résultat

pi@jeedom:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 12d1:14dc Huawei Technologies Co., Ltd. E33372 LTE/UMTS/G                                     SM HiLink Modem/Networkcard
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@jeedom:~ $ dmesg | grep USB
[    0.390222] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
[    0.393674] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 4.19
[    0.393708] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.394307] hub 1-0:1.0: USB hub found
[    0.394915] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    0.394952] xhci_hcd 0000:01:00.0: Host supports USB 3.0 SuperSpeed
[    0.395327] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 4.19
[    0.395359] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.395919] hub 2-0:1.0: USB hub found
[    0.404856] usbhid: USB HID core driver
[    0.758303] usb 1-1: new high-speed USB device number 2 using xhci_hcd
[    0.940950] usb 1-1: New USB device found, idVendor=2109, idProduct=3431, bcdDevice= 4.21
[    0.940990] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    0.941016] usb 1-1: Product: USB2.0 Hub
[    0.942708] hub 1-1:1.0: USB hub found
[    5.808384] usb 1-1.3: new high-speed USB device number 3 using xhci_hcd
[    5.960135] usb 1-1.3: New USB device found, idVendor=12d1, idProduct=157d, bcdDevice= 1.02
[    5.960157] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    5.984974] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[    6.989838] usb 1-1.3: USB disconnect, device number 3
[    8.368282] usb 1-1.3: new high-speed USB device number 4 using xhci_hcd
[    8.499708] usb 1-1.3: New USB device found, idVendor=12d1, idProduct=14dc, bcdDevice= 1.02
[    8.499724] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    8.587393] usb-storage 1-1.3:1.2: USB Mass Storage device detected

pour faire apparaître le 12d1:14dc, j’ai du mettre DisableMBIMGlobal=1 au lieur de 0

je t’avais dis de ne pas modifier /etc/usb_modeswitch.conf

peux tu remettre /etc/usb_modeswitch.conf comme au début

et repartir du début

akenad :slight_smile:

Je crois que le DisableMBIMGlobal=1 est celui par défaut. Tu peux vérifier chez toi STP ? Car j’avais touché cela il y a quelques semaines lors de la migration vers le rpi4 quand mon ancien d’ongle ne marchait pas.
Sinon je recommence avec le DisableMBIMGlobal=0. Pour être sûr.
Je t’envoie le résultat ce soir vers 22h car je ne suis pas chez moi a l’instant.

tu m’as déjà listé un /etc/usb_modeswitch.conf en me demandant si c’était correct. j’ai t’ai répondu qu’il était par défaut et qu’il n’était pas nécessaire de le modifier.
autrement dit j’ai le même contenu, c’est le fichier initial non modifié, celui que tu m’as indiqué plus haut
ou il y avait DisableMBIMGlobal=0

tu es sûr que tu es entrain d’utiliser une E3531i-2, car moi j’en ai 2 et
au départ c’est du 12d1:1f01 et non pas 12d1:157d

est-ce que tu as un Hub auto alimenté sur ton Pi4 ?
comme ici : [RTEX] RPi4B - Raspbian Buster Lite - USB SSD - Jeedom V4

il y a un exemple ici qui parle d’une E3531 avec 12d1:157d : https://community.jeedom.com/t/20271

akenad :slight_smile:

Ok merci, je vais réessayer tout à l’heure avec le =0

oui c’est bien une E3531i-2
Je viens de faire ceci :

  • enlever toutes les clé USB du raspberry
  • remise du DisableBIMGlobl=0
  • redemarrage pi
  • mise de la clé 3G
  • lsusb :
pi@jeedom:/etc $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 010: ID 12d1:157d Huawei Technologies Co., Ltd.
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • dmesg | grep usb :
[10621.350281] scsi host0: usb-storage 1-1.3:1.0
[10622.327343] usb-storage 1-1.3:2.2: USB Mass Storage device detected
[10622.329454] scsi host0: usb-storage 1-1.3:2.2
[10622.387454] usb 1-1.3: USB disconnect, device number 9
[10627.685833] usb 1-1.3: new high-speed USB device number 10 using xhci_hcd
[10627.817569] usb 1-1.3: New USB device found, idVendor=12d1, idProduct=157d, bcdDevice= 1.02
[10627.817577] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10627.817582] usb 1-1.3: Product: HUAWEI Mobile
[10627.817587] usb 1-1.3: Manufacturer: HUAWEI
[10627.817592] usb 1-1.3: SerialNumber: FFFFFFFFFFFFFFFF
[10627.820717] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[10627.821033] scsi host0: usb-storage 1-1.3:1.0

Toujours pas de ttyUSB !!! c’est curieux.

IMG_20200312_223421

Moi je n’ai pas « O2 prepaid-surfstick » écrit sur la clé.

C’est une clé fournie par l’opérateur O2 et non pas acheté sur un site marchand ?
Le firmware doit etre different.
Je ne recommande pas d’utiliser une clé marque opérateur car elle peut être bridée.

attention c’est
dmesg | grep USB
(avec USB en majuscules et non pas « usb« )

Je te propose de retester la config decrite
dans le lien indiqué précédemment et que tu as déjà essayé au debut mais pas avec le /etc/usb_modeswitch.conf par defaut.

fichier /etc/usb_modeswitch.d/12d1:157d avec pour contenu

# Huawei E3531
DisableSwitching=1
TargetVendor=0x12d1
TargetProduct=0x1001
MessageContent="55534243123456780000000000000011062000000100000000000000000000"
NoDriverLoading=1

akenad :slight_smile:

Est ce que ça peux vraiment venir du hub alimenté ? j’ai essayé avec et sans. Nada !!!
j’ai celui ci : Anker Hub Ultra Fin 4 Ports USB 3.0 https://www.amazon.fr/gp/product/B0192W3HX8/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

mais je ne pense pas que le fait de ne pas pouvoir passer en mode modem avec ttyUSB vienderait du HUB!!!

je l’ai acheté chez amazon https://www.amazon.fr/gp/product/B00HSZEY34/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

J’ai acheté exactement la même clé, j’avais commandé la version blanche à 22€, j’ai reçu la noire à 47€. En commandant la même référence, on n’a pas les mêmes produits, c’est le problème d’Amazon ! Donc pas sûr qu’on ait la même version…

Dans mon cas, il faut créer un fichier nommé 12d1:1f01 avec ça dedans

# Huawei E353 (3.se)

TargetVendor=  0x12d1
TargetProduct= 0x1f01 

MessageContent="55534243123456780000000000000011062000000100000000000000000000"
NoDriverLoading=1

Mais je n’ai pas l’option

DisableSwitching=1

Bonjour @ Domatizer

merci pour la réponse, je vais essayer cela.

tu peux m’envoyer le contenu de ton fichier /etc/usb_modeswitch.conf STP ?

Je n’ai jamais édité ce fichier, le voici

# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# Evaluated by the wrapper script /usr/sbin/usb_modeswitch_dispatcher
#
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0

# Disable check for MBIM module presence and configuration globally (to aid
# special embedded environments). Available as per-device parameter
# 'NoMBIMCheck'

DisableMBIMGlobal=0

# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" and probably others

EnableLogging=0

# Optional increase of "delay_use" for the usb-storage driver; there are hints
# that a recent kernel default change to 1 sec. may lead to problems, particu-
# larly with USB 3.0 ports. Set this to at least 3 (seconds) in that case.
# Does nothing if the current system value is same or higher

#SetStorageDelay=4

# If the configuration for your Huawei modem uses the standard switching method,
# you can globally set an alternative method here which provides a different mode:
# either plain serial PPP (for older modems) or NCM which integrates nicely
# with recent Linux distributions, possibly avoiding configuration through a
# modem built-in web page. All other modems are not affected.
# Available as per-device parameter 'AltHuaweiMode'

HuaweiAltModeGlobal=0

L’option DisableSwitching est bien à 0 et non pas à 1 comme tu avais mis au début.

ok merci je teste

Bon, je n’arrive toujours pas à faire fonctionner ce foutu dongle.

pi@jeedom:/etc/usb_modeswitch.d $ ls
12d1:1f01
pi@jeedom:/etc/usb_modeswitch.d $ cat 12d1:1f01
# Huawei E353 (3.se)

TargetVendor=  0x12d1
TargetProduct= 0x1f01

MessageContent="55534243123456780000000000000011062000000100000000000000000000"
NoDriverLoading=1
pi@jeedom:/etc/usb_modeswitch.d $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 001 Device 008: ID 12d1:157d Huawei Technologies Co., Ltd.
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@jeedom:/etc/usb_modeswitch.d $

j’ai essayé avec /etc/usb_modeswitch.d/12d1:157d sans succès.

Tu n’as pas la même clé que moi.

Tu as essayé les liens de @akenad pour du 12d1:157d ?

Sinon, si tu viens d’acheter la clé, essaie de la renvoyer et d’en demander une autre.

Oui j’ai essayé toutes les recommandations de @akenad que je remercie pour son aide.

Oui je pense que je vais la retourner demain à Amazon et en prendre une autre. à suivre…

Merci encore à tous.