Plugin Prevision meteo ne s'actualise plus

Tags: #<Tag:0x00007f3858318840>

Bonsoir,

Depuis quelques jours, le plugin ne se met plus à jour.

Au moment ou j’écris, « current date » retourne 02/04 au lieu de 05/04.
Il semble que cela vienne de la source https://www.prevision-meteo.ch.
Avez-vous constaté la même chose ?

ZygOm4t1k,
Si tu passes par là :slight_smile:

Merci !

PS : Jeedom v3.

Bonsoir,

Un petit up au cas où…

Salut,

chez moi ça se met à jour. Erreur dans les logs? Le cron est actif?

PS: Je n’ai pas le tag du plugin car pas tout fait dans les normes… Donc rajoute un @ devant le pseudo c’est plus simple pour moi en tout cas

@ZygOm4t1k

Hello,
Des précisions ci-dessous :

Le widget ne se rafraichit plus depuis le 020/4 :

Le cron est OK :

Le log atteste d’un problème depuis le 02/04 :

[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 17:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586185200
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 18:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586188800
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 19:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586192400
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 20:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586196000
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 21:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586199600
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 22:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586203200
[2020-04-02 08:00:29][DEBUG] : date : 06.04.2020 keys 23:00
[2020-04-02 08:00:29][DEBUG] : timestatmp : 1586206800
[2020-04-02 08:00:29][DEBUG] : rain 4 10.8
[2020-04-02 08:00:31][DEBUG] : To html
[2020-04-02 08:05:46][DEBUG] : To html
[2020-04-02 08:16:29][DEBUG] : To html
[2020-04-02 08:16:43][DEBUG] : To html
[2020-04-02 08:18:21][DEBUG] : To html
[2020-04-02 09:11:05][DEBUG] : To html
[2020-04-02 09:23:56][DEBUG] : To html

[2020-04-05 23:09:37][DEBUG] : To html
[2020-04-06 15:01:03][DEBUG] : Droits sudo dossier data
[2020-04-06 15:01:03][DEBUG] : fichier existe pas
[2020-04-06 15:01:03][DEBUG] : rain 0 0
[2020-04-06 15:01:03][DEBUG] : rain 1 0
[2020-04-06 15:01:03][DEBUG] : rain 2 0
[2020-04-06 15:01:03][DEBUG] : rain 3 0
[2020-04-06 15:01:03][DEBUG] : rain 4 0
[2020-04-06 19:23:26][DEBUG] : To html
[2020-04-06 19:23:42][DEBUG] : To html
[2020-04-06 21:26:43][DEBUG] : To html
[2020-04-06 22:00:29][DEBUG] : Droits sudo dossier data
[2020-04-06 22:00:29][DEBUG] : datas = json continue
[2020-04-06 22:00:41][DEBUG] : To html
[2020-04-07 00:00:59][DEBUG] : Droits sudo dossier data
[2020-04-07 00:00:59][DEBUG] : datas = json continue
[2020-04-07 00:00:59][DEBUG] : To html

Je ne comprends pas ce problème de droits soudain.

@ZygOm4t1k je confirme que j’ai un soucis d’actualisation, le log m’indique les ligne suivantes

[2020-05-14 12:01:50][DEBUG] : Droits sudo dossier data
[2020-05-14 12:01:50][DEBUG] : datas = json continue

Les fichiers json ne sont pas mis à jour

EDIT : ou plus exactement on dirait que c’est toutes les 2h

[2020-05-14 12:01:50][DEBUG] : Droits sudo dossier data
[2020-05-14 12:01:50][DEBUG] : datas = json continue
[2020-05-14 14:00:56][DEBUG] : Droits sudo dossier data
[2020-05-14 14:00:56][DEBUG] : datas!= json
[2020-05-14 14:00:58][DEBUG] : date : 14.05.2020 keys 0:00

@ZygOm4t1k
De mon côté, c’est revenu.

Je suis repassé sur PARIS cela a recréé toutes les commandes. Puis j’ai remis ma ville, les commandes se sont actualisées, et tout est rentré dans l’ordre. Curieux, je ne sais pas ce qui s’est passé.

PS : je ne ferme pas le post car @sebfar a toujours son souci.

@+

En fait, j’ai pris un autre plugin car le site remonte des infos toutes les 2h, j’ai vérifié à la génération sur le site. Donc on peut clore merci.

Bonjour,
depuis cette nuit, le site www.prevision-meteo.ch ne répond plus…
Du coup mon design qui l’utilise sur ma tablette se met en chargement permanent, empêchant l’affichage du design. Est-il possible de remédier à cela ? ou le prévoir dans une évolution ?

le site est down mais n’entraîne pas d’erreur d’affichage.

Tu as mis quoi sur le design?

Bonjour,
j’ai juste ajouté l’équipement « Méteo_MaVille » dans mon design sur ma tablette.
Maintenant c’est revenu à la normal puisque le site n’est plus down.

Bonjour,

est-ce que le lien à copier dans meteoprev est bien celui là? :
https://www.prevision-meteo.ch/meteo/localite/maville

Car ça ne marche pas pour moi.

Merci de votre aide

Bonjour,
Je me permets de relancer le sujet. J’ai installé le plugin hier et malgré le cronHourly, ça ne se met pas à jour. J’ai à peu près les mêmes logs que ceux postés par @dvb.
Est ce qu’il serait possible de rajouter une commande Refresh ?

Merci

Bonjour,

Depuis 1 mois environ, il n’y plus d’actualisation automatique des conditions.
La solution que j’ai trouvé c’est d’aller sur l’équipement et de re-sauvegarder la configuration et après ça re-fonctionne correctement durant 1 voir 2 jour. vraiment bizarre. marche.
Si vous avez une idée du problème ?

Merci