Plugin GSH et 'google home'

Tags: #<Tag:0x00007fcbb9fc70b0>

Bonjour,
J’ai configurer dans jeedom Smarthome
j’ai des équipements cochés qui sont vert

mon problème avec le plugin gsh
Se situe dans la mise en œuvre de celui ci
Dans google home je fais les actions suivantes

  • configurer un appareil
    Fonctionne avec google
    Choix --> Jeedom Smarthome
    message ‹ Jeedom Smarthome est associé ›
    ‹ Une erreur c’est produite, veuillez réasseyer ›

Je précise que mon Jeedom est accessible en https://xxxxxxx.fr

Je tourne en rond et ne sais plus quoi faire

Hello,

Si jeedom est déjà associé au compte et à google home (ce que semble indiquer le message)… Pourquoi refaire la chose ?

Parce que je ne vois aucun de mes équipements dans google home !
je suppose que le sevice et l’association n’esp pas bonne

C’est contradictoire avec la mention suivante

Bref… Même punition que pour les autres utilisateurs : copie d’écran, log, détails, précision sur le matériel, les versions
Sinon pas moyen de deviner

Je suis sur Raspberry pi 4B+
Version buster
OS Mis a jour

image

image

gsh.txt (350 Octets)
gsh (2).txt (4,2 Ko)
gsh.txt (350 Octets)

Voila

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed

Il faut relancer les dépendances, là c’est pas installé correctement

Voila c’est fait mais j’ai pas l’impression que cela est mieux

gsh_update.txt (4,2 Ko)

Bon a priori npm est bien installé en version 12

/var/www/html/plugins/gsh/core/class/../../resources/install_apt.sh: line 10: ${PROGRESS_FILE}: ambiguous redirect
Version actuelle : 12
Ok, version suffisante
Reading package lists..

Par contre les modules ne le sont toujours pas.

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
......

Potentiellement j’aurais tendance à tester les préconisations du message :

audited 73 packages in 3.039s
found 1 low severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details

Mais ça garantie rien

Et il manque nodejs
il faudrait tenter ça

sudo apt-get install -y nodejs

Voila ce que cela donne:

pi@RaspiProd:~ $ sudo apt-get install -y nodejs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
nodejs est déjà la version la plus récente (12.20.0-1nodesource1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 127 non mis à jour.

Autrement

pi@RaspiProd:~ $ sudo npm audit fix
npm ERR! code EAUDITNOPJSON
npm ERR! audit No package.json found: Cannot audit a project without a package.json

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-12-08T14_20_37_350Z-debug.log

Les derniers logsgshd.txt (72 Octets) gsh_update.txt (7,8 Ko) gsh.txt (350 Octets)

Je veux bien croire que le probleme se situe entre le dossier de la chaise et l’écran mais j’en arrive quand même à avoir des doutes

ça c’est parce que la commande est pas lancée au bon endroit.
Peut-être là

/var/www/html/plugins/gsh/resources/gshd/

ok c’est bien ca
voila la réponses du system

pi@RaspiProd:~ $ cd /var/www/html/plugins/gsh/resources/gshd/

sudo npm audit fix

npm WARN ts-node@8.2.0 requires a peer of typescript@>=2.0 but none is installed. You must install peer dependencies yourself.

up to date in 2.166s
fixed 0 of 0 vulnerabilities in 73 scanned packages

Pour faire le point
je m’aperçois si j’ai bien compris que le probleme est le suivant:
ma version de nodejs est 12.20.0
ma version de npn est 6.14.89
Manifestement il est impossible d’installer correctement c’est 2 packages
il faudrait installer toutes les dépendances a la main
Question est ce que ce sont les bonnes versions ou les bon paquets
comment revenir a une installation de ceux ci correcte
Je n’arrive pas à croire que je suis le seul dans ce cas la
Je précise que je suis dans une installation standard, à jour, sans modification particulière
Que faire ? pour revenir à la normale
Est ce que vous ne pensez pas que les developpeurs du plugin pourrait nous aider ou nous donner des preconisations sur les versions prerequises ?

Hello,

niveau version, c’est pas déconnant

root@jeedom:/# node -v
v12.20.0
root@jeedom:/# npm version
{
  npm: '6.14.8',
  ares: '1.16.1',
  brotli: '1.0.9',
  cldr: '37.0',
  http_parser: '2.9.3',
  icu: '67.1',
  llhttp: '2.1.3',
  modules: '72',
  napi: '7',
  nghttp2: '1.41.0',
  node: '12.20.0',
  openssl: '1.1.1g',
  tz: '2019c',
  unicode: '13.0',
  uv: '1.40.0',
  v8: '7.8.279.23-node.45',
  zlib: '1.2.11'
}

Bonjour,
J’ai passé pas mal de temps a essayer de remettre les paquets qui posent problème dans les logs
sans vraiment un grand succès.
j’ai même du casser quelque chose
je pense que j’ai lance des commande de nettoyage des paquets
jeedom ne demare plus j’ai ce message dans mon naviguateur
SQLSTATE[HY000] [2002] No such file or directory
Que faire ?
Relancer l’installation de jeedom ?

Tu peux essayer de restaurer la dernière sauvegarde. Là la base semble touchée

J’ai meme plus l’interface graphique de jeedom

Sans la base, le reste ne fonctionne pas

Bonjour,
Cela progresse
mais dans le dernier log je ne sais pas traiter les dernières erreurs !
gsh_update.txt (1,4 Ko)

Bonjour,
je pense que je vais clore le sujet
La solution à mon probleme a été la suivante:
J’ai réinstallé complètement le système
puis Jeedom puis restauration sauvegarde antérieure de Jeedom

En fait le probleme venais d’une impossibilité de mettre à jour certains packages de l’os
Ce que je ne comprends toujours pas

En tous cas merci a tous pour votre temps passé a me fournir vos conseils

C’est dommage de ne pas avoir résolu la racine du problème car j’ai le même message d’erreur :

Depends: node-write-file-atomic (>= 2.3~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
npm WARN ts-node@8.2.0 requires a peer of typescript@>=2.0 but none is installed. You must install peer dependencies yourself.
audited 73 packages in 2.129s
found 0 vulnerabilities
********************************************************
*             Installation terminée                    *
********************************************************

edit solution:

sudo -su root
cd /var/www/html/plugins/gsh/resources/gshd
npm install typescript@2.0

puis relance de l’installation des dépendances.