Peugeot e-208 My Peugeot

Bonsoir @laguinch,
Je n’ai pas eu ce problème sur mes 2 plateformes de test.
Tu utilises quel matériel pour Jeedom ?

Tu pourrais me confirmer également que tu as ce messages lorsque tu ouvres le panel, ou bien que tu cliques sur l’image de la voiture dans le widget ? (ce qui a pour effet d’ouvrir le panel).

Quand au widget, il est correctement affiché chez toi, avec les infos mises à jour ?

@laguinch,
Tu pourras essayer la dernière mise à jour ?
Merci.
Lelas

Bonsoir @lelas,
je viens d’installer la mise à jour sur ma smart qui est en V4.
A priori tout fonctionne sauf que j’ai ce message :

Fichier Ligne Message
http://10.0.0.30/index.php?v=d&p=dashboard&object_id=20 14 ReferenceError: Can’t find variable: L

je ne sais pas si ca vient du plugin

Bonsoir @laguinch,

Ok, bonne nouvelle.
Le message vient bien du plugin. Je n’ai pas encore réussi à le corriger, mais il n’est pas gênant. On peut vivre avec le temps que je trouve.
Il empêche l’affichage de la carte avec le point GPS dans le widget lors du rafraichissement de la page dashboard, mais on le récupère en faisant un refresh du widget (flèches image )

1 J'aime

bonjour @lelas, tu me confirmes que ton plugin ne fonctionne que pour les vehicules hybride ?

j’ai un 3008 (connecté donc via mypeugeot, dispo sur mon compte mypeugeot / sur l’appli) mais j’ai les erreurs :
[2020-12-10 09:39:58][INFO] : postSave: success=KO
[2020-12-10 09:39:58][INFO] : Ce vehicule n’est pas connecté: vin=xxx
[2020-12-10 09:40:06][DEBUG] : Mise à jour périodique
[2020-12-10 09:40:06][ERROR] : Erreur sur peugeotcars::pull() : Call to a member function execCmd() on boolean

j’en deduis que malgré sa dispo sur mon compte, ça ne passe pas :wink:

merci pour ton retour

Bonsoir @MonsieurFlal,
Si tu as le message « Ce véhicule n’est pas connecté », cela signifie que son numéro de VIN ne répond pas aux API peugeot que j’ai utilisé.
La voiture pour laquelle j’ai fait les tests est une 208 électrique de génération 2019, mais je ne pense pas que la limitation soit liée au fait que ta voiture n’est pas électrique, mais plutôt à cette génération du véhicule.
De quelle année est ta voiture ?
Quel type d’informations du véhicule sont disponibles sur l’appli Peugeot ?
(Il est possible que ta voiture soit connectée, mais réponde à une autre API de Peugeot.)
Lelas

Merci pour ce retour. Donc à priori pas utilisable pour moi
J’arrive cependant à récupérer quelques infos dans le panel (sûrement pas des infos qui viennent de l’api peut être)

Cest un suv 3008 (thermique) de fin 2018. Je crois avoir vu sur le panel « garantie depuis 30/11/2018 »)
Il n’y a donc pas beaucoup de différence de temps entre nos deux voitures :slight_smile: mais peut être effectivement pas la même api :frowning:

Bonjour @laguinch,
Il semble que pour le moment, tu sois le seul qui ait pu mettre en oeuvre ce plugin.
Tu pourrais nous dire quel est modèle de ta voiture (et année)
Lelas

Bonjour @lelas
e208 fevrier 2020

Pour information, malgrès des messages d’erreur, il y a certaines informations qui remontent sur le panel. pour ma part 2008 thermique 10/2018.
image

bonjour,

je pense qu’on est dans le même cas… mon 3008 (thermique) de novembre 2018 a les mêmes infos qui apparaissent :

  • info véhicule ok, sauf les dernières lignes (LOGICIEL: undefined / Version courante connue: undefined / Version disponible: undefined (datée du undefined) / Taille du fichier: NaN MB)
  • maintenance vehicule affiche bien les infos (avec le kilométrage courants)

par contre, je n’ai pas d’info dans les trajets et l’imagine n’apparait pas à droite dans le panel

ma voiture apparait bien dans mypeugeot
screenshot_18

peut etre que je peux avoir qq part l’api que ma voiture utilise ?
pour aider @lelas ?

Merci pour le plug-in ! Super bien documenté et facile à mettre en œuvre.
Hâte de voir les futurs améliorations !

Ma configuration : Raspberry Pi 2, Jeedom 4.1

image

Cool,
Merci de tester ce plugin, et content de voir qu’il fonctionne bien pour toi.
Il y a également un autre post pour les utilisateurs de ce plugin:

Salut @lelas
Pas de nouvelles bonne nouvelles.
Bon globalement ça fonctionne correctement.

A signaler dans les petits détails :

Tous les jours a minuit maintenance chez Peugeot.

Log
[2021-01-28 00:00:08][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-01-29 00:00:07][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-01-30 00:00:07][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-01-31 00:00:08][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-02-01 00:00:07][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-02-02 00:00:07][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-02-03 00:00:09][ERROR] : Erreur d'accès à l'API pour informations de maintenance
[2021-02-04 00:00:08][ERROR] : Erreur d'accès à l'API pour informations de maintenance

suggestion : filtrer l’erreur a cet heure la …

Et l’erreur de script non pénalisante :

ReferenceError: L is not defined

Voilà bonne journée

Bonjour @olive,
C’est vrai pas de nouvelles.
Je fait une petite pose sur le développement du plugin.
Pas de grandes nouveautés en cours.
J’ai tout de même corrigé les bugs existants, et j’ai ajouté une représentation de l’altitude sur les trajets.
Je mettrait cela dans la prochaine livraison.
Je voulais tout de même ajouter la page statistiques avant de livrer.
A suivre…

Merci de ton retour
Il faut que je regarde toute la partie ou l’on click sur la voiture je sais qu’il y a chez moi des infos qui ne collent pas ( je vais prendre un moment et te remonter les infos de ce coté)

Dans les améliorations j’aimerai bien pour le suivi temps réel un bouton qui ouvre une modale ou un full screen sur la carte :wink:

Humour columbo : C’est ma femme qui va pas être contente … :joy:

Bonjour, Désolé de venir vous importuner, mais aprés l’installation de votre plugin, j’ai l’erreur suivante:
" Erreur sur peugeotcars::pull() : Call to a member function execCmd() on bool ".
J’ai désinstallé et ensuite réinstallé, mais rien n’y fait. Ai-je oublié quelques choses. De plus je n’ai jamais reçu de code par SMS. Bonne journée

Bonsoir @yancelu,

C’est difficile de répondre sur un simple message d’erreur, surtout quand rien ne fonctionne.
Tu as quel type de voiture ?
Tu pourrais m’envoyer en MP le log d’installation des dépendances (« peugeotcars_update »), et le log du plugin (« peugeotcars ») ?

Pour la suite, je te propose de poster sur le sujet ci dessous (il est plus récent que celui-ci):

Lelas