MAJ des dépendances OpenZwave et désactivation du bluetooth embarqué

Tags: #<Tag:0x00007f3861a5eee8>

Bonjour à tous,

Mon installation à base de PI3B, carte SD, raspian stretch, jeedom 3.3.30, rflink et clé zwave aotec ayant crashé il y a 3 mois, j’ai décidé de repartir d’un backup pour réinstaller jeedom un système tout neuf.
Le setup reste le même mais j’ai juste remplacé l’installation sur SD par un disque dur USB pour plus de sécurité.

J’ai réinstallé et mis à jours le raspbian stretch, installé le jeedom en V3, restauré mon backup et j’ai fait la MAJ en 3.3.39 sans problème.

Mon problème concerne la mise à jours des dépendances du plugin openzwave.

En effet, suite à la maj des dépendances, le bluetooth embarqué sur le pi 3B est désactivé et …
j’avoue que je ne trouve pas comment le réactiver afin de pouvoir réutiliser le plugin BLEA avec mes nuts mini…

Avant la MAJ des dépendances openzwave, je vois que le bluetooth embarqué est activé :
pi@raspberrypi:~ $ dmesg | grep -i blue
[ 20.031244] Bluetooth: Core ver 2.22
[ 20.031307] Bluetooth: HCI device and connection manager initialized
[ 20.031321] Bluetooth: HCI socket layer initialized
[ 20.031329] Bluetooth: L2CAP socket layer initialized
[ 20.031352] Bluetooth: SCO socket layer initialized
[ 20.129307] Bluetooth: HCI UART driver ver 2.3
[ 20.129315] Bluetooth: HCI UART protocol H4 registered
[ 20.129391] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 20.129525] Bluetooth: HCI UART protocol Broadcom registered
[ 21.496321] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 21.496329] Bluetooth: BNEP filters: protocol multicast
[ 21.496344] Bluetooth: BNEP socket layer initialized
[ 21.750944] Bluetooth: RFCOMM TTY layer initialized
[ 21.750969] Bluetooth: RFCOMM socket layer initialized
[ 21.750993] Bluetooth: RFCOMM ver 1.11

pi@raspberrypi:~ $ hcitool dev
Devices:
hci0 B8:27:EB:1B:5D:D6

pi@raspberrypi:~ $ sudo bluetoothctl list
[NEW] Controller B8:27:EB:1B:5D:D6 raspberrypi [default]

Avant cela, j’avais fait la même opération de restauration et MAJ sur raspbian Buster et c’est le même résultat (j’avais un doute, je pensais que cela pouvait être lié à l’OS avant de m’apercevoir que c’est la MAJ des dépendances).

Après la MAJ des dépendances, voici le résultat des précédentes commandes :
pi@raspberrypi:~ $ dmesg | grep -i blue ; hcitool dev ; sudo bluetoothctl list
[ 51.662968] Bluetooth: Core ver 2.22
[ 51.663033] Bluetooth: HCI device and connection manager initialized
[ 51.663046] Bluetooth: HCI socket layer initialized
[ 51.663054] Bluetooth: L2CAP socket layer initialized
[ 51.663082] Bluetooth: SCO socket layer initialized
Devices:
Waiting to connect to bluetoothd…

Est-ce que quelqu’un sait comment réactiver le bluetooth embarqué sur PI 3B ??

Merci !

1 J'aime

Salut et bienvenu au club

Commence pas désactiver temporairement BLEA et ZWAVE

Ensuite
sudo systemctl stop bluetooth && sudo systemctl enable bluetooth && sudo systemctl start bluetooth && sudo systemctl stop hciuart && sudo systemctl enable hciuart && sudo systemctl start hciuart && sudo systemctl daemon-reload

C’est un grand classique… Tu va être em***dé à chaque resintallation de jeedom ou des dépendances Zwave

Merci Naboleo ! Problème résolu :slight_smile:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.