Jeedom v4 (Docker Nas) plugin sonos probleme TTS

Tags: #<Tag:0x00007fcbac60ed28> #<Tag:0x00007fcbac60eb48>

Bonjour,

je viens d’installer sur un nas synology la v4 de jeedom sous docker en suivant l’excellent tuto de @Didier3L [Tuto] Installation de Jeedom sur Synology / docker / debian buster / réseau macvlan

Ca fonctionne très bien , niveau réactivité c’est top , seulement voila, j’ai un soucis pour faire parler mon enceinte connectée (SONOS symfonisk ).

En effet , j’ai installé le plugin : Sonos-Controller , comme ceci :
plugin-sonoscontroller

coté Nas j’ai bien créé le repertoire : jeedom/TTS et donné les droits lecture/ecriture à l’utilisateur : « jeedom »

coté TTS je suis sur la config par défaut jeedom :
jeedom-tts

coté log je n’ai aucun log pour le tts et je n’ai rien qui se génére dans le repertoire jeedom/TTS sur mon nas.

y’a t’il une manip à faire en plus pour faire fonctionner le TTS sous docker ?

merci d’avance pour votre aide.

Et c’est bien le dossier jeedom que tu as partagé?

Salut!

Y a pas un paquet spécifique à installer sous linux pour qu’il puisse générer le fichier, il me semble avoir vu un truc comme ça passer

Le TTS ainsi que la lecture des médias ne fonctionnaient pas alors que la communication était bonne (les commandes arrivaient sur le Google Home).
J’ai du installer le paquet ffmpeg via SSH sur ma Debian pour que ça fonctionne :

sudo apt install ffmpeg

Tu veux dire dans le plugin sonos ? oui
j’ai suivi la documentation officiel du plugin : https://doc.jeedom.com/fr_FR/plugins/multimedia/sonos3/

à savoir :
Côté NAS, voici ma config :

  • le dossier jeedom est partagé (j’y accede bien depuis un pc avec l’utilisateur)
  • l’utilisateur jeedom a un accès Lecture/Ecriture (nécessaire pour Jeedom)
  • l’utilisateur sonos a un accès en Lecture seule (nécessaire pour les Sonos)

Côté Plugin Sonos, voici ma config :

  • Partage :
    • Champ 1 : 192.168.0.101 (ip de mon nas)
    • Champ 2 : jeedom/TTS
  • Nom d’utilisateur : jeedom et son mot de passe…​

Côté Bibliothèque Sonos (App iOS)

je vais tester ça en me connectant sur l’instance docker je te tiens au courant de suite :slight_smile:

il est deja installé :frowning:

root@jeedom:/# apt-get install ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ffmpeg is already the newest version (7:4.1.6-1~deb10u1).
The following packages were automatically installed and are no longer required:
  python-bcrypt python-blinker python-fasteners python-idna python-jwt python-lockfile python-monotonic python-nacl python-oauthlib python-openssl python-paramiko python-pexpect
  python-ptyprocess python-pyasn1 python-urllib3
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
root@jeedom:/#

N’utilisant pas le truc, je connais pas trop.
As-tu tenté de mettre à jour linux ?
apt-get update
apt-get upgrade
apt autoremove

Sinon il y a ca aussi à vérifier Important

Il faut ABSOLUEMENT ajouter le partage réseaux dans la bibliothèque du sonos, sinon Jeedom va bien creer le mp3 du tts mais il ne pourra pas etre joué par le Sonos

Tout ca m’a l’air correcte, j’ai le même setup.
pico tts est installé?
ce n’est pas ffmpeg qu’il faut je pense (pas vérifié le code)

quand tu dis « pico tts est installé? » tu parles du plugin jeedom ? ou d’un package linux ?

en faites on est à l’étape d’avant c’est à dire que ça bloque :
soit à la génération du mp3,
soit un probleme d’ecriture lorsqu’il essaye de déposer le fichier mp3 sur le nas

Je me rappel qu’il y a longtemps j’avais eu le même genre de soucis mais c’était avant d’avoir ces configs de tts dans le core donc je ne sais pas si le core se charge d’installer les dépendances correctement.

Mais à l’époque je m’en étais sorti en installant le #plugin-playtts; même sans l’utiliser, juste pour tourner l’install des dépendances qui install correctement ce qu’il faut pour picotts.

je viens de l’installer le plugin playtts :

Début de l'installation
Installation mplayer
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (10.2019051400).
mpg123 is already the newest version (1.25.10-2).
mplayer is already the newest version (2:1.3.0-8+b4).
software-properties-common is already the newest version (0.96.20.2-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Installation PicoTTS
'non-free' distribution component is already enabled for all sources.
'contrib' distribution component is already enabled for all sources.
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
libttspico-utils is already the newest version (1.0+git20130326-9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Ajout de www-data dans le groupe audio
Fin de l'installation

il n’a pas installé de package en plus

Et toujours pas de génération de fichier?

toujours pas de génération de fichier mp3 du moins il n’est pas copié sur le nas.

en attendant je vais verifier que la copie d’un fichier qquelconque fonctionne en ligne de commande et je pense que c’est ça qui bloque :

root@jeedom:/# smbclient //192.168.0.101/jeedom/TTS -c 'put /tmp/voice.wav'

do_connect: Connection to 192.168.0.101 failed (Error NT_STATUS_HOST_UNREACHABLE)

root@jeedom:/#

En faite je viens de comprendre :smile: il ne faut pas mettre l’ip du nas mais l’ip du bridge car on est sous docker (dans mon cas 192.168.0.241) !!!

maintenant j’ai bien mon fichier mp3 qui est sur le nas : Etape 1 ok

jeedom-partage

mais le fichier mp3 n’est pas joué sur l’enceinte

la connexion réseau avec l’enceinte est bonne (ping ok , j’arrive à faire des play/pause depuis le dashbord)

c’est bon j’ai trouvé il faut également mettre la même ip coté application sonos.

Donc si je résume pour les personnes sous docker utilisant le plugin : sonos et qui tombe sur ce topic :

Côté Plugin Sonos, voici la config :

  • Partage :
    • Champ 1 : 192.168.0.241 (ip du bridge docker nas)
    • Champ 2 : jeedom/TTS
  • Nom d’utilisateur : jeedom et son mot de passe…​

Côté Bibliothèque Sonos (App iOS)

pour vérifier la connexion entre votre instance docker et le partage nas :

connectez vous à l’instance docker :

docker exec -it <instanceID> /bin/bash
smbclient //192.168.0.241/jeedom/TTS -U jeedom
Enter WORKGROUP\jeedom's password:

Si l’invite de commande vous propose de saisir le password c’est que la connexion est OK :slight_smile:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.