Issue with user rights

Tags: #<Tag:0x00007fcba67e8c30>

So I have this odd issue. I really created a new user for external access. I was using the regular admin until now, and realized that this was not the best idea… :grin:

I then created my external access user, which was granted « user » status. The problem is that this status does not stay such, and that user always end up with admin rights!!!

I am running the latest stable version (4.1.19) on a Jeedom smart. I tried to see if anybody reported that (on the english and french boards) but did not find anything. Any idea what could be going on here?

Hi,
Would you have a screen of your user settings ?

Are you saying that when you create a user, set it as user in Profile column, it ends up administrator ? After changing the setting, do you save it with top right button ?

Here is an example of admin and user

Untitled-1

Hello,

yes I save after setting the status, yes it goes back to admin. The user under the grey box is supposed to be a user.

Screen Shot 2021-02-07 at 6.47.03 PM

I think I figured out what triggers the change, although I don’t know why it does it. When I log in to the mobile jeedom app with that external account, it seems to change the status to administrator… What log could i check to try to see what is happening?

Wow, never seen that !

I just tried on a 4.1.19, even with some strange characters and space in the user name, can’t manage to reproduce such behavior.

Could you have a look in settings, OS/DB, database administration ?
Just type SELECT * FROM `user` and see in profils column if it is admin or user ? Don’t be shy this is just display command and won’t affect anything :wink:

What you could test:
UPDATE `user` SET `profils`= 'user' WHERE `id` = X where X is the id of your user. And then check in user page if this is just a display problem. But never seen a report on such thing.

Just did more test, no problem here.

it says administrator in the database.

Where should I do the update pat. In the user admnistration? I have a system backup, but I am leary to change anything in there (you know the red box warning and all. :grin:)

It seems that database and display are the same, no problem on this side.

Could you share a screen of analysis/health page ?

Sorry, got stuck in dinner and family time. Here it is. Thanks in advance for you help

Screen Shot 2021-02-07 at 9.33.26 PM

So yeah I just went through the same process. As soon as I access the jeedom via the mobile app with this user, it changes to administrator. This is funky…

Screen Shot 2021-02-07 at 9.41.15 PM Screen Shot 2021-02-07 at 9.40.38 PM

Sorry, a bit late there, will have to try with jeedom app tomorrow.
Just to be sure, you are talking about mobile app (I can try it on iOS), not the webApp ?

Yes the iOS app. I deleted the user and created a new one (with a different name). It seems to behave normally… I’ll see on the long run.

Cheers

Ok, please let us known how it goes.
I will check with the team, maybe someone working on the app will know better than us :beers:

Well it seems stable now… No idea what was going on.

Thanks for your help anyways. :slight_smile: