Impossible d'installer les dépendances pour plug in zwave

Tags: #<Tag:0x00007f282cd3a878>

Bonjour,

J’ai installé pour la première fois le plug in zwave, mais les dépendances ne s’installent pas

J’ai essayé quelques solutions proposées dans le forum sans succès :
apt update
apt upgrade
pip install --upgrade setuptools
python -m pip install --upgrade pip
python3 -m pip install --upgrade pip

La sortie de log ne m’inspire pas vraiment
Si une âme charitable pourrait me mettre sur la voie j’avoue être perdu.

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.9.5)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.1)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (3.5.0b2)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pylint) (1.12.0)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.3.21)
Requirement already satisfied: astroid<2.0,>=1.6 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.6)
Requirement already satisfied: futures; python_version < "3.2" in /usr/local/lib/python2.7/dist-packages (from isort>=4.2.5->pylint) (3.3.0)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.12.1)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.4.3)
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"
Dependencies for users installed (python 2 7 16)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
cc1: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-8/README.Bugs> for instructions.
make[2]: *** [/opt/python-openzwave/openzwave/cpp/build/support.mk:142: /opt/python-openzwave/openzwave/.lib/hid.o] Error 1
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make[1]: *** [Makefile:20: all] Error 2
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
make: *** [Makefile:273: openzwave/.lib/] Error 2
sed: can't read /boot/cmdline.txt: No such file or directory
sed: can't read /etc/inittab: No such file or directory
Everything is successfully installed!

Merci

Bonjour @sentinelle,

Des infos ici : [Présentation] akenad

akenad :slight_smile:

Bon c’est pas claire ton affaire … on reprend les choses a Zéro :

connecte toit en ssh et passe les commandes suivantes

pi@covid:~$ python3 --version
Python 3.7.3
pi@covid:~$ python --version
Python 2.7.16
pi@covid:~$ pip3 --version
pip 18.1 from /usr/lib/python3/dist-packages/pip (python 3.7)
pi@covid:~$ pip --version
pip 18.1 from /usr/lib/python2.7/dist-packages/pip (python 2.7)

fait moi ensuite une copie du résultat comme-ci dessus.

fonction du résultat je te guide ok ?

Merci pour tes suggestions voilà mon output:
(J’ai du passer par la console web de Jeedom SSH pas configuré et impossible d’éditer /etc/sshd_config par la console )
python3 --version
Python 3.7.3
python --version
Python 2.7.16
pip3 --version
pip 20.1.1 from /var/www/.local/lib/python3.7/site-packages/pip (python 3.7)
pip --version
pip 20.1.1 from /var/www/.local/lib/python2.7/site-packages/pip (python 2.7)

Merci

Bon dejà tes pip/pip3 et python son bon (c’est pas toujours le cas )…

pour le log c’est assez contradictoire … j’aime bien la fin Everything is successfully installed!

pour le reste c’est pas top

Il y a quoi dans le fichier :

See <file:///usr/share/doc/gcc-8/README.Bugs> for instructions.

README.Bugs.txt (10,8 Ko)

un readme de plus pour rapporter les bugs je pense, j’ai du le mettre en txt pour l’uploader.

@ akenad: Merci pour ton support, je l’avais validée précédemment.
@ olive pour info j’ai rattrapé mon accès ssh.

Merci

1 J'aime

Bonjour,

J’ai fini par en avoir marre de chercher, j’ai été au plus simple réinstallation et restauration, et là plus de problème de dépendance.
un mal pour un bien cela m’a permis de tester la restauration.

Merci à vous pour votre temps.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.