Impossible d'accéder à Jeedom en externe après changement de FAI (livebox 5)

Tags: #<Tag:0x00007fcbb31b9d48>

Bonjour à tous,

Je viens vers vous afin de vous présenter ma problématique à laquelle je n’ai pas trouvé de solution depuis plusieurs jours maintenant et cela m’embête beaucoup. Je viens chercher un peu l’aide de la communauté.

Historique

Installation de Jeedom sur un RPI 3 B+ et un ssd mSata avec comme FAI Free :

  • Pour l’accès externe j’ai acheté un nom de domaine chez OVH (mondomaine.ovh par exemple)

  • Ouverture des ports 80 et 443 dans le paramétrage de ma box

  • Installation du certificat SSL let’s encrypt sur mon RPI

Free fournit une IP fixe gratuitement. Aucun problème de fonctionnement pendant un an.

Aujourd’hui

Changement de FAI de Free vers Orange (pour la fibre) avec une livebox 5

  • Début des problèmes car Orange ne fourni pas d’IP fixe

Solution envisagée :

  • Paramétrer le DynDns avec la création d’un sous domaine dans OVH (jeedom.mondomaine.ovh)
    image

  • Ouverture des ports 80 et 443 sur ma livebox 5

Aujourd’hui je n’arrive même pas à accéder à mon interface Jeedom en http (sans sécurisation HTTPS pour le moment). A noter que le ping sur jeedom.mondomaine.ovh fonctionne…

Avec Free je n’avais pas de sous domaine (pas besoin car adresse IP fixe), j’avais créé le certificat SSL pour mon domaine www.mondomaine.ovh et je pouvais donc accéder à mon interface Jeedom via https://mondomaine.ovh.

Avec Orange étant donné que j’ai dû créer un sous-domaine, dois-je de nouveau générer un certificat SSL pour mon sous domaine (jeedom.mondomaine.ovh) ou alors le certificat su domaine www.mondomaine.ovh suffit. Mais avant d’en arriver là, je n’arrive même pas à accéder à mon Jeedom en HTTP classique. J’essaye de via l’adresse suivante, jeedom.mondomaine.ovh mais la redirection ne passe pas…
Je me demande sur les règles NAT/PAT de ma livebox sont correctes(j’ai mis le parfeu sur faible également), voir les images ci-dessous pour le paramétrage de la livebox.
image
image
image

J’ai essayé d’installer un certificat SSL pour mon sous-domaine mais la encore je rencontre une erreur (ce qui me fait penser que c’est bien un accès en http qui ne fonctionne pas de base).
image

J’accède bien à mon Jeedom en interne via on adresse IP locale (192.168.1.51).

Je suis donc un peu perdu, je cherche depuis une semaine sans succès… Si quelqu’un à une idée sur le problème je suis preneur.

Merci à tous pour votre aide.

Cordialement,

Hello,

je sais qu’il y a un problème sur les règles NAT depuis une MAJ du firmware des LiveBox 4 en décembre dernier. Je ne sais pas si les livebox 5 sont concernées…
Et le problème est visiblement toujours pas corrigé.

La solution est de créer une nouvelle règle sur un autre port, et ca fonctionne (testé chez moi).

Bonjour,

Merci beaucoup pour le retour. J’aurais pu chercher longtemps en fait… C’est incroyable cet amateurisme chez Orange. Pour être sûr que ce soit bien la même version que nous avons pourriez-vous me communiquer la version de firmware pour votre livebox (pour moi c’est 3.3.14) ?

Si j’ai bien compris l’url que vous avez partagé il faut rediriger le http vers le port 2000 par exemple (cela doit être supérieur à 1025) ? Après l’accès à mon Jeedom sera de la manière suivante http://jeedom.mondomaine.ovh:2000 ?

Concernant le certificat SSL qui avait été généré pour mon domaine, il sera suffisant pour mon sous-domaine si je souhaite utiliser le https ou faudra t-il le regénérer pour mon sous-domaine ?

Merci encore pour votre aide.

Moi je suis en 3.103.16 sur livebox V4.

D’après cet autre article (https://www.touslesdrivers.com/index.php?v_page=3&v_code=7888), la V5 en 3.3.14 ne semble pas concernée (dernière phrase de l’article) mais il faudrait vérifier…

Sinon oui, dans mon cas, un port > 1025 et un accès en https://jeedom.domaine.ovh:port fonctionne. Et pas besoin de nouveau certificat.

Avec la livebox 5 aucun ne fonctionne, les ports 80 et 443 et même un port supérieur à 1025. Je pense que je dois avoir un problème ailleurs probablement. Je n’arrive pas à trouver où…

J’ai bien ajouter le port 2000 également et voici la configuration dans jeedom pour l’accès externe :
image

image

J’ai ce résultat quand j’essaye d’y accéder via le navigateur :
image

Merci pour m’avoir aidé et merci à autres qui pourront m’aider.

Bonjour,

J’ai une LB4 et je n’ai pas de souci :

image

Bonjour,

Ton probleme est plus côté OVH.

Je suis chez sosh, le probleme des firmwares des LB4 c’est le loopback. En gros depuis l’extérieure tu arrives a accéder a ton jeedom mais pas depuis le local.

Suite au remplacement de la LB4 par la LB5, le problème a été résolu chez moi.

As-tu essayé d’accéder a ton jeedom depuis l’extérieur de ton réseau? avec ton nom de domaine et ensuite en tapant l’IP de ta box?
On dirai que ton nom de domaine ne pointe pas vers l’IP de ta box.

Quand tu essaies avec les autres ports, tu modifies aussi le port d’écoute apache? car sinon ca sera que 443 et 80.

Et ta redirection du port 2000 n’est pas coherente entre ta box et ton jeedom. Si en local c’est 80, dans ta règle nat, c’est le 2000 qui doit renvoyer vers 80.

image

Le liens orange des regles NAT:
Loopback ne fonctionne plus sur Livebox 4 firmware… - Page 26 - Communauté Orange

C’est quelle IP cible que tu as mis dans la config OVH? J’ai l’impression que tu as mis l’IP local de la box 192.168.1.1. Si c’est le cas, l’erreur est la.
image

Configurer DynHost:
Paramétrer un DNS dynamique pour son nom de domaine | Documentation OVH

Si ca peut aider:
DynHost, le DynDNS de chez OVH (perhonen.fr)
ou:
DynDNS OVH avec ddclient – Lucas Videlaine (wordpress.com)

Stef.

Merci beaucoup Stef pour votre aide.

Voici mon paramétrage actuel livebox (avec parfeu à faible) et ovh :
image
Ici je ne sais pas à quoi sert le paramètre IP externe (je met un espace car sinon par défaut c’est 0.0.0.0/0)

image
Pour OVH et le paramétrage de mon DynHost c’est bien l’adresse publique de ma box et non pas l’adresse locale.

image
Les accès pour la maj de l’IP dynamique

image
Le paramétrage du DynDns côté Jeedom et le résultat (la même IP publique que sur OVH pour mon sous-domaine
image

Alors pour répondre aux différentes questions :
J’ai essayé de me connecter depuis l’extérieur de mon réseau (avec mon téléphone déconnecter du wifi, donc en 4G) :

  • Avec le nom de domaine http://jeedom.mondomaine.ovh = ECHEC

  • Avec l’IP http://xx.xxx.139.1 = ECHEC
    Je ne sais pas si j’ai oublié quelque chose côté OVH, j’ai juste paramétré un DynHost. Jen’ai donc plus de zone DNS avec une adresse A qui pointe vers une adresse IP
    image

Quand tu essaies avec les autres ports, tu modifies aussi le port d’écoute apache? car sinon ca sera que 443 et 80

C’est à dire ? Comment dois-je faire ça ? Je n’ai pas essayé avec un autre port du coup car je ne sais pas faire cela (sinon j’ai compris ma première erreur avec le port, 2000 doit être en entrée et 80 en sortie).

Merci bien :slight_smile:

Bonsoir,

Peux tu vérifier l’adresse IP externe de ta livebox. Je suppose que tu peux le voir dans l’interface de gestion.
Autrement, à partir d’un navigateur sur ton PC, via l’url http://checkip.dyndns.com

Au vu des règles que tu as configuré, tu devrais pouvoir accéder à ton jeedom via http:// ou http://:2000
correspond à l’adresse obtenue au premier test.
Si cela ne fonctionne pas, c’est une configuration ou problème dans la livebox.

Si tu accèdes à jeedom. Vérifie si l’adresse ip connue par via ton dynhost est correcte.
nslookup jeedom.mondomaine.ovh
Cette commande doit te retourner l’adresse IP trouvée au premiet test.

je vois pas la conf de ton sous domaine sur ovh c’est normal ?

Bonsoir Henribi,

Voici l’adresse IP externe de ma livebox :
image

Le résultat du nslookup jeedom.mondomaine.ovh :
image

Les adresses IP sont les mêmes… Jesuis perdu !

Merci à tous pour vos suggestions

c’est l’@ externe de ta livebox le 139.1 ?

Bonsoir Xav31190,

Si je créé un sous domaine dans le DynHost il ne doit pas avoir le même dans la ZoneDns si j’ai bien compris non ?

Merci.

Oui xx.xxx.139.1 est l’adresse externe de la livebox.

donc en externe ton nom de domaine pointe bien sur ton ip externe

Oui le nslookup et le ping renvoient bien la bonne IP externe de ma box :
image

donc de ton tel en coupant le wifi si tu met http://jeedom.
tondomane.ovh:port eventuel , tu dois acceder à ton jeedom

pour info le parametre ip externe de ta livebox sert à forcer la connexion d’une seule ip de l’exterieur.Ex l’ip de ton boulot et c’est tout, autrement vide c’est de partout

> pour info le parametre ip externe de ta livebox sert à forcer la connexion d’une seule ip de l’exterieur.Ex l’ip de ton boulot et c’est tout, autrement vide c’est de partout

Merci pour l’information je me demandais à quoi servait ce paramètre.

Malheureusement je n’arrive pas à y accéder via mon téléphone (avec une connexion 4G) :
J’essaye http://jeedom.mondomaine.ovh
image
image

je mettrai le 2eme sur https , et fermerai le port 80 sur la livebox pour commencer.C’est un peu dangereux de laisser le 80 ouvert surtout pour serveur domotique
fais ça et réessaie en https
image
chez moi :
image

Peux-tu verifier l’IP réel de ton jeedom?

Vérifier qu’il a bien pris une IP sur la plage de la box.

ip addr 

Stef.