Graphique historique valeurs supérieur > 1 an

Tags: #<Tag:0x00007f385049b210>

Bonjour,
J’ai pas mal cherché mais pas moyen de trouver une solution…
Sur l’année 2020 j’ai une valeur / jour de ma conso EDF et d’Eau.
J’ai réussi a ajouter une valeur pour mes 10 précédentes années que j’avais relevé manuellement.
Du coup mon historique possède 10 années de valeurs qui pourrait faire un joli graphique sur mon Design.
Mais impossible de faire un graphique sur le Design au dela de 2020…
Alors que dans Analyse / Historique je peux afficher différents graphiques en choisissant la période adéquate
J’ai bien essayé de modifié sur le graphique dans paramètres d’affichage la période année ou tous mais rien n’y fait
Je n’arrive pas a avoir le menu de sélection de la période comme sur Analyse / Historique…
Pas moyen d’aller au dela de l’année en cours sur le Graphique
merci de votre aide
Lemars

Bonjour,

En effet, après test, je constate la même chose que toi… ça ressemble fortement à un bug.
Je te conseille d’ouvrir une demande de bug sur ce pb.

désolé de te demander : comment dois je faire pour faire cette demande de bug ou de ticket ?
merci

https://market.jeedom.com/index.php?v=d&p=&

mon compte
demande de support

merci
demande faite
a suivre

Bonjour,
En fait, Loic vient de me répondre qu’il ne peut pas m’aider car j’avais installé l’Alternative Market et qui a priori modifie beaucoup de choses.
Malheureusement je ne savais pas, j’avais pas compris.
Du coup je vais devoir tout refaire mon Jeedom…
Savez vous s’il y à moyen de sauvegarder un à un les Virtuels ? Et un Design ?
Par avance merci

Bonjour
Je viens de finir de ré-installer totalement Jeedom sur une nouvelle machine virtuelle (Synology) sans plugin extérieur au market Jeedom.
Avant de faire une ouverture de ticket comme suggéré précédemment j’aimerais mieux comprendre comment fonctionne le système de calcul de regroupement des valeurs sur un graphique ou historique.
J’ai historisé les moyennes de consommation d’eau sur les 10 dernières années : j’ai donc ajouté manuellement 10 valeurs de consommation pour chacune des années avec une formule comme celle-ci :
$cmd = cmd::byId(314);
$cmd->addHistoryValue(281.1, ‹ 2020-08-31 17:25:09 ›);

puis pour l’année en cours 2020 j’ai une valeur journalière de consommation d’eau

Au total cela fait 10 valeurs pour les années 2010 à 2019
et environ 8 mois x 30 jours environ 240 valeurs de consommation pour 2020

Et lorsque je vais dans Historique : si je choisis du 01/01/2010 a aujourd’hui sans Regroupement de valeurs je vois bien toutes mes valeurs (1valeur/année pouis plusieurs sur 2020) : graphique ci-dessous
Capture1

Et sur le même graphique si je choisis regroupement : « Moyenne par année » impossible d’avoir une courbe de 2010 a 2020 :

  • j’ai soit la courbe de 2010 a 2019 mais sans 2020
  • ou la courbe avec une seule valeur moyenne pour 2020
    Voir copie ecran

Capture2

Je ne comprends pas ce que je fais pas bien

Ou faut il que je mette au moins 2 valeurs (identiques) pour chaque année de 2010 a 2019 ?

Ou alors je n’ai rien compris à ces regroupement de valeurs…

Par avance merci pour votre aide

Lemars

H.S. Tu n’aurais pas interet a basculer toutes ces données dans influxdb et d’utiliser grafana pour exploiter l’ensemble ?

1 J'aime

merci mais je n’ai que 250 points de valeurs… à comparer des centaines de valeurs des sondes de température et autres cela ne doit pas faire grand chose…
mon probleme doit venir d’un déséquilibre entre 1 valeur / an et ensuite 240 valeurs / 1 an ?

si une ame charitable pouvait passer par la et me proposer une piste d’amélioration ? de solution ?
merci

Je pensais le fait d’avoir qu’une seule valeur pour les années de 2010 a 2019 pose un probleme mais a priori le ptobleme ne vient pas de la…

J’ai réessayé d’importer dans un virtuel de test de nouvelles valeurs :
12 valeurs pas an de 2010 a 2019
puis 240 valeurs pour 2020 (de janvier a aout)
et voila rien n’y fait : en mode pas de regroupement de valeurs j’ai bien toutes les valeurs : 2020 compris :
Capture1
Et si je fais moyenne par année : pas de valeur en 2020 ???
Capture2

Dans la config du plugin : en mode de lissage de valeur je suis en moyenne :
Capture3

Si vous aviez une idée ? je ne sais plus quoi faire…

merci

Pensez vous que je puisse ouvrir un ticket pour ce probleme ?
Par avance merci
Lemars

Salut,

ça ne coûte pas grand chose d’essayer, non ?

Hello,
Je pense qu’il y a un vrai bug là derrière… comme indiqué plus haut. Sur une commande qui relève la température extérieure, et qui de l’historique depuis des années, je n’arrive pas à obtenir de graphique « design » au-delà de un an (Jeedom 3.3.53).
Perso ce n’est pas un problème car mes graphs design sont limités pour accélérer le chargement, mais je note aussi le pb si j’essaye de le faire.

merci cela me rassure
car sur le Design aussi je n’arrive pas a aller au dela de 1 an
Impossible d’avoir la selection de la période comme dans l’historique (pourtant j’ai bien coché le paramètre sur le graphique avec afficher le selecteur de période
Capture0

alors que dans l’historique je peux voir sur 10 ans

je viens d’ouvrir un ticket sur les conseils de Naboleao

Bonjour à tous,

Voici la réponse de Loïc :


Bonjour,

Le soucis est connu et avait été corrigé en 4.1, je viens de porter la correction sur votre jeedom et sur la prochaine stable v4.

Désolé pour le bug

Loic


Super !

En effet voici le résultat :
Capture1

Maintenant un petit tour sur le Design et à priori cela fonctionne aussi :
Capture2

Problème résolu merci à tous !!!

N’oublie pas de solutionner le post !

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.