Google Cast: Sin detectar dispositivos con escaneo

Tags: #<Tag:0x00007f384e93dab8>

Buenos días,
estoy muy interesado en utilizar el complemento Google Cast por toda la funcionalidad que aporta. Tengo v.3.0 (estable) instalada en un Jeedom Pro en V4.0.61.

Las dependencias están bien instaladas (OK).

Tengo varios Google Home y varios Chromecast configurados en el plugin oficial GCast (en diferente subred al Jeedom Pro). Sin embargo, cuando escaneo desde el complemento Google Cast no detecta nada.

Después de revisar en el foro y ver las siguientes entradas:

  • Googlecast - pas de détection lors du scan (pir2d2)
  • Pas de detection des équipements avec plugin google cast (patogo)
  • Equipements non touvés après scan gcast (jabber)

He realizado:

  • La reinstalación « Zeroconf » con la versión indicada y reiniciado el demonio.
sudo pip3 install zeroconf==0.24.3
Collecting zeroconf==0.24.3
  Using cached https://files.pythonhosted.org/packages/35/c2/66800724e76095d5bc7ad6f76ccaa495e5d4e4a8e1c36f39aa820f17468c/zeroconf-0.24.3-py3-none-any.whl
Requirement already satisfied: ifaddr in /usr/local/lib/python3.5/dist-packages (from zeroconf==0.24.3)
Installing collected packages: zeroconf
  Found existing installation: zeroconf 0.28.5
    Uninstalling zeroconf-0.28.5:
      Successfully uninstalled zeroconf-0.28.5
Successfully installed zeroconf-0.24.3
  • Instalado el paquete:
    apt-get install avahi-utils
  • … y ejectuado:
    avahi-browse -t -a
    (sin devolver nada).

Sin embargo, sigue sin detectar ningún dispositivo al finalizar el escaneo.

Por favor, ¿se puede realizar alguna otra acción para solucionar el problema? ¿hay posibilidad de agregar los dispositivos (por IP/Mac) si no funciona el escaneo?

Gracias por la ayuda!

Si estas en diferentes subredes, necesitas gestionar que el multicast pase a través de cada una de estas redes, estos paquetes no es enrutados por defecto por los firewalls.