Gestion des Groupes et Binding avec Deconz

Tags: #<Tag:0x00007f7536431a90> #<Tag:0x00007f7536431860>

Bonjour à tous,

J’ai une cinquantaine de spots Phillips hue à commander via deconz, le plugin officiel ne permet actuellement pas de les piloter en utilisant la fonction « groupes » intégrée au protocole zigbee.

J’ai fait des virtuels pour allumer les spots par groupe (Table, Tv, Cuisine, Couloir, etc…), les spots s’allument presque 1 par 1, il faut environ 2 à 3 secondes pour qu’un groupe de 8 s’allume entièrement.

Pour l’instant, je compte utiliser l’api Deconz via des scripts (ou autre) pour pallier ce manque, mais c’est tout de même dommage.

Si vous avez des solutions, je suis preneur.

L’équipe Jeedom travail-t-elle actuellement sur une remontée des groupes et scènes dans le plugin ?

Merci d’avance

Bonjour,
C’est dans la todolist mais dans longtemps (mois voir année)

Ok merci Loïc pour l’info.

Du coup en attendant que ce soit implémenté dans le plugin, si quelqu’un d’autre a été confronté au mème problème, je suis preneur de son retour d’expérience sur ce sujet.

Je relance un peu le sujet, personne ne gère autant d’ampoules en Zigbee ?

Pas par Deconz en ce qui me concerne. Mais par appairage direct. Du coup, les spots s’allument quasi simultanément. Mais ce n’est pas vraiment la solution que tu cherches…

Salut, pas autant de matos, et des groupes de 3 à 6 device,
j’utilise le plugin « Groupe », qui te permet de faire des groupes, de regrouper les commandes on et off, de faire tous On ou tous off, et de savoir combien de On et combien de Off en commande déjà disponibles par le plugin.

Bien commode ce plugin Groupe en effet. Je viens de le tester sur des spots (je l’utilisais pour tout autre chose) : allumage/extinction simultané de tous les spots.

Test à prendre avec des pincettes car dans des conditions « idéales » : groupe de seulement 4 spots, pas de routage (box sous les spots), box sans charge système,…

@Avallo : En effet l’appairage direct je le réserve en cas de défaillance de la partie informatique, je pense me prendre quelques télécommandes au cas où.

@Bben : J’ai mis en place le plugin Groupe, mais ça ne change rien, le problème c’est que Jeedom envoi une requête http à Deconz pour chaque spot, il doit d’ailleurs y avoir un timeout quelque-part car parfois ils ne s’allument/s’éteignent pas tous…

@Loic : Dans l’API, un équipement, un groupe, une scène se gère de la même façon, serait-il possible de faire évoluer le plugin pour les faire remonter ?
Quitte à ce que cette config ne soit par défaut mais en activant l’option dans la config du plugin.
Sans forcément gérer les groupe/scéne sous Jeedom, on pourrait en effet dans un premier temps les paramétrer dans Phoscon.

Bonjour
J’ai déjà répondu merci de lire les postd ça permet de faire gagner du temps a tout le monde

J’ai bien lu, je sais qu’il y a pas mal de boulot sur d’autres développements et que ce n’est pas une priorité, je me dis juste que si personne ne demande ça restera sous la pile…

Bon avant de me résigner je vais essayer de voir si je peux faire moi même la modif sur le plug-in, sinon je ferai un script.

Comme dit c’est pas une question de demandé c’est déjà dans la todolist juste une question de temps a trouver pour le faire

Si tu veux bricoler de ton coté, et que tu as les bases, c’est tres facile d’utiliser les groupes sous deconz.
Tu les configures sous Phoscon, et tu as une seule commande a faire en http pour allumer ou éteindre les spots (mais du « perso » pas dans le plugin deconz).
Je dois pouvoir retrouver les commandes avec Curl, si tu l’as pas deja fait ?

Oui la doc de l’API est ici : https://dresden-elektronik.github.io/deconz-rest-doc/groups/, j’envoi les commandes avec RESTED sous Firefox, ça fonctionne nickel.

Il ne te reste plus qu’à copier la commande curl depuis l’interface RESTClient et de la copier dans un script Jeedom que tu customises (ou pas) avec un joli widget et que tu affiches dans un Design.
Toutes mes commandes groupe sont ainsi faites et ça marche super bien (Extinction lumières
générale, fermeture des VR générale, …)

1 J'aime

j’ai gratté un peu et il y a un problème, lorsque je lance une modification d’état sur un groupe, une ampoule ou une scène, par exemple :
curl -X PUT -i 'http://127.0.0.1:8484/api/cléAPI/groups/5/action' --data '{"toggle": true}'
je suis très souvent obligé de lancer la commande plusieurs fois pour que ça fonctionne.
En regardant le log du plugin, on voit que Jeedom reçoit une notification (websocket ?) de changement d’état et envoi immédiatement un ordre pour maintenir l’état présent dans Jeedom.

Vous avez une idée pour changer ce comportement ?

J’ai installé Deconz via la page de config du plugin, y a t-il des manip à faire pour le désinstaller proprement ?
Je souhaite l’installer manuellement et voir si en me passant complètement du plugin ça résout mes problèmes.

Tu peux essayer avec l’appli deCONZ directement sous win10 depuis un PC.
Sinon sur ta box domotique tu peux aussi essayer l’appli deCONZ GUI . Pour cela il faut au préalable arrêter le deamon deconz du plugin puis sudo kill -9 des processus deCONZ lancés par le plug in. Ensuite lancer l’appli deCONZ en GUI et tester directemnt avec l’appli.
Pour ma part je n’ai pas constaté le pb que tu rencontres. J’ai plusieurs groupes éclairages (un par pièce , un par étage et un pour la maison complète). Les actions sur ces groupes sont simplement pilotées soit par un script Jeedom soit par des interrupteurs (émetteur zigbee) physiques appairés avec les groupes.

Salut,
Il faut lancer quoi en ligne de commande pour lancer en gui ?

Installer l’appli deCONZ et la lancer depuis l’interface graphique du bureau de ta box (je le fais via VNC personnellement) .
Sinon tu trouveras ici les commandes si tu veux lancerl’appli depuis une console :

Au sinon juste arretter le plugin, tu pourras tester tes commandes et voir si c’est le plugin jeedom qui revoit des commandes par dessus les tiennes (qui essayerait d’éteindre une lampe car elle est éteinte dans sa config mais allumé dans l’info venant du websocket).
Par contre si ça vient d’un script, tu auras le même probleme.

Le plugin Deconz de Jeedom est installé sur ton système ?

Hier soir j’ai désinstallé le plugin et installé deconz en manuel, ça fonctionne impec avec un script.