Geoloc App Mobile

Tags: #<Tag:0x00007f24273e5e48>

Bonjour,

Je suis confronté exactement au même soucis.
J’ai placé un point “travail” dans l’application en vue de faire connaitre à Jeedom ma présence au travail. Ça bien fonctionné pendant plusieurs mois, et depuis quelques semaines, la remontée se fait de manière erratique…

Je suis actuellement au travail, pourtant
L’info [Smartphones][TelDavid][1-Travail] me renvoie 0

Dans la configuration avancé de mon mon mobile dans le plugin App Mobile je vois :
Date de dernière communication : 2020-02-03 11:36:02 (j’étais au travail)
Dernière mise à jour : 2020-02-02 17:14:20 (je n’y étais pas)

Le fait d’ouvrir l’application (qui l’était déjà en tâche de fond apparemment) ne met pas à jour l’information. Pourtant dans les paramètres de géolocalisation, ma localisation se situe bien dans le cercle travail.

Il semble qu’il n’y pas de remontée de la localisation périodique, ou lorsque que l’on ouvre l’application.

Mon smartphone est Xiami Redmi Note 7, j’ai pris le soin d’exclure l’application de l’économiseur de batterie.

Avez-vous trouver une solution à ce problème ?

Sinon en attendant, existe-t’il une solution très simple pour simplement remonter ma localisation à Jeedom (en évitant les solution cloud comme IFTTT).

Merci pour aide
David

Personnellement, sur mon One+ 5T j’ai plein de problème, ça marche de façon aléatoire.
Par contre, sur le MI 9 SE de ma copine, ça marche vraiment beaucoup mieux.

oui idem : fonctionnement trop aléatoire…
dommage

1 J'aime

Pareil fonctionnement aléatoire chez moi.
Sur celui de ma femme c’est aléatoire et sur le mien ça marchait bien jusqu’à ce que je passe à android 10.
@Fabrice y’a t-il une mise à jour de prévus?

Idem
Depuis android 10 ne fonctionne plus du tout
C’est tellement dommage car les possibilités sont enormes !
Merci

Bonjour,

Je ne sais pas pourquoi je suis cité ici :blush:

Sinon, avez vous tenté de réinitialiser l’application qui vous créer défaut ?

  • Depuis le Smartphone : Paramètres / Applications
  • Cliquer sur l’application qui doit être réinitialisée, puis : Stockage / effacer les données de stockage (cela réinitialise l’application, comme si elle n’avait jamais été exécuté sur le Smartphone.
  • Cela corrige le plus souvent, les problèmes issues d’une migration d’OS ou de montée de version d’application.

Bonjour
Je viens de tester et cela n’a pas fonctionné
J’ai refait les points gps et reparamétré totalement l’application
Sous android 10 la géolocalisation ne fonctionne plus
Merci

Hello. J’essaie de voir depuis des heures pourquoi je n’ai aucune valeur de remontée lorsque je change de zone et passe de maison à travail. Je n’ai ni valeur 0 ni 1, juste «  » sans valeur dans mes logs.

Est-ce que ça serait à cause d’Android 10 ?

Je suis sur un Galaxy S20Ultra

1 J'aime

bonjour
moi j’ai bien un des 2 points GPS à 1 mais toujours à 1 !
a suivre

J’ai bien l’impression qui y a un souci avec android 10.
Je suis dessus pour trouver une solution !

merci de votre aide
a votre service pour aider
Lemars

Je crois qu’il manque l’autorisation d’utiliser le GPS en arrière plan lorsque l’application est ,'est pas ouverte. je peux te faire des copies d’écran si besoin

Après check, effectivement, ça doit être un souci car il n’y a que l’option d’utilisation du GPS seulement si l’appli est en cours d’utilisation. Il manque peut-être l’option « Toujours autoriser »

Il serait souhaitable selon moi d’indiquer dans la doc qu’il faut supprimer l’optimisation de la batterie sur cette app, sinon elle se mets en veille au bout d’un certain temps.

Au delà de ça, même en la laissant en avant plan, j’ai toujours aucune valeur de retournée lorsque je change de zone. Possible de forcer un refresh quand on se trouve dans une zone ?

Cet évolution doit être la cause des soucis :

https://developer.android.com/about/versions/10/privacy/changes#app-access-device-location

c’est exactement ça, merci. je vais faire les modifications, il y a pas mal de modification que je doit faire monté en beta, j’espère pouvoir vous proposer une nouvelle version (beta) d’ici deux semaines max :wink:

c’est sur la prochaine beta, et j’ai lancer une beta aujourd’hui ça devrai être très rapidement valider par Google :wink:

bonjour
merci de vous être penché sur ce problème.

je suis passe d’un android 8 à 10, et effectivement aucune remontée d’info j’ai teste avec une application qui force le GPS. mais rien à faire aucun retour de position.
sur mon ancien (android 8) je forcé app mobile en arrière plan et ça marchait vraiment bien.
sur redmi note 9s, android 10q . ( en mode développeur muiu optimisation désactivé, gps forcé, options diverses en forcés(optimisation, gps quand actif…) rien a faire.
install refaite à neuf sur tel.
ma question est: y a t il eut une avancée? ou un paramètre que je n’aurais pas vue

C’est sur la bêta :wink:
Sortie stable fin du mois.

bonjour, merci d’avoir répondu aussi rapidement.
désolé de t’embêter le weekend. :star_struck:
je l’ai installer en bêta sur le market android. Et effectivement ça marche bien mieux avec la localisation toujours autorisée.
je te ferais un retour en fin de semaine.
je n’ai gardé que forcé l’app en arrière plan. je ferais le test aussi sans.
bonne semaine à tous.
stéphane

1 J'aime

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.