Fullykiosk - Demon NOK

Tags: #<Tag:0x00007fa7b9b80228> #<Tag:0x00007fa7b9b80048>

Bonjour tout le monde,

Depuis la dernière mise à jour FullyKiosk, impossible de lancer le demon.

Malgré tout, cela fonctionne, j ai bien le retour d’état de la tablette, les Screenshots fonctionne!

Par contre j ai tout le temps un message dans les warning:

fullyKiosK - Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consecutivement

Vous pensez que cela viens d’où?

Idem pour moi, j’ai désactivé la gestion automatique du daemon

idem

[2019-10-21 10:25:05][ERROR] : Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consecutivement

j’ai relancé les dépendances mais pas mieux

Bonjour,
pareil pour moi…

Merci d’ajouter un tag à votre demande, sinon celle-ci a peu de chance d’être vue par la personne intéressée (le dev)

c’est fait, merci pour l’astuce.

idem, y a t’il une solution ?
Comme indiqué dans le log, j’ai effectué la commande sudo dpkg --configure -a, mais ça ne change rien.
merci

Même problème.
En debug j’ai cette info lorsque le deamon crash

[2019-10-28 17:06:07][DEBUG] : No active MQTT, Daemon stopped

moi aussi j’ai le meme problème
Capture

Bonjour,

Je rencontre également le problème pour une première utilisation et installation.
Si vous voulez plus d’info sur ma config, je suis à votre disposition.

Merci
image

Même souci que pour vous.
C’est sûrement lié à une mise à jour.

Hello,
C’est peut-être à cause de ça :

Mathieu

Bonjour,

J’ai aussi des problèmes lorsque j’active le MQTT côté tablette ainsi que plugin.
Le démon crashe dès qu’il reçoit un message MQTT car il n’arrive pas à créer correctement la commande info associée.

En utilisant la version beta (mais je pense que c’est pareil dans la version stable), j’ai corrigé les erreurs suivantes pour que ça fonctionne.

1 - Dans mon cas, le bloc suivant est mal placé

                if($this->getLogicalId() == ''){
                   $this->setLogicalId($json['deviceID']);
                   $this->save();
                }

Il faut le remonter avant la partie //update settings value qui exécute une commande listSettings car c’est la commande deviceInfo qui contient le deviceId alors que la commande listSettings ne le contient pas.

2 - De plus, il y avait initialement une faute de frappe dans la ligne $this->setLogicalId($json['de**iv**ceID']); à corriger.

Maintenant, ça a l’air de bien fonctionner mais je voudrais aussi proposer de préfixer le nom des commandes Info ainsi créées avec un identifiant clair comme mqttScreenOn afin d’éviter la confusion avec la commande action screenOn créée à la création de l’équipement.

Je ne sais pas si c’est la bonne façon de remonter le problème… merci de m’indiquer s’il faut contacter autrement le dev.

fx

P.S. En tout cas, le plugin est vraiment bien :smile:

Bonjour,
Merci pour ton analyse.
J’ai monté le bloc que tu indiques. Je n’ai pas testé.

c’est quoi la faute de frappe du point 2?

En ce qui concerne le nom des commande mqtt, oui c’est une bonne idée de mettre un préfixe sur les retour d’évènements.
J’ai modifié la beta le nom de la commande est désormais mqtt+nom évènement

Bonjour,
Tu peux oublier le point 2/faute de frappe. J’ai vérifié dans le github et ça me semble ok. Ca a du être une erreur de ma part en debuggant.
Merci pour ta réactivité.
fx

Bonjour,

Merci pour les modifications !
Au passage, il manque un $ devant json dans le code suivant de la fonction message

      		log::add('fullyKiosK', 'debug', 'Event received:' .  $json['event'] . ' ' . date('y/m/d h:i:s'));
        	$fullyKiosKCmd->setValue(date('h:i:s'));
		$fullyKiosKCmd->setName('mqtt'.$json['event']);		
		$eqlogic->checkAndUpdateCmd(**json**['event'],date('y/m/d h:i:s'));

		$fullyKiosKCmd->save();

fx