Fibaro FGS-214 Smart module - Utilisation des scenes S1 S2

Tags: #<Tag:0x00007fcbb5d60708>

Bonjour à tous, :slightly_smiling_face:

J’utilise Jeedom depuis plusieurs années et je l’adore mais cette fois je bloque sur un sujet qui m’amène à vous demander de l’aide :yum:

J’ai acheté un module Fibaro FGS-214 mais il ne semble pas correctement configuré dans le plug-in z-wave Jeedom.

J’ai bien utilisé la fonction ‹ Configuration › > ‹ Configs modules › afin d’actualiser les configs des modules, ce qui a plus ou moins amélioré les choses mais pas totalement.

Je m’explique, dans les commandes du module j’ai bien les 4 commandes : ‹ Etat ›, ‹ On ›, ‹ Off › et ‹ Scene ›. Les 3 premières marchent très bien mais ‹ Scene › ne renvoie jamais rien.

De plus, les paramètres Z-wave ne correspondent pas tous à la doc Fibaro et certains sont manquants.

J’ai bien réussi à configurer le module en mode impulsion en entrant des paramètres manuellement (Paramètres 150 et 154) mais lorsque je souhaites modifier le paramètre 40 qui correspond au déclenchement des scenes, le plug-in zwave renvoi un message d’erreur et plante. Je dois alors relancer le démon.

Mon but étant de récupérer dans Jeedom l’état d’un interrupteur bi-stable relié d’un côté à la phase et de l’autre au S1 ou S2 du module.

Y-a-t-il d’autres paramètres à modifier avant que je n’aurais pas vu ?
Existe-t-il un moyen de récupérer les scenes ailleurs que par la commande qui ne fonctionne pas ?

Je suis preneur de tout conseil et dispo si besoin de plus d’informations :slightly_smiling_face:

En vous remerciant par avance,
Clément

Bonjour,
Fan de Jeedom depuis 2 ans, j’ai trouvé toutes mes réponses dans la communauté!
Mais là je sèche complètement sur ce sujet!
J’ai récemment acheté deux FGS 224 pour piloter mon portail et ma porte de garage.
Jusque là tout va bien mes modules sont bien programmé en contact sec, j’arrive à ouvrir et fermer mes ouvrant.
En revanche, j’ai connecté un contact fin de course sur S1 pour détecter si mon ouvrant est ouvert ou fermé.
Et là rien! je sèche complètement.
J’ai bien créé une info 91/1/128, lorsque j’actionne mon contact, l’info me remonte 10 (le numéro de scène), mais cela reste à 10 tout le temps!
Je suis preneur de toute information, car il faut dire que la doc Fibaro est un peu indigeste :slight_smile:
Par avance merci

Bonjour @bertrand520,

Je suis rassuré de voir que je ne suis pas le seul mais j’ai pas vraiment avancé de mon côté, je n’arrive même pas à récupérer les numéros de scènes…

Par contre, j’ai ajouté un raccourci pour activer mon module dans l’application Jeedom, et de là, j’ai un retour d’état qui semble fonctionner comme par magie ! Sauf que je n’ai aucune confiance dans la fiabilité de l’info renvoyée même si elle parait correcte. De plus, l’info se met à jour uniquement quand le module a été actionné récemment, j’ai l’impression qu’il y a une sorte de veille.

L’info 91/1/128 me renvoie toujours 0 je crois.

Comment as-tu paramétré les paramètres 40 et 41 ?
J’ai l’impression qu’il y aussi quelque chose à jouer avec les paramètres 156 à 160 (envoi de scènes aux groupes d’association) mais je ne vois pas trop comment cela fonctionne.

Cordialement,
Clément.

Bonjour Clement356,
Désolé pour ma réponse tardive!
Tout d’abord, j’ai branché mon contact sec entre Q2 et IN ( pourquoi Q2, parce qu’il y avoir un problème de remonté d’état sur l’état 2). Ensuite j’ai branché mon contact fin de course entre la phase et S1. Ca c’est pour le branchement.
Coté paramètre j’ai laissé les paramètres 40 & 41 à 15 par défaut, càd que pour tout mouvement sur S1 ou S2 une scène sera activée.
Ensuite pour S1 (mon contact fin de course) le paramètre 20 est Toggle switch.
Bien vérifier que la gestion de la répétition des valeurs dans l’onglet configuration de la commande Etat1 est sur automatique.
Voilà, de mon coté cela fonctionne: dès que je bouge mon contact fin de course, l’Etat1 passe de 0 à 1 et vis versa.
Maintenant j’ai un autre problème, je ne peux plus mettre de Widget sur mon jeedom, mais c’est un autre problème!
Cordialement

Bertrand

Bonjour Bertrand,

Pas de problème pour le retard, je n’ai pas été très réactif de mon côté la première fois et c’est un forum d’entraide, pas un service SAV :wink:

Pour ce qui est du branchement, nous avons la même config (à ceci près que je n’ai qu’une sortie puisque module j’ai un FGS-214 et non 224).

Mon paramètre 20 est sur ‹ Toggle switch (contact closed - On, contact opened - OFF) › (j’ai deux options ‹ toggle switch ›, l’autre est ‹ Toggle switch (device changes status when switch changes status) › ).

La gestion de la répétition des valeurs dans l’onglet configuration de la commande Etat est bien sur automatique, je viens de vérifier.

Je referais des tests bientôt et je vous tiendrais au courant.

Bon courage pour les widgets !

Cordialement,
Clément.

1 J'aime

Bonjour @bertrand520 et bonne année !

J’ai refait des tests sur FGS-214 mais rien à faire, cela me rend fou ! A chaque fois que j’essaie de modifier les paramètres 40 et 41 (S1 et S2 input – scenes sent), mon plug-in z-wave plante et je dois le redémarrer…
Les scènes ne sont jamais déclenchées et l’état retourné par la commande ‹ etat › de Jeedom ne correspond finalement pas à grand chose.

Suite à la lecture de plusieurs discutions sur le FGS-214 cela ne semble pas possible de le faire fonctionner actuellement correctement sur Jeedom…
J’envisage de passer sur un smart implant qui paraît plus adapté.

Cordialement,
Clément.

Bonjour Clement356,
Je n’ai pas bien compris ce que vous vouliez faire!
Pour vous rassurez chez moi cela fonctionne très bien.
Attention, il semble y avoir un mauvais retour d’état sur Q2 ne fonctionne pas sur jeedom, il faut utiliser Q1.
Pour déclencher les scènes il faut laisser les paramètres 40 et 41 à 15, cela veut dire que sur toutes actions sur S1 et S2 une scène sera déclenchée.
Autre solution, recherger la configuration dans Jeedom, puis dans le FGS et perso je referais une config usine du module, histoire de repartir à plat.
Mais j’avoue, c’est pas très intuitif .

Bon courage,
Bertrand

Bonjour,

Pour ma part, les paramètres de mon module fgs-214 ne correspondent à rien du tout… j’ai par exemple:

40: Reaction to General Alarm
41: Reaction to flood Alarm
le dernier paramètre visible est le 60: Measuring energy consumed by the device itself

j’ai régénéré le plugin, ça ne change rien.

Bonjour @Ludo79,

J’ai exactement la même chose de mon côté.

Pour configurer le module, il faut regarder la doc officielle Fibaro (lien sur mon tout premier post) et entrer les valeurs manuellement grâce à la ligne « Paramètre (manuel) : » à la fin de la liste dans Jeedom (attention à la « taille » qui est donnée dans la doc également).

Le problème c’est que, chez moi, pour certains paramètres cela marche très bien mais pour d’autres (le 40 et 41 notamment) cela fait planter le plug-in z-waze et je dois le redémarrer.

Pour les scènes, si j’ai bien compris, il faut aussi regarder l’onglet « Association » et associer les évènements voulus à la clé z-waze mais pour moi l’association n’a fonctionné que sur S1 et pas sur S2. Et au final les scènes ne sont jamais déclenchées.

Cordialement,
Clément.

Bonjour @bertrand520,

J’ai fait tout ce que vous avez dit mais en vain…
Même après une réinitialisation des modules aucune scène ne remonte…

Je crois que je vais profiter des soldes pour passer sur un smart implant.

Cordialement,
Clément.

Bonjour,

Merci pour la réponse, après une petite recherche, je constate qu’en fait mon module est bien repris comme « Fibaro FGS 214 single switch » mais il a en réalité les paramètres du FGS 213 … bug Jeedom ?

Merci,
Ludo

@Ludo79,

Pas vraiment un bug, c’est plutôt que la bibliothèque utilisée par le plug-in Z-waze de Jeedom n’est pas à jour et ne supporte pas encore les derniers modules Fibaro.

Arrivez-vous à modifier les paramètres 40 et 41 manuellement ?

Cordialement,
Clément

Je n’ai pas essayé de les modifier, je soulignais juste le fait que la fonctionnalité de ces 2 paramètres était différente chez moi… j’ai déjà essayé d’ajouter les param 150-154 en manuel, il me dit que c’est ok mais ils n’apparaissent pas dans l’arbre zwave (dans le tableau ça c’est normal)… j’attendrai une mise à jour, j’utilise ce module pour la porte de garage, je suis débutant, je teste pour le moment, je vais me concentrer sur les capteur de fenêtre, chauffage et éclairage.

Merci,
Ludo

Bonjour,

Je comprends tout à fait. Après plus d’un mois d’utilisation, j’ai perdu toute ma config Z Wave, mes modules sont devenu inconnu, etc…
Ce n’est pas très stable, mais je persévère :slight_smile:
Bon courage

Bertrand

Bonjour,

J’avais oublié de faire un retour.
J’ai bien reçu mon Smart Implant, il est monté, configuré correctement et c’est que du bonheur ! :slight_smile:
C’était pas super évident à configurer mais en suivant d’autres posts de ce forum j’ai pu me débrouiller assez rapidement.

Reste à savoir ce que je vais faire de mon FGS-214…

@bertrand520 votre retour m’inquiète un peu quand même ! :confused: Ce n’est pas possible d’exporter/importer la config Zwave ?

Cordialement,
Clément.

Bonjour Clement356,

Après quelques mois d’utilisation, ou plutôt de familiarisation avec le réseau ZWAVE, voici mon retour d’expérience:

Tout d’abord mon réseau est enfin stable! C’est déjà une bonne nouvelle. Je pilote l’ouverture et la fermeture de mon garage, je lui ai connecté un capteur de position qui me permet de connaitre sa position, idem pour mon portail.
J’ai finalisé l’éclairage de mon allée, que je peux piloté.
J’ai ajouté deux capteurs PIR, et j’ai ajouté un scénario pour déclencher l’éclairage de mon allée quand une personne passe et qu’il y a moins de 100 Lux.
Et pour finir je peux piloter tout cela par la voix sur ma box connecté!

Bref tout fonctionne presque parfaitement (et oui sinon cela ne serait pas drôle)!
J’ai de temps à autre des soucis avec mon FGS 224 qui commande mon portail! j’ai l’impression qu’il se déprogramme ou il y a une mauvaise liaison, mais pour autant il est toujours présent sur le réseau! Il a un ping qui des fois est à plus de 2000ms, alors qu’il sait répondre aussi en moins de 200ms! Je ne comprend pas pourquoi! Est-il défectueux?..

Le point important qu’il faut souligner est que le réseau ne se construit pas en claquant des doigts! On est sur de l’IOT (objet connecté) et que tous les objets discutent entre eux. Et en Zwave cela prend beaucoup de temps, cela peu se compter en jour.
Et le second point important, il faut surveiller la mise à jour du plugin et vérifier s’il n’y a pas de mise à jour de descriptif des documents des modules fgs2x4.
Voilà en espérant avoir été clair!
Cordialement