Erreur Authentification

Tags: #<Tag:0x00007f384fec0bb0>

@jag, @Fifisoft57

bonsoir a tous les deux j’ai également la même config que @Fifisoft57

j’ai eu de nouveau l’erreur tout a l’heure mais dans les log il y a déjà plus les infos a l’heure de l’erreur
on peut augmenter le temps a garder dans un log

sinon je vais également supprimer mon player mini ( actuellement il est juste désactivé )

wait and see

L erreur authentification doit être afficher dans les logs

Il faut augmenter le nombre de ligne des logs dans la configuration de jeedom

Bonjour
Je m’immisce dans votre discussion car j’ai un probleme similaire. Mon plugin freebox fonctionne sauf qu’apres chaque redemarrage de la freebox revolution j’ai le message « Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction ». Je suis obligé à chaque fois de me reauthentifier.
Mon systeme : jeedom 4.0.61 raspberry 3B+ derniere image fournie par jeedom
Merci de votre aide

Hello

Comme dit a chaque fois. Malheureusement sans log je ne peux rien faire.

@leojeedom As-tu essayer de redémarrer juste le Demon quand tu as ce message ? au lieu de refaire l’authentification. Car toi le message apparait uniquement quand tu redémarre le serveur.

Vu que tu redémarres la Freebox, le Token a changé

@ludoviclt @Fifisoft57 @leojeedom
Pour Info : Le code pour l’authentification avec la Freebox n’a pas changé depuis très longtemps (bien avant que je commence à toucher au code). C’est juste le visuel d’appairage qui a évolué afin d’aider les utilisateurs débutant.
Nous avons surtout remonté les messages d’erreur de la Freebox, c’est une demande des utilisateurs ici
Et c’est ce nouveau message qui apparait mais qui ne devrait pas être bloquant mais ch…

Merci de me dire si vous perdez réellement la connexion avec la Freebox. Vous pouvez le voir en enregistrant juste un équipement. si c’est le cas Merci de fournir les Logs à la même heure que le message

Salut @JAG de mon côté c est juste pour information de l erreur car cela ne me dérange aucunement
J ai pas l impression de perdre la liaison de la Freebox et celle ci ne se relance pas non plus

Chez moi tout fonctionne tres bien.

J ai augmenté le nombre de ligne dans mes logs si j ai de nouveau le message d erreur et que celle ci est dans les logs je les remontent bien-sûr oui.

Bonne journée à tout le monde

Dans la Beta de demain, j’ai séparé les messages d’erreur pour savoir ce qui bloque

bon je viens d’avoir l’erreur, je met les logs :
image

[2020-09-05 11:15:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-05 11:15:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/(null)
[2020-09-05 11:15:12][ERROR] : [FreeboxCloseSession]404
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] {"uid":"XXXXXXXX73a03968f927e9d8","success":false,"msg":"Vous devez vous connecter pour accéder à cette fonction","result":{"password_salt":"XXXXXXXXHAiGuDQkXdcZyGCvQH","challenge":"XXXXXXXXXNeyFQ5uH2gz+KCHsY"},"error_code":"auth_required"}
[2020-09-05 11:15:13][ERROR] : Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction
[2020-09-05 11:15:13][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/lte/config(null)
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] {"uid":"XXXXXXXXXb73a03968f927e9d8","success":false,"msg":"Vous devez vous connecter pour accéder à cette fonction","result":{"password_salt":"XXXXXXXXXGuDQkXdcZyGCvQH","challenge":"XXXXXXXX
[2020-09-05 11:15:13][ERROR] : Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction
[2020-09-05 11:15:13][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/config(null)
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] {"uid":"XXXXXXX9b73a03968f927e9d8","success":false,"msg":"Vous devez vous connecter pour accéder à cette fonction","result":{"password_salt":"XXXXXXXXHAiGuDQkXdcZyGCvQH","challenge":"XXXXXXeyFQ5uH2gz+KCHsY"},"error_code":"auth_required"}
[2020-09-05 11:15:13][ERROR] : Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction
[2020-09-05 11:15:13][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-05 11:15:13][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/ftth(null)
[2020-09-05 11:15:17][DEBUG] : [FreeboxPassword]{"success":true,"result":{"logged_in":false,"challenge":"XXXXXXXeyFQ5uH2gz+KCHsY","password_salt":"XXXXXXG5HwHAiGuDQkXdcZyGCvQH","password_set":true}}
[2020-09-05 11:15:17][DEBUG] : [FreeboxOpenSession]{"result":{"session_token":"XXXXXXXXXXhH7NRQuneogAA4CDCOfV0kHtAfcvQ2Ti8sNwbMyOl8eQXABDpSZ","challenge":"XXXXXXXNeyFQ5uH2gz+KCHsY","password_salt":"XXXXXXXHwHAiGuDQkXdcZyGCvQH","permissions":{"parental":true,"contacts":true,"explorer":true,"tv":true,"wdo":true,"downloader":true,"profile":true,"camera":true,"settings":true,"calls":true,"home":true,"pvr":true,"vm":true,"player":true},"password_set":true},"success":true}
[2020-09-05 11:15:18][DEBUG] : │ [FreeboxRequest] {"uid":"XXXXXXXXa03968f927e9d8","success":false,"msg":"Vous devez vous connecter pour accéder à cette fonction","result":{"password_salt":"XXXXXXXHwHAiGuDQkXdcZyGCvQH","challenge":"XXXXXXXXXeyFQ5uH2gz+KCHsY"},"error_code":"auth_required"}
[2020-09-05 11:15:18][ERROR] : Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction

Cool :sunglasses:
Je regarde dans la journée

Merci @Fifisoft57 par contre j ai beau analysé je ne comprend d ou vient l erreur
Ta freebox est en fibre ? Adsl ? 4g possible ?
Elle est en bridge ou pas ?

Même question pour les autres @ludoviclt @leojeedom ?

J’ai besoin de ces infos pour orienter ma recherche

@Fifisoft57 peut tu désactiver cet équipement « Freebox Débits » qq jour pour savoir si cela vient bien de celui la

Merci à tous

Autres questions : Vous avez bien le paramètre de l’IP est bien comme ceci
Capture d’écran 2020-09-05 à 18.56.47

bonsoir @JAG
voici ma config :
Freebox Delta
Mode Bridge
connexion Fibre
Pas de module 4g car il est incorporé dans le module ADSL que j’ai retiré

je soupçonne que l’erreur arrive toute les 3h mais c’est un supposition

j’ai désactivé le module débit

info complémentaire :

je suis sous jeedom 3.3.53
j’ai pas la capture que tu as, j’ai juste ca :
image

Alors je comprends un peu mieux

Vu que tu es V3 le core ne supprime pas les fichiers qui ne servent plus.

As tu moyen de désinstaller le plugin cela ne supprime pas les équipements. Fais bien une sauvegarde avant

Et après retelecharge le plugin. Et refais l appairage avec le nouveau menu appairage qui se trouve dans l interface du plugin.

Et tiens moi au courant

@Fifisoft57 : Il y a sur le fil d’actualité du plugin, une explication du nouveau système d’appairage

je viens de mettre a jour la beta

j’attends de voir ce que cela donne

1 J'aime

pareil j’ai refait une installation complète du plugin
j’attend les logs

1 J'aime

bon , j’ai de nouveau des erreurs :
image

les logs :

[2020-09-06 17:15:08][DEBUG] : ================= CRON pour l'actualisation de : Air Média ==================
[2020-09-06 17:15:08][DEBUG] : ================= CRON pour l'actualisation de : Appareils connectés ==================
[2020-09-06 17:15:08][DEBUG] : ================= CRON pour l'actualisation de : Appareils connectés Wifi Invité ==================
[2020-09-06 17:15:08][DEBUG] : ================= CRON pour l'actualisation de : Wifi ==================
[2020-09-06 17:15:08][DEBUG] : ================= CRON pour l'actualisation de : Freebox Débits ==================
[2020-09-06 17:15:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:15:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/(null)
[2020-09-06 17:15:12][ERROR] : [FreeboxCloseSession]404
[2020-09-06 17:15:13][DEBUG] : [FreeboxPassword]{"success":true,"result":{"logged_in":false,"challenge":"XXXXXXsh1RiZVZqIlC8lwgUETDa","password_salt":"XXXXXXG5HwHAiGuDQkXdcZyGCvQH","password_set":true}}
[2020-09-06 17:15:13][DEBUG] : [FreeboxOpenSession]{"result":{"session_token":"XXXXXXXXX\/XH+hINqlZ4SvuXswzQQkruvRvosah0Y6u18bApX5+3dltO8","challenge":"XXXXXXXXiZVZqIlC8lwgUETDa","password_salt":"XXXXXXXXAiGuDQkXdcZyGCvQH","permissions":{"parental":false,"contacts":true,"explorer":true,"tv":true,"wdo":true,"downloader":true,"profile":true,"camera":true,"settings":true,"calls":true,"home":true,"pvr":true,"vm":true,"player":true},"password_set":true},"success":true}
[2020-09-06 17:15:13][DEBUG] : │ [FreeboxRequest] {"uid":"XXXXXXX03968f927e9d8","success":false,"msg":"Vous devez vous connecter pour accéder à cette fonction","result":{"password_salt":"XXXXXXXXXDQkXdcZyGCvQH","challenge":"XXXXXXXXXXZqIlC8lwgUETDa"},"error_code":"auth_required"}
[2020-09-06 17:15:13][ERROR] : Erreur Authentification : Vous devez vous connecter pour accéder à cette fonction
[2020-09-06 17:15:13][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:15:13][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/lte/config(null)
[2020-09-06 17:15:13][DEBUG] : │ [FreeboxRequest] {"msg":"Aucun module 4G détecté","success":false,"error_code":"noent"}
[2020-09-06 17:15:13][DEBUG] : └─────────
[2020-09-06 17:15:13][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:15:13][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/config(null)
[2020-09-06 17:15:18][DEBUG] : │ [FreeboxRequest] {"success":true,"result":{"ping":true,"remote_access_ip":"XXXXXXX","allow_token_request":true,"is_secure_pass":true,"adblock":true,"adblock_not_set":false,"remote_access":false,"wol":false,"api_remote_access":true,"https_port":18933,"https_available":true,"disable_guest":true,"remote_access_port":46987,"remote_access_min_port":0,"remote_access_max_port":65535,"api_domain":"XXXXXXX.fbxos.fr"}}
[2020-09-06 17:15:18][DEBUG] : └─────────
[2020-09-06 17:15:18][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:15:18][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/ftth(null)
[2020-09-06 17:15:24][DEBUG] : │ [FreeboxRequest] {"success":true,"result":{"sfp_has_power_report":true,"sfp_has_signal":true,"sfp_model":"F-MPON07A","link_type":"pon","sfp_pwr_rx":-1790,"sfp_vendor":"FREEBOX","sfp_pwr_tx":190,"has_sfp":true,"link":true,"sfp_alim_ok":true,"sfp_serial":"XXXX69B29.25","sfp_present":true}}
[2020-09-06 17:15:24][DEBUG] : └─────────
[2020-09-06 17:15:24][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:15:24][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/xdsl(null)
[2020-09-06 17:15:29][DEBUG] : │ [FreeboxRequest] {"msg":"Impossible de récupérer l'état de la connexion: Ce service n'est pas disponible actuellement","success":false,"error_code":"service_down"}
[2020-09-06 17:15:29][DEBUG] : └─────────
[2020-09-06 17:20:08][DEBUG] : ================= CRON pour l'actualisation de : Air Média ==================
[2020-09-06 17:20:08][DEBUG] : ================= CRON pour l'actualisation de : Appareils connectés ==================
[2020-09-06 17:20:08][DEBUG] : ================= CRON pour l'actualisation de : Appareils connectés Wifi Invité ==================
[2020-09-06 17:20:08][DEBUG] : ================= CRON pour l'actualisation de : Wifi ==================
[2020-09-06 17:20:08][DEBUG] : ================= CRON pour l'actualisation de : Freebox Débits ==================
[2020-09-06 17:20:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/(null)
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] {"success":true,"result":{"type":"ethernet","rate_down":31970,"bytes_up":133886634593,"ipv4_port_range":[0,65535],"rate_up":5870,"bandwidth_up":700000000,"ipv6":"XXXXXXXXXXX","bandwidth_down":10000000000,"media":"ftth","state":"up","bytes_down":649494630055,"ipv4":"XXXXXXX"}}
[2020-09-06 17:20:08][DEBUG] : └─────────
[2020-09-06 17:20:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/lte/config(null)
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] {"msg":"Aucun module 4G détecté","success":false,"error_code":"noent"}
[2020-09-06 17:20:08][DEBUG] : └─────────
[2020-09-06 17:20:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/config(null)
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] {"success":true,"result":{"ping":true,"remote_access_ip":"XXXXXXXXX","allow_token_request":true,"is_secure_pass":true,"adblock":true,"adblock_not_set":false,"remote_access":false,"wol":false,"api_remote_access":true,"https_port":18933,"https_available":true,"disable_guest":true,"remote_access_port":46987,"remote_access_min_port":0,"remote_access_max_port":65535,"api_domain":"XXXXXXXXX.fbxos.fr"}}
[2020-09-06 17:20:08][DEBUG] : └─────────
[2020-09-06 17:20:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/ftth(null)
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] {"success":true,"result":{"sfp_has_power_report":true,"sfp_has_signal":true,"sfp_model":"F-MPON07A","link_type":"pon","sfp_pwr_rx":-1779,"sfp_vendor":"FREEBOX","sfp_pwr_tx":190,"has_sfp":true,"link":true,"sfp_alim_ok":true,"sfp_serial":"XXXXXXXXB29.25","sfp_present":true}}
[2020-09-06 17:20:08][DEBUG] : └─────────
[2020-09-06 17:20:08][DEBUG] : ┌───────── Début de Mise à jour
[2020-09-06 17:20:08][DEBUG] : │ [FreeboxRequest] Connexion GET sur la l'adresse mafreebox.freebox.fr/api/v8/connection/xdsl(null)
[2020-09-06 17:20:13][DEBUG] : │ [FreeboxRequest] {"msg":"Impossible de récupérer l'état de la connexion: Ce service n'est pas disponible actuellement","success":false,"error_code":"service_down"}
[2020-09-06 17:20:13][DEBUG] : └─────────

Hello,

Ne reproduisant pas ton erreur sur ma v4 j’ai repris ma v3 afin de faire le test par contre pour me mettre dans la même version de plugin j’ai besoin de savoir si tu est avec la version stable ou beta de Freebox_OS.

1 J'aime

bonjour

pour ma pars en V4 avec la dernières beta de ce jour, toujours pas de retour et je viens de réactiver tous mes équipements et tiles

image

bonsoir

version beta

Bonsoir à tous.

Demain il y aura une beta mais qui ne corrige pas ce problème malheureusement.

Mais pour nous permettre de nous confirmer que le problème vient de Freebox Debit @Fifisoft57 Peut-tu désactiver cet équipement qq jours et voir si tu as toujours l’erreur

OK je refais tout au complet sur ma v3 pour voir si j’arrive a avoir l’erreur que tu as eu afin d’aider @JAG au débogage merci pour ta réponse.

bonsoir

Freebox_OS (2).txt (800,9 Ko)

ça y est après avoir éteint et rallume ma vm je pense

vers les 21h00

edit : je desactive de nouveau les players et ce que je n’utilise pas et relance ma vm

Merci pour tes logs @ludoviclt

Mais tu nous as fait un cas bien particulier. Je pense que tout le monde est dans ce cas si tu rallume ta box.
Il faut attendre que le token soit renouveler

Je prends note du message

Mais je préférais que l’on essaye de l’avoir uniquement en fonctionnement normal dans un premier temps

Merci par avance
Bonne soirée