Erreur 500 (dashboard) lors de l'affichage d'un équipement

Tags: #<Tag:0x00007f38538fa3f8>

bonjour à tous,

je viens de tester ce plugin en ayant pour objectif d’enlever une partie de mes plugins actuels (car celui ci fait vraiment le café, à vue de nez. bravo!)

  • j’ai donc ma clé API, attendu qq 10 aines de minutes (il est noté une 30 aine, j’ai fais un peu plus)
  • j’ai ensuite crée un équipement avec qq commandes pour voir
  • je teste qq commandes, marche nikel !
  • j’affiche donc le widget et là, erreur 500 sur le dashboard

dans les logs du plugin : rien
dans les logs http.error : l’info ci dessous, alors oui ce ne sont pas les logs du plugin mais ça réfère à une partie du code du plugin…

[Thu Sep 10 14:07:52.712464 2020] [:error] [pid 6104] [client 165.225.204.93:63934] PHP Fatal error:  Uncaught Error: Call to a member function execCmd() on boolean in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php:716
Stack trace:
#0 /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php(621): weatherbit->getIcone('daily0')
#1 /var/www/html/core/ajax/object.ajax.php(177): weatherbit->toHtml('dashboard')
#2 {main}
thrown in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php on line 716, referer: --lien de mon jeedom (adresse externe)--

de plus, tous les équipements des différents plugins de mon objet « météo » disparaissent avant affichage d’un équipement du plugin :
screenshot_02
après affichage :
screenshot_01
est-ce que quelqu’un a eu un soucis identique ?
je vous remercie pour les retours :slight_smile: pour le moment, en testant juste les commandes, super boulot sur le plugin !

je suis sous jeedom v4.0.61
OS raspbian stretch
machine raspberry 3

Idem pour moi dans le dashboard et même erreur dans le http.error.

J’up un coup mon thread…
Est-ce un problème quasi isolé ou non ? je vois qu’on est deux à avoir exactement le même soucis, ce qui est quand même intéressant, en soi, mais y’a t il un sujet plus global ? y’a t il besoin de + pour investiguer ? je suis dispo et je peux faire les tests necessaires.
merci :slight_smile:

Bonjour, même problème avec Jeedom v3

Hello et merci pour ce nouveau plugin :kissing_heart:

J’ai cette erreur dans http.error quand je veux rendre le widget visible sur le dashboard avec 500.internal Server Error en entête de ce dernier :roll_eyes:
Mes commande remontes bien dans le plugin…

[Wed Sep 16 08:51:32.965007 2020] [:error] [pid 1134] [client 192.168.254.32:15571] PHP Fatal error:  Uncaught Error: Call to a member function execCmd() on boolean in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php:716
Stack trace:
#0 /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php(621): weatherbit->getIcone('daily0')
#1 /var/www/html/core/ajax/object.ajax.php(177): weatherbit->toHtml('dashboard')
#2 {main}
thrown in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php on line 716, referer: http://192.168.254.37/index.php?v=d&p=dashboard

Une idée ?

Jeedom v4 à jour sur Intel NUC 6CAYH | Linux NUC 4.9.0-12-amd64 | Debian 9.13

Cela concerne que moi apparemment :zipper_mouth_face:

Je viens de désactiver toutes personnalisations avancés et toujours pareil !!!

Sur le 105 installations à ce jour, bien évidemment, personne à cette erreur ? :cold_sweat:

Salut,

A tout hasard as tu essayé de désactivé l’équipement créé dans Weatherbit et voir si tu avais toujours l’erreur?

Merci pour ton intérêt :grinning:

Je n’ai pas cette erreur si je rend l’équipement non visible et activé , et idem si il est visible et non activé.

Au final le problème se pose uniquement sur l’affichage du widget

Tu l’as installé ?

Oui au tout début qu’il est sortie et depuis je n’y ai pas retouché

Capture
Capture1

Merci

Je viens de passer par la beta et plus de problème… :thinking:

Au final, et si j’ai bien compris, ce plugin va remplacer Dark sky et vigilance météo ?

Oui car Darksky va s’arrêter car racheté par Apple et Vigilance Météo je pense qu’a terme il sera remplacé par le plugin Météo France

Bonjour,

meme probleme que vous (erreur 500) lors de l’affichage du plugins (meme en beta)

Bonjour,
Problème identique : erreur 500 dasboard et panneau desktop
Configuration :
Version v4.0.61
JEEDOM SMART
Version du plugin : 2020-08-25 13:37:00
Log dasboard

 [Sun Oct 04 10:14:44.302638 2020] [:error] [pid 17281] [client 192.168.1.88:60483] PHP Fatal error:  Uncaught Error: Call to a member function execCmd() on boolean in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php:716
Stack trace:
#0 /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php(621): weatherbit->getIcone('daily0')
#1 /var/www/html/core/ajax/object.ajax.php(177): weatherbit->toHtml('dashboard')
#2 {main}
  thrown in /var/www/html/plugins/weatherbit/core/class/weatherbit.class.php on line 716, referer: http://192.168.1.40/index.php?v=d&p=dashboard&object_id=11

Bonjour tout le monde problème identique avec une smart ( Version Normal ou beta!)

Les infos remontent bien:

image

Par contre dans le dashboard erreur 500:

image

Si quelqu’un a une idée?

J’ai configurer ma localisation avec geoloc ou jeedom mais le résultat est le même!!

Je me reponds a moi même!

Il faut créer toutes les commandes et cela fonctionne!!!

image

image

Bonjour,
Créer toutes les commandes
Je confirme, ça marche !

okay, un grand merci pour tes tests.
du coup je passe mon chemin, c’est « trop » pour mon utilisation même si je suis sur que c’est un très bon truc pour certains.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.