Démon Z-Wave OK - Mais Echec de la requête … Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused)

Bonjour,
J’ai fait un changement hardware de solution domotique de RPi3 vers RPi4 et de Jessy a Buster pour avoir la dernière version de Jeedom mais tout mon réseau Z-Wave est KO.
Installation from scratch avec restauration de la derniere backup. Aucune erreur jusque là.
Mon probleme reside sur le plugin Openzwave. Le démon est bien lancé mais je n’ai aucune remontée. Pas de paquets qui s’incremente dans les statistiques et aucun noeud dans la table de routage, bref zero.
voici les erreurs que je recupere des logs.
Erreur Javascript
https://jeedom.arsiezis.com/index.php?v=d&m=openzwave&p=openzwave line 2 > injectedScript 396 TypeError: data.controllerNodeCapabilities is undefined

Openzwave

[2021-09-24 09:45:04][INFO] : Graceful stopping the ZWave network.
[2021-09-24 09:45:04][INFO] : Stop Openzwave network.
[2021-09-24 09:45:04][INFO] : ZWave configuration written to user directory.
[2021-09-24 09:45:09][INFO] : Openzwave network are Network is stopped
[2021-09-24 09:45:09][INFO] : The Openzwave REST-server was stopped in a normal way
[2021-09-24 09:45:09][INFO] : Backup xml config file with mode: stop
[2021-09-24 09:45:09][INFO] : Xml config file successfully backup
[2021-09-24 09:45:10][ERROR] : Erreur exécution de la commande [Bureau][Radiateur Bureau][Arret] : Echec de la requête http : http://127.0.0.1:8083/node?node_id=23&instance_id=1&cc_id=38&index=0&type=setvalue&value=0&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
[2021-09-24 09:45:10][ERROR] : Erreur exécution de la commande [Chambres][Radiateur Parents][Arret] : Echec de la requête http : http://127.0.0.1:8083/node?node_id=25&instance_id=1&cc_id=38&index=0&type=setvalue&value=0&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
[2021-09-24 09:45:10][ERROR] : Erreur exécution de la commande [Chambres][Radiateur Romeo][Arret] : Echec de la requête http : http://127.0.0.1:8083/node?node_id=26&instance_id=1&cc_id=38&index=0&type=setvalue&value=0&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
[2021-09-24 09:45:10][ERROR] : Erreur exécution de la commande [Chambres][Radiateur Tia][Arret] : Echec de la requête http : http://127.0.0.1:8083/node?node_id=22&instance_id=1&cc_id=38&index=0&type=setvalue&value=0&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
[2021-09-24 09:45:10][ERROR] : Erreur exécution de la commande [Salle De Bain][Radiateur][Arret] : Echec de la requête http : http://127.0.0.1:8083/node?node_id=13&instance_id=1&cc_id=38&index=0&type=setvalue&value=0&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
[2021-09-24 09:45:11][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device /dev/ttyAMA0 --loglevel info --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback https://127.0.0.1:443/plugins/openzwave/core/php/jeeZwave.php --apikey pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
[2021-09-24 09:45:12][INFO] : Start openzwaved
[2021-09-24 09:45:12][INFO] : Log level : info
[2021-09-24 09:45:12][INFO] : Device : /dev/ttyAMA0
[2021-09-24 09:45:12][INFO] : Callback : https://127.0.0.1:443/plugins/openzwave/core/php/jeeZwave.php
[2021-09-24 09:45:12][INFO] : Cycle : 0.3
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:849: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
[2021-09-24 09:45:12][INFO] : Check if the port REST server available
[2021-09-24 09:45:12][INFO] : --> pass
[2021-09-24 09:45:12][INFO] : Check OpenZWave Devices Database
[2021-09-24 09:45:12][INFO] : --> pass
[2021-09-24 09:45:12][INFO] : Validate zwcfg configuration file(s)
[2021-09-24 09:45:12][INFO] : ... check: /var/www/html/plugins/openzwave/core/class/../../data/zwcfg_0xdb589f9c.xml
[2021-09-24 09:45:12][INFO] : ... check: /var/www/html/plugins/openzwave/core/class/../../data/zwcfg_0x00000000.xml
[2021-09-24 09:45:13][INFO] : ... check: /var/www/html/plugins/openzwave/core/class/../../data/zwcfg_0xff4918e0.xml
[2021-09-24 09:45:13][INFO] : ******** The ZWave network is being started ********
[2021-09-24 09:45:13][INFO] : Start Openzwave network.
[2021-09-24 09:45:13][INFO] : OpenZwave Library Version 1.4.0
[2021-09-24 09:45:13][INFO] : Python-OpenZwave Wrapper Version 0.3.1
[2021-09-24 09:45:13][INFO] : --> pass
[2021-09-24 09:45:13][INFO] : Waiting for network to become ready
[2021-09-24 09:45:13][INFO] : Démon openzwave lancé
[2021-09-24 09:47:20][INFO] : 200 GET /network?type=info&info=getStatus&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el (127.0.0.1) 4.01ms
[2021-09-24 09:47:23][INFO] : 200 GET /network?type=info&info=getNeighbours&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el (127.0.0.1) 1.73ms
[2021-09-24 09:47:23][INFO] : 200 GET /network?type=info&info=getStatus&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el (127.0.0.1) 1.58ms
[2021-09-24 09:47:24][INFO] : 200 GET /network?type=info&info=getNeighbours&apikey=pO9xgEBpIEchvYM2H68xCmGqK3M3p8Z3DqSrmEf7GHXnS4el (127.0.0.1) 2.02ms

Openzwaved

2021-09-24 09:50:12.414 Always, OpenZwave Version 1.4.0 Starting Up
2021-09-24 09:50:12.417 Info, Setting Up Provided Network Key for Secure Communications
2021-09-24 09:50:12.417 Info, mgr,     Added driver for controller /dev/ttyAMA0
2021-09-24 09:50:12.417 Info,   Opening controller /dev/ttyAMA0
2021-09-24 09:50:12.417 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2021-09-24 09:50:12.417 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2021-09-24 09:50:12.418 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-09-24 09:50:13.418 Error, contrlr, ERROR: Dropping command, expected response not received after 1 attempt(s)
2021-09-24 09:50:13.419 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x20) - FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2021-09-24 09:50:14.419 Error, contrlr, ERROR: Dropping command, expected response not received after 1 attempt(s)
2021-09-24 09:50:14.420 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x05) - FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2021-09-24 09:50:15.420 Error, contrlr, ERROR: Dropping command, expected response not received after 1 attempt(s)
2021-09-24 09:50:15.421 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x07) - FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2021-09-24 09:50:16.421 Error, contrlr, ERROR: Dropping command, expected response not received after 1 attempt(s)
2021-09-24 09:50:16.422 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x56) - FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2021-09-24 09:50:17.423 Error, contrlr, ERROR: Dropping command, expected response not received after 1 attempt(s)

j’ai verifié via un netstat que le port 8083 était en ecoute et c’est le cas :
tcp 0 0 127.0.0.1:8083 0.0.0.0:* LISTEN 33 53920 13169/python

et que le process python associé est bien celui du plugin openzwave :
www-data 13169 1.2 1.0 125260 40976 ? Sl 09:50 0:02 /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py --device /dev/ttyAMA0 --loglevel info --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback https://127.0.0.1:443/plugins/openzwave/core/php/jeeZwave.php --apikey myapikey --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid

mon controleur zwave est une carte razberry v1

Que puis je vous donner comme information supplémentaire pour trouver la root cause ?

Cordialement,
R. SUAREZ

Tu as installé quelle version de debian ? Tu as réinstallé les dependances ?

Bonjour,

Pour moi ca ressemble plus à un mauvais port sélectionné ou simplement le contrôleur qui n’est pas vu.
c’est typiquement ce genre d’erreur qu’on aura dans ce cas: pas de noeuds, pas de table (+ les erreurs dans le log du démon)

Et oui, le démon démarre et reste vert dès qu’il reçoit une config et que tout est installé même s’il n’arrive à pas à se connecter au controleur.

Pouvez-vous montrer la page de config du plugin avec la liste des ports proposés?

1 « J'aime »

Bonjour,

Merci pour ta reponse rapide.
Voici le screen de la page de configuration du plugin.

la version de Debian est celle ci :
image

et oui les dependances ont deja été réinstallées :

Le controleur est sur carte gpio c’est bien ca?
Je ne connais pas trop ce type de controleur, avec un lusb est-il listé par le système?
(vous pouvez lancer la commande via l’outils adminstration système dans la configuration jeedom)

et si vous débranchez le controleur, apparait-il toujours dans la liste déroulante de la config du plugin?

c’est 2 actions pour tenter de confirmer que c’est le bon choix à faire dans la liste :slight_smile:

En auto ça marche pas ?

le contrôleur est directement connecté sur les GPIO du coup un lsusb ne donnera pas l’information qu’on cherche.
je vais faire la demarche en enlevant le controleur pour etre sur mais je pense qu’il est bien detecté vu les logs.

non justement car l’autodetection ne fonctionne qu’avec les dongle USB.

Grrrrrrrrrrrrr je viens de trouver !
il y a une incompatibilité entre le bluetooth interne du RPI et la carte Razberry.
J’ai du desactiver le bluetooth :

en SSH
sudo nano /boot/config.txt
et mettre
dtoverlay=disable-bt

exact, c’est un problème connu en plus :grin:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.