Démon Homebridge Shuntingdown

Tags: #<Tag:0x00007fa7a6539cb0>

Bonjour depuis quelques semaine mon démon Homebridge stop quelque minutes après son lancement.
La cause serais que le port 33221 est utilisé par un autre service !
Est il possible de changer ce port sans démarrer le démon ?

Voila la fin des logs au moment de l’erreur :

Homebridge est démarré et a intégré 2 accessoires ! (Si vous avez un Warning Avahi, ne pas en tenir compte) ==--
e[0;37m[7/22/2021, 7:31:50 AM] e[0me[0;36m[Homebridge UI]e[0m e[0;33mHomebridge Config UI X v4.41.1 is listening on :: port 33221e[0m
e[0;37m[7/22/2021, 7:31:51 AM] e[0me[0;36m[Homebridge UI]e[0m e[0;31mError: listen EADDRINUSE: address already in use :::33221e[0m
e[0;37m[7/22/2021, 7:31:51 AM] e[0me[0;36m[Homebridge UI]e[0m e[0;31mAnother process or service on this host is using port 33221.e[0m
e[0;37m[7/22/2021, 7:31:51 AM] e[0me[0;36m[Homebridge UI]e[0m e[0;31mPlease stop the other service or change the port you have assigned to homebridge-config-ui-x.e[0m
e[0;37m[7/22/2021, 7:31:51 AM] e[0me[0;36m[Homebridge UI]e[0m e[0;31mEnding process now.e[0m
[7/22/2021, 7:31:51 AM] Got SIGTERM, shutting down Homebridge...

Bonjour,
Essayez d’abord de redémarrer pour être certain qu’il n’y a pas un ancien process qui ne se serait pas coupé complètement.

Sinon avez-vous installé quelque chose récemment ?

1 J'aime

Le serveur à déjà redémarré plusieurs fois depuis l’apparition du bug.
Non il me semble pas avoir installé d’autre plugin récemment.
C’est arrivé subitement, mais je ne saurais dire depuis quand. Homebridge ne répondait plus sur IPAd

Hello, juste après un redémarrage tu as ce problème ? (Car tu n’as pas répondu clairement)

Si oui peux tu taper ceci :

ss -neopa 

Non cela fait 2 semaines que Homebridge démarre puis s’arrête après 40 secondes. Du à ce défaut de port.

Quel effet aura cette commande ?
Ou je doit la taper ?

Commencez par redémarrer jeedom donc

Comme dit @Mips… faites ce qu’on vous demande dans l’ordre ou on vous l’a demandé… ma commande va juste lister les ports ouverts et par quel processus…

En faite ça fait une bonne semaine que je redémarre Jeedom quasi tous les jours.
Je viens de réglé le problème en récupérant une sauvegarde d’il y a quelques jours, sur une carte SD avec Jeedom fraichement installé.
Pour le moment ça tourne correctement.

Merci à vous d’avoir prit le temps de me répondre.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.