Décalage d'un bouton commande lors du clic

Tags: #<Tag:0x00007f5924cc8bf0>

Bonjour à tous,

Je me suis mis à Jeedom il y a quelques semaines et actuellement j’ai besoin de faire des design.
J’ai un problème de décalage d’un bouton lors du clic dessus.
Voilà le bouton Confort du plugin Thermostat au chargement du design:
1_mode_edition

je clique sur le bouton Confort et il se décale vers le haut:
edition_design_apres_clic

On voit bien que l’encadrement autour du bouton est plus grand que les autres commandes.

Je ne comprends pas ce qui se passe. Sur un autre design je fais exactement la même chose et ça marche très bien.

Avez vous connaissance de ce bug ?

Je vous remercie de vos réponses.

Bonsoir,

J’ai eu exactement le même souci que toi avec le mode “confort” de mon thermostat, il faudrait essayer de recréer le mode pour voir si ça corrige le souci… Pour ma part j’ai finalement ajouté l’équipement complet pour d’autres raisons. Tu peux essayer de replacer la commande et de la verrouiller sans garantie.

c’est pas une histoire de :
Retour à la ligne forcé avant le widget | après le widget ?

Possible mais c’est les modes créés dans le #plugin-thermostat donc le widget est le widget core des commandes action/défaut donc je ne vois pas pourquoi ça le fait avec le mode “confort” et pas les autres, tu penses qu’il faudrait forcer le retour à la ligne avant ou après sur la commande “confort”? Ça se tente!
En fait c’est le cadre de la commande qui se modifie…

Je n’utilise pas ce plugin et je vais pas l’acheter pour faire le test mais si il fonctionne comme les autres core il a les options "Retour à la ligne forcé avant le widget | après le widget " donc juste vérifier que Confort n’ait tout simplement pas la case “Retour à la ligne forcé avant le widget” coché …

Je m’en doute :grinning: je viens de vérifier et non la case n’est pas coché comme sur les autres modes. Mais l’idée est bonne, peut-être qu’il y a un retour à la ligne dans le code du plugin au niveau de la création de la commande du premier mode… Je refais quelques tests dans le week-end selon la réponse de @guillaumeb3147.
Merci à toi.

Salut,

Faudrait regarder ce qui agit sur le positionnement en mode développeur du navigateur (F12 sous Chrome ou clic droit -> inspecter)

Salut @Salvialf,

Oui maintenant que tu me le dis ça me paraît évident, je découvre tout juste le mode développeur et je ne suis pas encore très à l’aise mais il m’a déjà bien aider pour modifier le menu de F$B33 donc j’essaye ça demain et poste le résultat ici.

Pour une fois je vais essayer de ne pas passer ma soirée sur le PC. :roll_eyes:

Bonne soirée. :wink:

Bonjour,
Merci pour vos réponses. Ce n’est pas forcément lié au mode confort car j’ai déjà eu le problème sur d’autres boutons. J’ai finis par le rajouter au moins dix fois et la dixième fois a été la bonne. Le cadre a eu la bonne dimension. Je n’ai rien changé dans les paramètres du widget et en insistant c’est passé.

Bonjour,

Tant mieux si tu as résolu ton souci même si le forcing n’ai pas forcément la meilleure solution.
De mon côté je n’arrive plus à reproduire le souci… Donc je ne vais pas non plus chercher les problèmes. :slightly_smiling_face: