Configuration BLEA en local only

Tags: #<Tag:0x00007fcbbf1f6250>

Bonjour à tous,

Je me permets de vous demander de l’aide car je galère pas mal avec le plugin BLEA. Comme déjà précisé dans mon précédent message, je suis nouveau sur Jeedom (et dans la Domotique en général) et je pense ne pas avoir bien configuré le plugin.

Le problème est que, en suivant les tutos, j’avais dans la tête le fait que mon RPI4 sur lequel est installé mon Jeedom est muni d’une antenne bluetooth et que mes outils bluetooth étaient suffisamment proches de ma box pour ne pas avoir besoin d’acheter de relais pour le moment.

Cependant, ce n’est qu’après avoir suivit un tutoriel d’installation que je crois comprendre que je ne suis pas censé installer mon bluetooth local comme une antenne. Car c’est effectivement ce que j’ai fait. J’ai créé une antenne « Bluetooth RaspPi4 » mais qui est en fait mon RPI4 local…

Du coup je cherche partout comment installer BLEA sans antenne relais en ne se reposant que sur l’antenne local mais je ne trouve pas…

Il s’avère que, malgré tout, BLEA fonctionnait jusqu’il y a quelques jours. Bizarrement il semblait que le plugin n’acceptait de scanner que lorsque l’antenne « Bluetooth RaspPi4 » était activé mais que dans les faits, seul l’antenne « local » se connectait aux divers devices :
Capture0

Du coup je sui parvenu à connecter un thermomètre Xiaomi. Mais désormais, pour je ne sais quelle raison, je ne parviens plus à scanner quoi que ce soit…

Dans les Logs, je vois que l’antenne « Bluetooth RaspPi4 » (qui n’est autre que mon RPI4 Local) n’arrête pas de planter (alors que ça n’était pas le cas avant) :

  • Log blea :
[2021-04-02 01:00:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:05:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:10:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:15:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:20:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:25:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:30:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:35:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:40:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:45:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-04-02 01:50:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
  • Log blea_local :
[2021-03-26 13:00:06.564][ERROR] : GLOBAL------Fatal error : [Errno 98] Address already in use

Je m’en remets donc à la communauté pour m’aider à configurer correctement BLEA avec mon antenne locale comme seule et unique antenne.

Ma config :

  • Matériels : RPI4 sous Raspbian GNU/Linux 10 (buster) ;
  • Version Jeedom Core : 4.1.20 ;

La configuration du plugin :
Capture1
Capture2

J’ai essayé de vous donner le max d’info sur mes configs mais j’en ai certainement oublié. N’hésitez pas à me demander.

Merci d’avance pour votre aide,

Georgio

Lo,

Tu n’as indiqué aucune clef dans le champ Port clef bluetooth,
Une fois sélectionnée, sauvegarde, le démon passera en statut OK,

Au plaisir, bonne journée,

1 J'aime

Bonjour,

Alors oui, la réponse de Toms est certainement la solution. Maintenant pour la cause, il faut trouver pourquoi le Bluetooth interne du Raspberry Pi 4B n’est pas activé.
Avez vous usage du port GPIO ? Avez vous récemment installé le plugin Z-Wave (ses dépendances ?).

Si c’est le cas, il faut réactiver le Bluetooth, on en parle en fonction de vos réponses.

Par contre, si vous avez installé une antenne sur le Raspberry Pi local, il faut commencer par la supprimer. En effet, les antennes au sens plugin BLEA, c’est sur du matériel déporté.

1 J'aime

Hello à tous les 2, merci pour vos retours,

Tu n’as indiqué aucune clef dans le champ Port clef bluetooth

Le truc c’est que le menu déroulant est vide (je ne sais pas pourquoi). Il n’y a que l’option « Aucun »…
Capture4

Avez vous usage du port GPIO ?

Je ne sais pas, je ne sais pas trop ce que c’est (je l’ai dit, je suis un peu noob :sweat_smile:). Mais je ne crois pas. J’ai installé mon RPI4 dans un boitier acheté sur Amazon et n’y ai branché que le ventilateur fourni avec le boitier. A part ça je n’utilise que 2 port USB (Un USB 3 pour le SSD sur lequel tourne mon RPI 4, et un USB 2 sur lequel est branché ma clé ZigBee ConBee).

Avez vous récemment installé le plugin Z-Wave (ses dépendances ?)

Non, seulement une clé ConBee récemment. Mais effectivement je ne crois pas avoir eu de scan bluetooth réussi depuis l’installation de ma clé ConBee et je ne crois pas me souvenir que ça ne marchait déjà pas avant son installation. Penses-tu que l’installation de cette clé aurait pu avoir un impact ?

Si c’est le cas, il faut réactiver le Bluetooth, on en parle en fonction de vos réponses.

Comment savoir si le bluetooth a été désactivé ? Et comment le réactiver si c’est le cas ?

Par contre, si vous avez installé une antenne sur le Raspberry Pi local, il faut commencer par la supprimer. En effet, les antennes au sens plugin BLEA, c’est sur du matériel déporté.

Ok c’est fait, je l’ai supprimée. Mais du coup, comme expliqué dans mon premier message, je ne trouve pas de tuto expliquant comment installer BLEA en utilisant seulement l’antenne local.

Merci beaucoup pour votre aide :slight_smile:

Tu peux commencer par rentrer en ssh sur ta pi depuis putty par exemple,
Envoi cette commande service bluetooth status
Cette commande te donnera en retour le statut de ton bluetooth sur ta framboise,

Au plaisir,

1 J'aime

@Toms, voici ce que me retourne la commande :
Capture d’écran 2021-04-07 à 17.17.27

Une idée ?

Merci encore pour ton aide,

Georgio

Bonsoir.

En ssh, faites la commande :
hciconfig

Le retour ici.

Bonsoir @Fabrice,

La commande hciconfig donne le résultat suivant :
Capture d’écran 2021-04-07 à 19.14.32

Merci pour votre aide

Vous avez redemarré pour voir si cela ne réactive pas le port
Car là, il est down.

En principe, il faut faire :
sudo hciconfig hci0 up

Et pour cause, il n’y a rien à faire d’autre que d’installer le plugin, les dépendances du plugin et c’est tout. La documentation suffit pour cela. Il ne faut pas installer d’antenne en local

Bonjour,
Pour compléter ce qui est dit ci dessus, attention car sur votre première capture
Capture0
On dirait que vous avez créé une « antenne » sur votre pi (local) sur lequel est installé jeedom si j’ai bien suivi.

Il ne faut pas faire cela, cela va créer des conflits.

Il ne faut ajouter des antennes que pour des pi supplémentaires, sur lequel jeedom n’est pas installé.

Bonjour @Fabrice,

Comme conseillé, j’ai redémarrer ma box => sans succès… :disappointed:

J’ai ensuite exécuté la commande sudo hciconfig hci0 up et ai obtenu :

Can't init device hci0: Connection timed out (110)

Je ne sais donc pas trop quoi faire…

En revanche, cette histoire m’a fait me rappeler qu’en essayant de faire fonctionner ma clé ConBee (j’avais pas mal galéré aussi :sweat_smile:), j’avais lu un post duquel j’avais cru comprendre qu’il fallait « désactiver les serials » ou un truc comme ça avec la commande sudo raspi-config. En toute honnêteté je ne savais pas trop ce que ça voulais dire et j’ai tenté un truc… (je sais c’est pas bien… :sweat:)

Du coup j’ai été dans :
Capture d’écran 2021-04-08 à 11.05.48

Puis je ne me souviens plus de la question qui m’a été posée mais je crois avoir désactivé un truc…

Vous pensez que ça a un rapport ?

Merci encore pour votre aide !

Bonjour,

Copiez ici (le contenu txt pas une copie d’écran) du fichier config.txt :
cat /boot/config.txt

Voici le contenu du fichier config.txt :

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
gpu_mem=16
gpu_freq=250
enable_uart=0

On va tester un truc,

En ssh :
sudo nano /boot/config.txt

Remplacez ces lignes :

gpu_mem=16
gpu_freq=250
enable_uart=0

Par ces lignes :

# gpu_mem=16
# gpu_freq=250
# enable_uart=0

Puis, sudo reboot

Pour les lignes :

# gpu_mem=16
# gpu_freq=250

C’est définitif, ce n’est pas à faire sur les Raspberry Pi4B.

Pour les lignes :

# gpu_mem=16
# gpu_freq=250

C’est définitif, ce n’est pas à faire sur les Raspberry Pi4B.

Ah… Mais moi j’ai bien un Raspberry Pi 4B… Est-ce que je dois quand même le faire ? Ca fait quoi exactement ? Ca sert à quoi à la base ?

Justement, comme vous avez un Raspberry Pi 4B, il ne faut pas activer ces lignes (c’est des optimisations pour ceux qui on des Raspberry Pi4 (moins de mémoire RAM).

Le fait de mettre le signe # devant une ligne, fait que la commande de cette ligne devient un commentaire (elle n’est donc plus interprété).
Cela revient à supprimer la ligne (mais le # permet facilement de revenir en arrière).

Donc, faites-le pour les 3 lignes que j’ai indiqué, il est possible que cela soit la dernière ligne (enable_uart=0) qui désactive le Bluetooth chez vous.
Puis, une fois sauvegardé, faites un control :
cat /boot/config.txt
et regardez en bas.

Si c’est bien sauvegardé, faite :
sudo reboot

Puis, regardez dans le plugin BLEA si le port Bluetooth est de nouveau accessible.

1 J'aime

Super ! Merci beaucoup, ça re-fonctionne ! C’est génial ! :tada::tada::smiley:

1 J'aime

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.