Comment installer jeedom sur un Raspberry Pi4

Bonjour,
Je suis tout nouveau et j’essaye d’installer Jeedom sur un Raspberry Pi4.

Premierement, j’ai suivi ceci.
Quelle est la différence entre Jeedom Mini et Jeedom Smart? est-ce que je suis concerné par ceci, si j’ai un raspberry Pi4?

Je suis passé à l’étape 4. J’avais déjà une carte SD avec la derniere version de Rasbian installé.
Dans mon home, j’ai créé un dossier

cd /home/pierrot/
sudo mkdir jeedom
cd jeedom

Puis j’ai lancé cette commande

wget -O- https://raw.githubusercontent.com/jeedom/core/master/install/install.sh | sudo bash

Il y a pas mal de truc qui se sont passé, mais je m’attendais à avoir un dossier importé pour ensuite passer la commande

./install.sh -w /var/www/html -z -m Jeedom

Mais dans un autre sense, le wget lancais déjà un install.
Je n’ai aussi rien vu de www dans /var/

Deuxième solution
Ensuite, j’ai suivi ceci.
A un certain point, il est demandé de télécharger l’image. (vous trouverez le lien des images sous Téléchargement de Etcher et Jeedom, depuis le précédent lien. Je ne peux mettre que deux liens). Sauf que je ne savais pas quoi choisir entre les 4 choix, et tout particulièrement entre

  • Jeedom-jeeboard-3.0.11.zip
  • jeedom_jeeboard_3.3.24_stretch.zip

J’ai opté pour la version 3.3.24 mais si stretch indique un version antérieur de Rasobain.

Après avoir gravé l’image sur ma carte SD, j’ai connecté mon rasoberry et je l’ai allumé, mais rien y fait. L’OS n’a pas démarré. Même après 5 minutes.

Installation de Jeedom

Brancher votre Raspberry au réseau (cable ethernet)
Insérez votre carte SD préparée avec amour
Mettre l’alimentation

Vous allez attendre 5 minutes et… c’est tout.

Je suis donc un peu confu, car j’ai aussi entendu que Jeedom ne tournait pas parfaitement, ou n’était pas supporté sur la derbière vesrion de Rasbain, et qu’en plus, selon les échos que j’ai eu, Jeesdon sur Stretch ne tourne pas sur un Pi4.

Donc, qu’elles sont les conseils et démarche que vous me conseillerez pour installer Jeedom sur un Raspberry Pi4.

Je préfère. télécharger une image de Rasbpian sur mon Pi4 et installer Jeedom en ligne de commande, comme j’ai commencé à le faire, mais comment donc le faire correctement, ou comment vérifier le résultat de l’exécution de

wget -O- https://raw.githubusercontent.com/jeedom/core/master/install/install.sh | sudo bash

Milles merci pour vous lumières

Bonsoir,

WoW oui tu es vraiment perdu !

Question version de raspbian, tu peux mettre du Buster lite mais sache que certains plugins risquent de poser problème (des vieux ou peu maintenus)

Jeedom smart et mini, va voir sur www.jeedom.com , tu veras que c’est du matériel (comme ton raspberry)

Une fois ton système raspbian installé tu dois utiliser ton premier lien et la section “autre”. Donc tu raspi-config, tu changes ton mot de passe, tu active ssh, tu défini ta locale.

Ensuite comme indiqué (peu importe où tu te trouves mais typiquement dans /home/pi (utilisateur par défaut)) tu tapes :

wget https://raw.githubusercontent.com/jeedom/core/master/install/install.sh
sudo chmod +x install.sh
sudo ./install.sh

Et tout va se lancer !

Bonjour,
Sans faire de pub ou quoi mais le tuto qui est sur domo-blog fonctionne.

Oui le tuto de domo blog fonction bien pour le rpi 4, une fois que tu a mis buster lite sur le rpi tu a une ligne de commande a tapé.

Dsl, j’y suis allé à la hâte. En fait, il y a aussi la façon d’installer raspbian buster sur le RPi 4. Ce qui est important dans ce genre de tuto, c’est de bien lire les anecdotes. De souvenir de debian buster, il y a quelques particularités après l’installation.

Bonjour à tous et merci pour vos réponses. J’ai réussi.
Je ne sais pas ce que j’ai fait quand j’ai lancé cette commande, mais après avoir réinstallé le dernier OS de Rasbian et fait les principaux settings, ceci à bien fonctionné

wget https://raw.githubusercontent.com/jeedom/core/master/install/install.sh
sudo chmod +x install.sh
sudo ./install.sh

sauf que le processus a été interrompu 4 fois car il n’arrivait pas insttalé ntpdate, maria-db. mysql etc.

A chaque interruption j’ai du lancer ces commandes, une après l’autre


sudo apt-get install ntpdate 
sudo apt-get install mariadb-client mariadb-common mariadb-server
sudo apt-get install apache2 apache2-utils libexpat1 ssl-cert
sudo apt-get install php libapache2-mod-php php-json php-mysql

Puis, a chaque fois j’ai relancé l’installation y arrriver à la fin.

Je dois maintenant chercher comment ajouter mon ampoule et mon capteur de mouvement, pour faire mes premiers exercise :slight_smile:

Par contre j’essaye d’inclure mon premier capteur de mouvement.

Je suis allé dans pulgin -> z-wave et j’ai cliqué sur “mode inclusion” pour le passer en mode inclusion.
Après le clique, il me pose une question de sécurité

  1. Mode non securité.
  2. mode securisé.

Je pense que ca un lien avec le http ou le https?

Je reçois ce messge d’erruer

Echec de la requête http : http://127.0.0.1:8083/controller?type=addNode&security=0&apikey=rs4rQCQXwBEsXc8GugNQyyCD60v4J30a Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused

Aussi bien avec l’un ou l’autre choix.

J’ai donc installé ufw (firewall) et j’ai activer les port 21,22 et surtout le 8083

Mais malheureusement rien y faire. Le message d’erreur s’affiche toujours.

Ai-je bien commencer en intégrant un capteur?

Milles mercis pour vos lumières et tout bon dimanche

Pas de rapport entre https et inclusion sécurisée
Ici une explication

Merci beaucoup pour ces informations. Je le parcours et j’ai modifier ma clé par défaut.
Néanmoins, je pose une question au sujet du démon. Je n’arrive pas à avoir le status en vert
02
34
Est-ce que ca peut être la source du problème? et comment vérifier le statut alors?
(Après modifier la clé, j’ai redémarré le demon)

Merciii

J’ai fait plusieur chose pour résoudre le problème. Premierement, quand j’ai fait l’installation, je n0avais pas min routeur alors je me suis débrouyer avec mon iPhone.
Maintenant que j’ai mon routeur, j’ai modifié la configuration de mon réseau et je travaille avec l’adresse IP fourni par mon routeur, qui est maintenant réservée au raspberry.

J’ai réinstallé le plugin z-wave et j’ai copié une clé de sécurisé.

Aussi, j’ai changé “Port de clé z-wave” sur “Raspberry Pi…” Tout est vert maintenant

J’anticipe le prochain problème, si pi4 et zwave sur gpio, il faut couper le BT

Hello, merci beaucoup. On vient de me le signaler et je vais le couper. Merci pour l’info et bonne semaine.

J’ai fais un article ici pour l’installation de Jeedom sur un Raspberry Pi4, si jamais et à toute fin utile

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.