Arp-scan : commande introuvable depuis migration debian 10?

Tags: #<Tag:0x00007fcbb57f8f90>

Bonjour,

Je suis en v4 stable sur une debian 9 récemment migrée sur debian 10 (selon l’ancien tuto de Loic).
Tout fonctionne bien, sauf la commande arp-scan du plugin network.
J’ai essayé en ssh, et apparemment, sans sudo, un user normal (moi au www-data) ne peuvent plus executer arp-scan.
La cause possible : le fichier n’est plus dans /usr/bin, mais dans usr/sbin.
Suis-je le seul?
J’ai essayé de réinstaller le plugin network, sans succès.

Si qqun a une idée, je l’en remercie d’avance.

EDIT : Mes excuses, j’ai confondu arp-scan et arping (mais la question reste ouverte : comment executer une commandes dans usr/sbin avec www-data?

La commande arp est bien dans /usr/sbin sous Buster
Par contre pas d’option -scan comme le montre man arp

Merci, c’est bien l’impression que j’avais aussi. Du coup, c’est le cas aussi pour arping utilisé par le plugin NetWork. Et j’ai l’impression que chez moi, ca ne marche plus avec le user www-data.

Est-ce qu’il y a qqch a faire pour que le user www-data puisse l’executer (apparemment avec sudo dans le code du plugin) ?

Edit : je parlais des commandes arp-scan et arping.
présentes et installée dans /usr/sbin

De mon coté aucune commande arp-scan sous Buster 10.7. Probablement un paquet spécifique que tu as du installer ou installé par un plug in .
Idem pour la commande arping

Oui, j’ai installé arp-scan (pour le plugin ping, via apt-get).
(Et j’imagine que arping a été installé par le plugin network.)

OK . Donc mon aide s’arrête la hélas car je n’ai pas installé ces paquets.
Bon courage malgré tout.

Merci à toi.

Hello +1 je viens de basculer sur proxmox j’en ai profité pour allé sur buster avant la restauration et ça ne fonctionnait plus.

Je viens de faire cette manip ça a l’air d’etre de nouveau fonctionnel :

sudo apt-get install arp-scan
sudo visudo -s

Et ajoutez dans le fichier :
www-data ALL=NOPASSWD: /bin/ping
www-data ALL=NOPASSWD: /usr/sbin/arp-scan
www-data ALL=NOPASSWD: /usr/sbin/arping

++++

hello, en faite j’ai toujours le même problème avec ARP donc si quelqu’un passe par la avec la solution :wink: +++