Zwave Demon NOK

Tags: #<Tag:0x00007f282cff19e0>

Bonsoir à tous,

J’ai branché sur mon Raspberry pi 3 un SSD. J’ai installé JEEDOM ainsi que quelques plugins qui fonctionnent bien.
Le problème, seul le plugin Zwave ne marche pas…

En effet, j’ai branché ma clé Zwave sur le port USB de mon Raspberry, il est bien reconnu sur le port TTACM0. Les dépendances ont bien été installées et j’ai laissé par défaut le port 8083.
Je n’arrive pas à avoir le DEMON en OK… Voici le log :

> [2020-08-02 18:00:39][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log
> [2020-08-02 18:04:51][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
> [2020-08-02 18:04:52][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device /dev/ttyACM0 --loglevel debug --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback http://127.0.0.1:80/plugins/openzwave/core/php/jeeZwave.php --apikey **** --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
> ('The dependency of openzwave plugin are not installed. Please check the plugin openzwave configuration page for instructions', 'error')
> ('Error: No module named tornado.web', 'error')
> [2020-08-02 18:05:26][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log

Merci par avance pour votre aide :slight_smile:
Toadman.

Bonjour,
Je pense que le log est assez clair pourtant…

J’ai relancé les dépendances plusieurs fois que ce soit par l’interface JEEDOM ou Linux… Et à chaque fois :

Everything is successfully installed!

image

Oui mais il ne faut pas s’y fier… ça affiche toujours ça dès que tu arrives la fin de l’installation des dépendances… mais ça ne tient pas compte des erreurs éventuelles avant

J’ai également lancé les dépendances par le Rasp directement en tapant :
sudo bash -x /var/www/html/plugins/openzwave/resources/install_apt.sh

> Lancement de l'installation/mise à jour des dépendances openzwave
> Get:1 LIEN://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
> Get:2 LIEN://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
> Get:3 LIEN://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
> Get:4 LIEN://archive.raspberrypi.org/debian buster/main armhf Packages [330 kB]
> Get:5 LIEN://raspbian.raspberrypi.org/raspbian buster/contrib armhf Packages [58.7 kB]
> Error: Timeout was reached
> Fetched 13.4 MB in 19s (713 kB/s)
> Reading package lists...
> Installation des dependances
> Reading package lists...
> Building dependency tree...
> Reading state information...
> build-essential is already the newest version (12.6).
> g++ is already the newest version (4:8.3.0-1+rpi2).
> gcc is already the newest version (4:8.3.0-1+rpi2).
> git is already the newest version (1:2.20.1-2+deb10u3).
> libjpeg-dev is already the newest version (1:1.5.2-2).
> libudev-dev is already the newest version (241-7~deb10u4+rpi1).
> make is already the newest version (4.2.1-1.2).
> python-dev is already the newest version (2.7.16-1).
> python-louie is already the newest version (1.1-4).
> python-lxml is already the newest version (4.3.2-1).
> python-pyudev is already the newest version (0.21.0-1).
> python-requests is already the newest version (2.21.0-1).
> python-serial is already the newest version (3.4-4).
> python-setuptools is already the newest version (40.8.0-1).
> unzip is already the newest version (6.0-23+deb10u1).
> python-pip is already the newest version (18.1-5+rpt1).
> The following package was automatically installed and is no longer required:
>   rpi-eeprom-images
> Use 'sudo apt autoremove' to remove it.
> 0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
> Installation des dependances Python
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: urwid in /usr/local/lib/python3.7/dist-packages (2.1.0)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: louie in /usr/local/lib/python3.7/dist-packages (2.0)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: six in /usr/lib/python3/dist-packages (1.12.0)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Collecting tornado
>   Using cached LIENs://www.piwheels.org/simple/tornado/tornado-6.0.4-cp37-cp37m-linux_armv7l.whl (428 kB)
> Installing collected packages: tornado
> Successfully installed tornado-6.0.4
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> mkdir: cannot create directory '/opt': File exists
> Désinstallation de la version précédente
> Installation de Python-OpenZwave
> Found existing installation: Cython 0.29.2
> ERROR: Cannot uninstall 'Cython'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
> apt-get install --force-yes -y cython
> Reading package lists...
> Building dependency tree...
> Reading state information...
> cython is already the newest version (0.29.2-2).
> The following package was automatically installed and is no longer required:
>   rpi-eeprom-images
> Use 'sudo apt autoremove' to remove it.
> 0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
> W: --force-yes is deprecated, use one of the options starting with --allow instead.
> Installing dependencies for python : 2 7 16
> apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
> Reading package lists...
> Building dependency tree...
> Reading state information...
> python-dev is already the newest version (2.7.16-1).
> python-docutils is already the newest version (0.14+dfsg-4).
> python-louie is already the newest version (1.1-4).
> python-setuptools is already the newest version (40.8.0-1).
> python-pip is already the newest version (18.1-5+rpt1).
> The following package was automatically installed and is no longer required:
>   rpi-eeprom-images
> Use 'sudo apt autoremove' to remove it.
> 0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
> W: --force-yes is deprecated, use one of the options starting with --allow instead.
> apt-get install --force-yes -y build-essential libudev-dev g++
> Reading package lists...
> Building dependency tree...
> Reading state information...
> build-essential is already the newest version (12.6).
> g++ is already the newest version (4:8.3.0-1+rpi2).
> libudev-dev is already the newest version (241-7~deb10u4+rpi1).
> The following package was automatically installed and is no longer required:
>   rpi-eeprom-images
> Use 'sudo apt autoremove' to remove it.
> 0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
> W: --force-yes is deprecated, use one of the options starting with --allow instead.
> apt-get install --force-yes -y cython
> Reading package lists...
> Building dependency tree...
> Reading state information...
> cython is already the newest version (0.29.2-2).
> The following package was automatically installed and is no longer required:
>   rpi-eeprom-images
> Use 'sudo apt autoremove' to remove it.
> 0 upgraded, 0 newly installed, 0 to remove and 63 not upgraded.
> W: --force-yes is deprecated, use one of the options starting with --allow instead.
> pip install nose-html
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: nose-html in /usr/local/lib/python3.7/dist-packages (1.1)
> Requirement already satisfied: nose>=0.11.1 in /usr/local/lib/python3.7/dist-packages (from nose-html) (1.3.7)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> pip install nose-progressive
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: nose-progressive in /usr/local/lib/python3.7/dist-packages (1.5.2)
> Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python3.7/dist-packages (from nose-progressive) (1.7)
> Requirement already satisfied: nose>=1.2.1 in /usr/local/lib/python3.7/dist-packages (from nose-progressive) (1.3.7)
> Requirement already satisfied: six in /usr/lib/python3/dist-packages (from blessings<2.0,>=1.3->nose-progressive) (1.12.0)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> pip install coverage
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: coverage in /usr/local/lib/python3.7/dist-packages (5.1)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> pip install nose
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: nose in /usr/local/lib/python3.7/dist-packages (1.3.7)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> pip install pylint
> Looking in indexes: LIENs://pypi.org/simple, LIENs://www.piwheels.org/simple
> Requirement already satisfied: pylint in /usr/local/lib/python3.7/dist-packages (2.5.2)
> Requirement already satisfied: toml>=0.7.1 in /usr/local/lib/python3.7/dist-packages (from pylint) (0.10.1)
> Requirement already satisfied: astroid<=2.5,>=2.4.0 in /usr/local/lib/python3.7/dist-packages (from pylint) (2.4.1)
> Requirement already satisfied: mccabe<0.7,>=0.6 in /usr/local/lib/python3.7/dist-packages (from pylint) (0.6.1)
> Requirement already satisfied: isort<5,>=4.2.5 in /usr/local/lib/python3.7/dist-packages (from pylint) (4.3.21)
> Requirement already satisfied: six~=1.12 in /usr/lib/python3/dist-packages (from astroid<=2.5,>=2.4.0->pylint) (1.12.0)
> Requirement already satisfied: typed-ast<1.5,>=1.4.0; implementation_name == "cpython" and python_version < "3.8" in /usr/local/lib/python3.7/dist-packages (from astroid<=2.5,>=2.4.0->pylint) (1.4.1)
> Requirement already satisfied: wrapt~=1.11 in /usr/local/lib/python3.7/dist-packages (from astroid<=2.5,>=2.4.0->pylint) (1.12.1)
> Requirement already satisfied: lazy-object-proxy==1.4.* in /usr/local/lib/python3.7/dist-packages (from astroid<=2.5,>=2.4.0->pylint) (1.4.3)
> WARNING: You are using pip version 20.1.1; however, version 20.2 is available.
> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
> #pip install docutils
> #pip install setuptools
> #The following line crashes with a core dump
> #pip install "Cython==0.22"
> 
> Dependencies for users installed (python 2 7 16)
> sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
> cd openzwave && make
> make[1]: Entering directory '/opt/python-openzwave/openzwave'
> CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
> make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
> Building OpenZWave Version 1.4.-1
> Building tinystr.o
> Building tinyxmlerror.o
> Building tinyxml.o
> Building tinyxmlparser.o
> Building hid.o
> Building aeskey.o
> Building aescrypt.o
> Building aestab.o
> Building aes_modes.o
> Building Security.o
> Building Proprietary.o
> Building ClimateControlSchedule.o
> Building BarrierOperator.o
> Building ThermostatFanMode.o
> Building ControllerReplication.o
> Building BasicWindowCovering.o
> Building Color.o
> Building ZWavePlusInfo.o
> Building SoundSwitch.o
> Building CRC16Encap.o
> Building MeterPulse.o
> Building SensorBinary.o
> Building Configuration.o
> Building CommandClass.o
> Building SwitchToggleBinary.o
> Building ThermostatMode.o
> Building Battery.o
> Building TimeParameters.o
> Building UserCode.o
> Building CentralScene.o
> Building SwitchMultilevel.o
> Building ThermostatFanState.o
> Building DoorLock.o
> Building SwitchToggleMultilevel.o
> Building ApplicationStatus.o
> Building DoorLockLogging.o
> /opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp: In member function 'virtual bool OpenZWave::DoorLockLogging::HandleMsg(const uint8*, uint32, uint32)':
> /opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp:312:15: warning: passing argument 1 to restrict-qualified parameter aliases with argument 4 [-Wrestrict]
>       snprintf(usercode, sizeof(usercode), "%s %d", usercode, (int)_data[12+i]);
>                ^~~~~~~~                             ~~~~~~~~
> Building SensorAlarm.o
> Building NodeNaming.o
> Building WakeUp.o
> Building ManufacturerProprietary.o
> Building SwitchAll.o
> Building Lock.o
> Building Association.o
> Building MultiCmd.o
> Building Clock.o
> Building Powerlevel.o
> Building Meter.o
> Building AssociationCommandConfiguration.o
> Building SensorMultilevel.o
> Building ThermostatOperatingState.o
> Building MultiChannelAssociation.o
> Building Indicator.o
> Building SceneActivation.o
> Building MultiInstance.o
> Building Language.o
> Building Version.o
> Building Alarm.o
> Building Basic.o
> Building CommandClasses.o
> Building ManufacturerSpecific.o
> In file included from /usr/include/c++/8/map:60,
>                  from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
>                  from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
> /usr/include/c++/8/bits/stl_tree.h: In function 'std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::iterator std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::_M_emplace_hint_unique(std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::const_iterator, _Args&& ...) [with _Args = {const std::piecewise_construct_t&, std::tuple<long long int&&>, std::tuple<>}; _Key = long long int; _Val = std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>; _KeyOfValue = std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >; _Compare = std::less<long long int>; _Alloc = std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >]':
> /usr/include/c++/8/bits/stl_tree.h:2411:7: note: parameter passing for argument of type 'std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator' {aka 'std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >'} changed in GCC 7.1
>        _Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::
>        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> In file included from /usr/include/c++/8/map:61,
>                  from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
>                  from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
> /usr/include/c++/8/bits/stl_map.h: In static member function 'static bool OpenZWave::ManufacturerSpecific::LoadProductXML()':
> /usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type 'std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator' {aka 'std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >'} changed in GCC 7.1
>     __i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
> /usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type 'std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator' {aka 'std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >'} changed in GCC 7.1
>     __i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
> /usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type 'std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator' {aka 'std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >'} changed in GCC 7.1
>     __i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
> Building ThermostatSetpoint.o
> Building NoOperation.o
> Building EnergyProduction.o
> Building DeviceResetLocally.o
> Building Hail.o
> Building Protection.o
> Building SwitchBinary.o
> Building Value.o
> Building ValueList.o
> Building ValueButton.o
> Building ValueInt.o
> Building ValueStore.o
> Building ValueDecimal.o
> Building ValueRaw.o
> Building ValueString.o
> Building ValueByte.o
> Building ValueBool.o
> Building ValueSchedule.o
> Building ValueShort.o
> Building Controller.o
> Building Wait.o
> Building Thread.o
> Building Stream.o
> Building Log.o
> Building HidController.o
> Building Mutex.o
> Building SerialController.o
> Building Event.o
> Building FileOps.o
> Building TimeStamp.o
> Building FileOpsImpl.o
> Building TimeStampImpl.o
> Building WaitImpl.o
> Building ThreadImpl.o
> Building LogImpl.o
> Building MutexImpl.o
> Building SerialControllerImpl.o
> Building EventImpl.o
> Building Options.o
> Building Scene.o
> Building Utils.o
> Building Driver.o
> Building ZWSecurity.o
> Building Group.o
> Building Node.o
> Building Manager.o
> Building Msg.o
> Building Notification.o
> Creating vers.cpp
> Building vers.o
> Linking Static Library
> Linking Shared Library
> Making ozw_config file
> make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
> CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
> make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
> Building Main.o
> Linking /opt/python-openzwave/openzwave/.lib/MinOZW
> g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
> Creating Temporary Shell Launch Script
> make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
> make[1]: Leaving directory '/opt/python-openzwave/openzwave'
> python setup-lib.py build
> running build
> running build_ext
> cythoning src-lib/libopenzwave/libopenzwave.pyx to src-lib/libopenzwave/libopenzwave.cpp
> /usr/lib/python2.7/dist-packages/Cython/Compiler/Main.py:367: FutureWarning: Cython directive 'language_level' not set, using 2 for now (Py2). This will change in a later release! File: /opt/python-openzwave/src-lib/libopenzwave/libopenzwave.pyx
>   tree = Parsing.p_module(s, pxd, full_module_name)
> building 'libopenzwave' extension
> creating build
> creating build/temp.linux-armv7l-2.7
> creating build/temp.linux-armv7l-2.7/src-lib
> creating build/temp.linux-armv7l-2.7/src-lib/libopenzwave
> arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-InigCj/python2.7-2.7.16=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPY_SSIZE_T_CLEAN=1 -Iopenzwave/cpp/src/ -Iopenzwave/cpp/src/value_classes/ -Iopenzwave/cpp/src/platform/ -Iopenzwave/cpp/build/linux/ -I/usr/include/python2.7 -c src-lib/libopenzwave/libopenzwave.cpp -o build/temp.linux-armv7l-2.7/src-lib/libopenzwave/libopenzwave.o
> cc1plus: warning: command line option '-Wstrict-prototypes' is valid for C/ObjC but not for C++
> src-lib/libopenzwave/libopenzwave.cpp:3: warning: "PY_SSIZE_T_CLEAN" redefined
>  #define PY_SSIZE_T_CLEAN
>  
> <command-line>: note: this is the location of the previous definition
> In file included from openzwave/cpp/src/aes/aescpp.h:26,
>                  from openzwave/cpp/src/Driver.h:42,
>                  from src-lib/libopenzwave/libopenzwave.cpp:638:
> openzwave/cpp/src/aes/aes.h:75: warning: ignoring #pragma warning  [-Wunknown-pragmas]
>  #pragma warning( disable : 4324 )
>  
> openzwave/cpp/src/aes/aes.h:93: warning: ignoring #pragma warning  [-Wunknown-pragmas]
>  #pragma warning( default : 4324 )
>  
> src-lib/libopenzwave/libopenzwave.cpp: In function 'PyObject* __pyx_pf_12libopenzwave_9PyManager_268beginControllerCommand(__pyx_obj_12libopenzwave_PyManager*, PyObject*, PyObject*, PyObject*, PyObject*, PyObject*, PyObject*)':
> src-lib/libopenzwave/libopenzwave.cpp:30325:204: warning: 'bool OpenZWave::Manager::BeginControllerCommand(uint32, OpenZWave::Driver::ControllerCommand, OpenZWave::Driver::pfnControllerCallback_t, void*, bool, uint8, uint8)' is deprecated [-Wdeprecated-declarations]
>    __pyx_t_6 = __Pyx_PyBool_FromLong(__pyx_v_self->manager->BeginControllerCommand(__pyx_t_1, __pyx_t_2, __pyx_f_12libopenzwave_ctrl_callback, ((void *)__pyx_v_pythonfunc), __pyx_t_3, __pyx_t_4, __pyx_t_5)); if (unlikely(!__pyx_t_6)) __PYX_ERR(0, 4120, __pyx_L1_error)
>                                                                                                                                                                                                             ^
> In file included from src-lib/libopenzwave/libopenzwave.cpp:643:
> openzwave/cpp/src/Manager.h:1731:19: note: declared here
>    DEPRECATED bool BeginControllerCommand( uint32 const _homeId, Driver::ControllerCommand _command, Driver::pfnControllerCallback_t _callback = NULL, void* _context = NULL, bool _highPower = false, uint8 _nodeId = 0xff, uint8 _arg = 0 );
>                    ^~~~~~~~~~~~~~~~~~~~~~
> creating build/lib.linux-armv7l-2.7
> arm-linux-gnueabihf-g++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-InigCj/python2.7-2.7.16=. -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-InigCj/python2.7-2.7.16=. -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-armv7l-2.7/src-lib/libopenzwave/libopenzwave.o openzwave/libopenzwave.a -ludev -lstdc++ -o build/lib.linux-armv7l-2.7/libopenzwave.so
> python setup-lib.py install
> running install
> running bdist_egg
> running egg_info
> creating src-lib/libopenzwave.egg-info
> writing requirements to src-lib/libopenzwave.egg-info/requires.txt
> writing src-lib/libopenzwave.egg-info/PKG-INFO
> writing top-level names to src-lib/libopenzwave.egg-info/top_level.txt
> writing dependency_links to src-lib/libopenzwave.egg-info/dependency_links.txt
> writing manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
> reading manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
> writing manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
> installing library code to build/bdist.linux-armv7l/egg
> running install_lib
> running build_ext
> skipping 'src-lib/libopenzwave/libopenzwave.cpp' Cython extension (up-to-date)
> creating build/bdist.linux-armv7l
> creating build/bdist.linux-armv7l/egg
> copying build/lib.linux-armv7l-2.7/libopenzwave.so -> build/bdist.linux-armv7l/egg
> creating stub loader for libopenzwave.so
> byte-compiling build/bdist.linux-armv7l/egg/libopenzwave.py to libopenzwave.pyc
> installing package data to build/bdist.linux-armv7l/egg
> running install_data
> creating build/bdist.linux-armv7l/egg/config
> creating build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/PKG-INFO -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/SOURCES.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/dependency_links.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/not-zip-safe -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/requires.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-lib/libopenzwave.egg-info/top_level.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> writing build/bdist.linux-armv7l/egg/EGG-INFO/native_libs.txt
> creating dist
> creating 'dist/libopenzwave-0.3.1-py2.7-linux-armv7l.egg' and adding 'build/bdist.linux-armv7l/egg' to it
> removing 'build/bdist.linux-armv7l/egg' (and everything under it)
> Processing libopenzwave-0.3.1-py2.7-linux-armv7l.egg
> creating /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-armv7l.egg
> Extracting libopenzwave-0.3.1-py2.7-linux-armv7l.egg to /usr/local/lib/python2.7/dist-packages
> Adding libopenzwave 0.3.1 to easy-install.pth file
> 
> Installed /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-armv7l.egg
> Processing dependencies for libopenzwave==0.3.1
> Searching for six==1.12.0
> Best match: six 1.12.0
> Adding six 1.12.0 to easy-install.pth file
> 
> Using /usr/lib/python2.7/dist-packages
> Finished processing dependencies for libopenzwave==0.3.1
> 
> Installation of lib finished.
> python setup-api.py install
> running install
> running bdist_egg
> running egg_info
> creating src-api/openzwave.egg-info
> writing requirements to src-api/openzwave.egg-info/requires.txt
> writing src-api/openzwave.egg-info/PKG-INFO
> writing top-level names to src-api/openzwave.egg-info/top_level.txt
> writing dependency_links to src-api/openzwave.egg-info/dependency_links.txt
> writing manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
> reading manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
> writing manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
> installing library code to build/bdist.linux-armv7l/egg
> running install_lib
> running build_py
> creating build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/group.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/scene.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/option.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/object.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/value.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/command.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/network.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/controller.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/singleton.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/node.py -> build/lib.linux-armv7l-2.7/openzwave
> copying src-api/openzwave/__init__.py -> build/lib.linux-armv7l-2.7/openzwave
> creating build/bdist.linux-armv7l/egg
> creating build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/group.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/scene.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/option.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/object.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/value.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/command.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/network.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/controller.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/singleton.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/node.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/openzwave/__init__.py -> build/bdist.linux-armv7l/egg/openzwave
> copying build/lib.linux-armv7l-2.7/libopenzwave.so -> build/bdist.linux-armv7l/egg
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/group.py to group.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/scene.py to scene.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/option.py to option.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/object.py to object.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/value.py to value.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/command.py to command.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/network.py to network.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/controller.py to controller.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/singleton.py to singleton.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/node.py to node.pyc
> byte-compiling build/bdist.linux-armv7l/egg/openzwave/__init__.py to __init__.pyc
> creating build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/PKG-INFO -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/SOURCES.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/dependency_links.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/not-zip-safe -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/requires.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> copying src-api/openzwave.egg-info/top_level.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
> writing build/bdist.linux-armv7l/egg/EGG-INFO/native_libs.txt
> creating 'dist/openzwave-0.3.1-py2.7.egg' and adding 'build/bdist.linux-armv7l/egg' to it
> removing 'build/bdist.linux-armv7l/egg' (and everything under it)
> Processing openzwave-0.3.1-py2.7.egg
> creating /usr/local/lib/python2.7/dist-packages/openzwave-0.3.1-py2.7.egg
> Extracting openzwave-0.3.1-py2.7.egg to /usr/local/lib/python2.7/dist-packages
> Adding openzwave 0.3.1 to easy-install.pth file
> 
> Installed /usr/local/lib/python2.7/dist-packages/openzwave-0.3.1-py2.7.egg
> Processing dependencies for openzwave==0.3.1
> Searching for libopenzwave==0.3.1
> Best match: libopenzwave 0.3.1
> Processing libopenzwave-0.3.1-py2.7-linux-armv7l.egg
> libopenzwave 0.3.1 is already the active version in easy-install.pth
> 
> Using /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-armv7l.egg
> Searching for Louie==1.1
> Best match: Louie 1.1
> Adding Louie 1.1 to easy-install.pth file
> 
> Using /usr/lib/python2.7/dist-packages
> Searching for six==1.12.0
> Best match: six 1.12.0
> Adding six 1.12.0 to easy-install.pth file
> 
> Using /usr/lib/python2.7/dist-packages
> Finished processing dependencies for openzwave==0.3.1
> 
> Installation of API finished.
> sed: can't read /etc/inittab: No such file or directory
> Failed to get properties: Connection timed out
> Failed to stop serial-getty@ttyAMA0.service: Connection timed out
> See system logs and 'systemctl status serial-getty@ttyAMA0.service' for details.
> Failed to disable unit: Connection timed out
> Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth
> Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
> And reboot your Raspberry Pi
> Everything is successfully installed!

PS : j’ai tapé LIEN au lieu d’HTTP car étant nouveau membre, je ne pouvais pas poster plus de 2 liens^^

Ces lignes là me semble bizarres…
Mais je ne saurais pas aider plus…

Tu as bien sélectionné le bon port?

Merci Poumi pour ton temps :slight_smile:

Jusqu’à maintenant, j’ai laissé le port par défaut 8083 et ce soir j’ai essayé le port 80.
Concernant le port USB, j’ai tapé la commande lsusb pour voir l’id de ma clé usb zwave puis j’ai tapé une autre commande qui m’a dit que mon id est bien relié au TTACM0.
Mais rien y fait…

Je parlais du port usb, l’autre laisse 8083

Par contre je ne comprend pas pourquoi le log parle de AMA0 si tu as sélectionné ACM0…

Bien vu ^^ en effet, le long message de la mise à jour, je n’avais pas encore changé le port.
Si tu reprends mon tout premier message, tu verras le log de 18h qui correspond bien au TTACM0.

Bonjour,
Peux tu donner le résultat des commandes

python --version
pip --version 

Voilà voilà :slight_smile:
image

C’est bon ça.
Du coup je n’explique pas pourquoi les dépendances sont OK dans l’écran de config mais pas au lancement du démon…

Bonjour;
Je viens d’avoir le même problème sur ma configuration de test et je me suis arraché les cheveux pendant deux jours sur ce sujet. Et dans mon cas aucune modification de configuration n’a été faite depuis 10j, le plug in s’est envoyé en l’air tout seul avec à la clef démon impossible à relancer car dépendances non installées !
J’ai tenté donc la réinstallation avec les mêmes pbs que les tiens (mêmes logs)

J’ai réussi à régénérer correctement les dépendances en pratiquant comme suit :

  • débrancher le dongle et tous les autres accessoires USB connectés sur le PI
  • redémarrer la box
  • restauration d’une sauvegarde antérieure
  • réinstallation du plug in
  • lancer la régénération des dépendances vérifier que tout s’est bien déroulé
  • arrêt de la box et reconnexion du dongle Aeotec
  • après démarrage, sélectionner le port clef Zwave USB avec le port serveur 8383 dans la config du plug in et sauvegarder
  • vérifier que tout est OK
  • restauration de ma sauvegarde avant plantage
  • vérifier que tout est OK
  • mise à jour Jeedom en 4.0.61

Il y a probablement des étapes qui ne servent à rien mais je n’ai pas ensuite essayé de me pencher plus sur le pb car je suis occupé par ailleurs. Pour moi le plug in openzwave est un de ceux qui urge à remettre à un niveau de fiabilité requis pour de la domotique. Il est vraiment trop instable pour que j’y mettre autre chose que mes éclairages extérieurs pour l’instant.

1 J'aime

Bonsoir, je viens de tester ta méthode le problème étant que je n’ai pas de sauvegarde antérieure car tout est nouvellement installé.

Rien y fait :frowning:

Après débranchement du dongle désinstalle le plug in puis force sa réinstallation.
Désactive la gestion auto du plug in et ensuite fais la mise à jour des dépendances plusieurs fois de suite si besoin.

J’ai testé tout ça mais rien y fait. Si j’enlève le dongle et que je lance l’installation des dépendances cela plante l’installation. Quand je le remets, les dépendances s’installent correctement mais mon demon est toujours en NOK…

Cela fait 4 semaines que j’essaie de faire fonctionner le Zwave… J’en peux plus^^

J’ai réussi à le faire fonctionner !!!
Je suis passé en root sur mon raspberry. J’ai relancé une grosse mise à jour général, puis j’ai fait pleins de manipulations que j’ai trouvé sur des forums. Dans l’ordre des commandes saisies :

sudo su => pour passer en mode root
apt update
apt upgrade
pip install --upgrade setuptools
python -m pip install --upgrade pip
python3 -m pip install --upgrade pip
apt install python-pip
pip2 install --upgrade --force pip
sudo pip install six
python -m pip install --upgrade pip
reboot
systemctl stop cron
systemctl stop apache2
systemctl stop mysql
RELANCE DE L’INSTALLATION DES DEPENDANCES du ZWAVE SOUS JEEDOM
REBOOT
Premier lancement du DEMON NOK, second OKKKKKK :slight_smile:

MIRACLEEE!! Champagne les amis!!!

Merci à tous d’avoir participé à ce fil, en espérant pouvoir aider d’autres utilisateurs.
Toadman.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.