Z-Wave Version 2019-10-08 02:23:27

Tags: #<Tag:0x00007f282ef76c48>

Si je comprend bien ton interrogation, il me semble qu’ici on doit utiliser le Z-Stick Gen5 Backup Tool d’Aeotec pour récupérer sur la nouvelle clé les infos Zwave du backup.

Il me semble que sur l’ancien :innocent: forum le sujet avait été abordé.
Le backup auto de Jeedom contient : xxxxx
Le backup de la clé Aeotec contient : yyyyyy

Bonjour à tous,

j’avais une question au sujet de la mise à jour du plugin openzwave, je souhaiterai mettre à jour jeedom et ce plugin.
Voici où j’en suis :
Capture

Je suis sur un rpi 3 et sous Debien 8 (jessie). Ma question est la suivante :
Faut il obligatoirement passer sous Debian 9 (Stretch) pour faire ces 2 mises à jour ? Car je ne suis pas très chaud pour changer mon OS sachant que mon système est stable pour le moment (je n’ai aucun soucis). Mais j’ai lu quelque part qu’il était conseillé de le faire pour avoir la dernière version du plugin Openzwave sinon la mise à jour du plugin risquait de planter. .

Qu’en pensez-vous ?

D’avance merci.

Bonjour @papa_coni

Si la mise à jour du core en 3.3.33 ou celle du plugin openzwave nécessitaient obligatoirement Debian 9 “stretch”, je pense que le changelog comporterait un avertissement dans ce sens

Si tu as “lu quelque part qu’il était conseillé de le faire” il serait utile que tu nous donnes le lien vers cette information

Maintenant, il y a trois grands principes à prendre en compte dans le domaine informatique :

  • Si ton système fonctionne, qu’une mise à jour ne t’apportera rien de plus… tu n’effectues pas la mise à jour.
  • Dis toi que d’autres utilisateurs feront cette mise à jour et qu’ils ne manqueront pas de réagir sur le forum s’ils rencontrent un problème… donc patienter !
  • Il faut toujours effectuer une sauvegarde avant une mise à jour et externaliser cette sauvegarde (et les autres)
    La sauvegarde journalière de Jeedom sauvegarde Jeedom bien évidemment, mais pas les composantes du système.
    Un lancement des dépendances modifiera ces composantes. (c’est le cas de la dernière maj d’openzwave puisqu’il faut relancer les dépendances)
    Il est donc utile d’effectuer une sauvegarde de l’ensemble de sa configuration Jeedom
    Si tu fonctionnes avec une carte SD sur ton RPI, il faut cloner cette carte

Cela dit, il faut t’attendre à faire tôt ou tard la migration vers Debian 9 Stretch

Il me semble que certains dépôts pour raspbian ne sont plus disponibles pour Jessie.
Si c’est bien le cas, tu ne pourras plus installer les dépendances.
Dans ce cas, pour faire les mises à jour, migration vers Stretch obligatoire.

Vue qu’il y a la Buster qui est sortie cette été que la maintenance sous Jessie vas être arrêté
Je pense que c’est plutôt une bonne idée.
D’ailleurs si tu es sous raspbian je pense qu’une reinstall et restoration de backup sera beacoup plus rapide avec une monté de 2 version

1 J'aime

L’installation de Debian 10 Buster est prématurée

Si le core de Jeedom en V4 est compatible, certains plugins tiers ne le sont pas selon l’information suivante :
Voir ICI

Pour de la production, il est prudent de rester sous Stretch avec Jeedom en V3.

Oui il reste des plugin qui n’ont pas fait le travail mais il reste fonctionnel et c’est le meilleur moyen de les motivé a changer les quelques lignes

Perso j’ai tout migrée et a part quelque plugins que j’ai mise a jours toute fonctionne bien

Merci pour vos retours rapides. Rien que dans celles ci, je vois que j’ai de votre part, des avis qui peuvent diverger d’où mon hésitation :-).
Je suis d’accord avec le principe de si tout fonctionne bien, pas besoin de mettre à jour mais je me dis que le jour où cela ne sera plus le cas, je devrais lancer la mise à jour de jeedom, l’os, les plugins tout cela en cumulé et rattraper pas mal de versions en retarde et en cas de pb (parfois, on se rend compte du dysfonctionnement quelques heures après), j’aurais peut être du mal à savoir ce qui pose pb puisque j’aurais mis pas mal de choses à jour. Après j’ai peut-être tort… désolé si je pose des questions bêtes :frowning:

Pour passer sous Stretch avec un pi c’est assez facile.
Tu fais une sauvegarde Jeedom que tu externalises sur une autre machine.
Tu fais une installation de Stretch sur une nouvelle carte SD.
Tu restores ta sauvegarde.

En cas de problème, Jeedom sous Jessie est toujours opérationnel sur ton ancienne carte SD.

Bien l’idée d’une nouvelle carte, merci !

1 J'aime

En cadeau, la dernière version de Stretch pour pi.

https://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2019-04-09/2019-04-08-raspbian-stretch-lite.zip

Un nouveau sujet sur la V4
ICI

Maintenant je vous propose de continuer ce fil sur ce pourquoi il a été créé : Z-Wave :grinning:

Bonjour à tous,
Après être passé en V4 il y a quelques semaines j’ai fait la mise à jour d’openzwave et là …c’est le drame.
J’ai relancer les dépendances et redémarrer le serveur mais je ne vois plus mes modules et j’ai l’erreur :
http://192.168.0.41/index.php?v=d&m=openzwave&p=openzwave 396 Uncaught TypeError: Cannot read property ‘indexOf’ of undefined
dans les erreurs javascript.
Une idée pour solutionner le problème SVP ?
Merci d’avance.

@mnementh, quelles sont les infos du panneau de configuration de ton plugin Z-wave ?
Statut des dépendances ? Statut du démon ?
Est-ce que le réseau a démarré ? informations dans panneau résumé ?
Tu ne vois rien dans la table de routage ?

Quelle configuration matérielle, contrôleur ZWave ?

Les infos :
image

image

Serveur Debian stretch avec la V4 de jeedom et controleur Aeon zStisk S2

image

Je te propose de :

  • Dans le panneau de configuration, désactiver la gestion automatique du démon et de l’arrêter
  • Retirer ta Z-Stick Gen 5
  • Attendre 1 minute
  • Remettre ta Clé Gen 5
  • Redémarrer le démon

Si çà ne marche pas, redémarrer Jeedom

Ok. Merci pour la manip’.
Je ne suis pas à côté de mon serveur, je vais donc être obligé d’attendre demain pour tester.

Je viens de me rendre compte de deux choses :

  • J’évoque la clé Aeotec GEN5 et en fait tu mentionnes une clé AEON LABS Z-STICK S2.
    Mais cela ne change rien dans la procédure proposée
  • Tu as bien un Port clé Z-Wave de mentionné. Je suppose que c’est celui que tu connais

Pour te rassurer, j’ai déjà eu trois fois le cas avec ma configuration et une GEN5

Deux fois, j’ai redémarré Jeedom et le problème a été résolu

La troisième fois, j’ai souhaité que le cas soit examiné par l’assistance Jeedom qui m’a donné la procédure que je t’indique

La raison du problème ? On l’ignore

Si l’utilitaire de backup disponible pour la GEN5 fonctionne sur ta clé (ce que j’ignore), n’hésite pas à le faire