Worx landroid: pas de remontée d'infos

Tags: #<Tag:0x00007f2834f882a8>

Bonjour à tous,donc voilà le robot tondeuse va sortir de son hivernage, et je souhaitais l’associer à ma domotique, donc installation du plugin worx landroid S, tout semble ok: le plugin a détecté la tondeuse mais je n’ai aucune remontée d’infos même si clique sur refresh ou que je réinstalle le plugin.(pas de message d’erreur dans le debug).
Je séche un peu donc si quelqu’un a déjà eu le souci ?
le modèle est une WORX LANDROID M700 WR142E micrologiciel 2.92
Merci pour votre aide

Bonjour,
J’ai le même problème pour ceux que çà peut aider voici mes logs :

[2020-03-19 15:28:03][DEBUG] : Eqlogicname: Tondeuse
[2020-03-19 15:28:03][DEBUG] : Publication du message  refreshValue 1
[2020-03-19 15:28:03][DEBUG] : 16 : Client android-uuid/v158de26b7 sending CONNECT
[2020-03-19 15:28:03][DEBUG] : 16 : Client android-uuid/v158de26b7 sending SUBSCRIBE (Mid: 1, Topic: PRM100/98D8633C2F38/commandOut, QoS: 0)
[2020-03-19 15:28:03][DEBUG] : Subscribe to mqtt a1optpg91s0ydf-ats.iot.eu-west-1.amazonaws.com msg {}
[2020-03-19 15:28:03][DEBUG] : 16 : Client android-uuid/v158de26b7 sending PUBLISH (d0, q0, r0, m2, 'PRM100/98D8633C2F38/commandIn', ... (2 bytes))
[2020-03-19 15:28:04][DEBUG] : 16 : Client android-uuid/v158de26b7 received CONNACK (0)
[2020-03-19 15:28:04][DEBUG] : Connexion à Mosquitto avec code 0 Connection Accepted.
[2020-03-19 15:28:04][DEBUG] : 16 : Client android-uuid/v158de26b7 received SUBACK
[2020-03-19 15:28:04][DEBUG] : Subscribe to topics
[2020-03-19 15:28:04][DEBUG] : Eqlogicname: Tondeuse
[2020-03-19 15:28:04][DEBUG] : Publication du message  refreshValue 1
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 sending CONNECT
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 sending SUBSCRIBE (Mid: 1, Topic: PRM100/98D8633C2F38/commandOut, QoS: 0)
[2020-03-19 15:28:05][DEBUG] : Subscribe to mqtt a1optpg91s0ydf-ats.iot.eu-west-1.amazonaws.com msg {}
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 sending PUBLISH (d0, q0, r0, m2, 'PRM100/98D8633C2F38/commandIn', ... (2 bytes))
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 received CONNACK (0)
[2020-03-19 15:28:05][DEBUG] : Connexion à Mosquitto avec code 0 Connection Accepted.
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 received SUBACK
[2020-03-19 15:28:05][DEBUG] : Subscribe to topics
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 received PUBLISH (d0, q0, r0, m0, 'PRM100/98D8633C2F38/commandOut', ... (506 bytes))
[2020-03-19 15:28:05][DEBUG] : Message {"cfg":{"id":1,"lg":"it","tm":"15:28:03","dt":"19/03/2020","sc":{"m":1,"p":0,"d":[["13:30",0,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0]]},"cmd":0,"mz":[0,0,0,0],"mzv":[0,0,0,0,0,0,0,0,0,0],"rd":0,"sn":"2019301984010106080A"},"dat":{"mac":"98D8633C2F38","fw":2.92,"bt":{"t":22.1,"v":17.17,"p":9,"nr":237,"c":0,"m":1},"dmp":[-0.7,-2.6,196.5],"st":{"b":23677,"d":406235,"wt":25564,"bl":162},"ls":30,"le":0,"lz":0,"rsi":-66,"lk":0,"act":1,"conn":"wifi"}} sur PRM100/98D8633C2F38/commandOut
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v158de26b7 received PUBLISH (d0, q0, r0, m0, 'PRM100/98D8633C2F38/commandOut', ... (506 bytes))
[2020-03-19 15:28:05][DEBUG] : Message {"cfg":{"id":1,"lg":"it","tm":"15:28:03","dt":"19/03/2020","sc":{"m":1,"p":0,"d":[["13:30",0,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0]]},"cmd":0,"mz":[0,0,0,0],"mzv":[0,0,0,0,0,0,0,0,0,0],"rd":0,"sn":"2019301984010106080A"},"dat":{"mac":"98D8633C2F38","fw":2.92,"bt":{"t":22.1,"v":17.17,"p":9,"nr":237,"c":0,"m":1},"dmp":[-0.7,-2.6,196.5],"st":{"b":23677,"d":406235,"wt":25564,"bl":162},"ls":30,"le":0,"lz":0,"rsi":-66,"lk":0,"act":1,"conn":"wifi"}} sur PRM100/98D8633C2F38/commandOut
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v1c55dc2d4 sending DISCONNECT
[2020-03-19 15:28:05][DEBUG] : 16 : Client android-uuid/v158de26b7 sending DISCONNECT
[2020-03-19 15:31:19][DEBUG] : Eqlogicname: Tondeuse
[2020-03-19 15:31:19][DEBUG] : Publication du message  refreshValue 1
[2020-03-19 15:31:19][DEBUG] : 16 : Client android-uuid/v1c7b801dd sending CONNECT
[2020-03-19 15:31:19][DEBUG] : 16 : Client android-uuid/v1c7b801dd sending SUBSCRIBE (Mid: 1, Topic: PRM100/98D8633C2F38/commandOut, QoS: 0)
[2020-03-19 15:31:19][DEBUG] : Subscribe to mqtt a1optpg91s0ydf-ats.iot.eu-west-1.amazonaws.com msg {}
[2020-03-19 15:31:19][DEBUG] : 16 : Client android-uuid/v1c7b801dd sending PUBLISH (d0, q0, r0, m2, 'PRM100/98D8633C2F38/commandIn', ... (2 bytes))
[2020-03-19 15:31:19][DEBUG] : 16 : Client android-uuid/v1c7b801dd received CONNACK (0)
[2020-03-19 15:31:19][DEBUG] : Connexion à Mosquitto avec code 0 Connection Accepted.
[2020-03-19 15:31:20][DEBUG] : 16 : Client android-uuid/v1c7b801dd received SUBACK
[2020-03-19 15:31:20][DEBUG] : Subscribe to topics
[2020-03-19 15:31:21][DEBUG] : 16 : Client android-uuid/v1c7b801dd received PUBLISH (d0, q0, r0, m0, 'PRM100/98D8633C2F38/commandOut', ... (504 bytes))
[2020-03-19 15:31:21][DEBUG] : Message {"cfg":{"id":1,"lg":"it","tm":"15:31:19","dt":"19/03/2020","sc":{"m":1,"p":0,"d":[["13:30",0,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0],["14:00",120,0]]},"cmd":0,"mz":[0,0,0,0],"mzv":[0,0,0,0,0,0,0,0,0,0],"rd":0,"sn":"2019301984010106080A"},"dat":{"mac":"98D8633C2F38","fw":2.92,"bt":{"t":22.4,"v":17.05,"p":9,"nr":237,"c":0,"m":1},"dmp":[0.7,-3.4,45.9],"st":{"b":23677,"d":406269,"wt":25568,"bl":162},"ls":30,"le":0,"lz":0,"rsi":-77,"lk":0,"act":1,"conn":"wifi"}} sur PRM100/98D8633C2F38/commandOut
[2020-03-19 15:31:21][DEBUG] : 16 : Client android-uuid/v1c7b801dd sending DISCONNECT

Merci d’avance

J’avais le même soucis, je me suis connecté sur le site Landroid pour accéder à mes produits. J’ai pu mettre à jour le PIN code (à quoi il correspond exactement je ne sais pas mais bon) j’ai mis le meme que le code sur la tondeuse. Ensuite j’ai supprimer l’objet du plugin. Je suis retourner dans la config, le démon était arrêter donc je l’ai démarrer puis relancer la synchronisation avec le cloud. Le robot est réapparu et maintenant ça fonctionne. J’espère que ça pourras vous aider aussi :slight_smile:

Bonjour answer, je viens de mettre à jour aussi mon PIN code (j’ai mis identique au PIN Code de ma tondeuse), ensuite j’ai supprimer l’objet du plugin et j’ai désactivé le plugin, je le réactive, il détecte bien la tondeuse avec son numéro de série/adresse mac/date fin de garantie… mais aucun retour d’informations sur le plugin( battery level/status/last date… ) je ne comprends pas :frowning:
quelqu’un aurait une idée ??
Merci à tous

Pour confirmation,vous vous connectez bien sur https://account.worxlandroid.com ??

Oui c’est bien cette adresse. Avez-vous vérifier l’état du démon ?
Une chose que je remarque dernièrement c’est comme si le robot avait une période de veille puis passait en veille prolongé. Après avoir passé la nuit, celui-ci n’a également plus de remontée et je suis obligé de le remettre en marche manuellement, ensuite la connexion avec les serveur worx se remet et jeedom aussi. Curieux donc cette sorte de veille prolongée ou je ne sais quoi :confused:

Je viens de faire un ticket sur le site pour leur parler de cette perte de connexion avec leur serveur.
A voir maintenant la réactivité du service pour trouver une solution :slight_smile:

Edit: Je viens de voir sur le changelog de Juin cette ligne « Sleep mode for battery overtemperature »
A se demander si ce n’est pas ce sleep mode qui génère le problème justement. Du coup lorsqu’il reste bien « longtemps » à la station il se déconnecte et ne se reconnectera que lorsque son programme interne lui dit de démarrer. Donc Jeedom ne peut lancer le robot lui-même après être passé dans ce mode.

Hello, pareil plus de remontée sur le plugin depuis une semaine environ. Sur l’application Landroid pour Android j’ai bien les statuts qui se mettent à jour mais je ne peux pas commander la tondeuse (start, pause, home) il essaie de se connecter au cloud et pas de réponse … Pour moi le problème est bien du côté de Worx :confused:

Hello les amis,
Idem pour moi plus de remontées sur le plugin depuis le 24/03.
Pas de soucis sur l’appli par contre.
J’ai les commandes depuis jeedom qui répondent une fois sur 10…

En espérant que ca soit vite corriger, avec le retour des beaux jours j’ai également ressorti le robot. Me reste le changement de lames à faire (encore faut il pouvoir en commander…)

++

Bonjour,
J’ai aidé l’auteur à apporter une série de fix sur ce plug-in car je n’arrivais pas non plus à le faire fonctionner.
Ce n’est pas fini mais chez moi la bêta fonctionne pour la majorité des fonctions; s’il y a des motivés vous pouvez l’installer et faire un retour.

Bonjour,
Comment fait-on pour installer la bêta ?
Après, on peut repartir sur une version stable ?

Bonjour,

J’ai poussé les modifs de Mips vers la stable donc normalement c’est la même version.

Les changements sont en stable à présent.
Mais il est possible qu’il y ait d’autres problèmes encore. J’ai 3 jeedom en test/dev chez moi,
Sur une v4 buster debian ça fonctionne.
Sur une v3 stretch raspberry aussi
Mais sur une v3 stretch debian les infos ne remonte pas.
Je n’ai pas encore eu le temps de comprendre pourquoi, sûrement lié aux dépendances.

yes je te confirme que sur jeedom V3 debian ça ne fonctionne pas :wink:

Peux-tu me montrer une copie de la page santé ?
Que je puisse check la version de debian ?

image

Pareil que Chouby :confused:

version os dans page santé :

Version OS Linux jeedom 3.10.105 #24922 SMP Wed Jul 3 16:34:56 CST 2019 x86_64 GNU/Linux [9.11]

Hello,

Vous avez des messages d’erreurs avec l’installation de mosquitto?

sudo apt-get install mosquitto mosquitto-clients

C’est debian stretch ?

Yes !

PRETTY_NAME=« Debian GNU/Linux 9 (stretch) »
NAME=« Debian GNU/Linux »
VERSION_ID=« 9 »
VERSION=« 9 (stretch) »
VERSION_CODENAME=stretch

et aucun problème de ce coté :

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait mosquitto-clients is already the newest version (1.4.10-3+deb9u4). mosquitto is already the newest version (1.6.8-0mosquitto1~stretch1). 0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

est-ce qu’en niveau de log debug, lorsque tu utilises la commande refresh_value tu as quelque chose comme ça?

20-04-25 21:00:08][DEBUG] : 16 : Client android-uuid/xxxxx sending CONNECT
ensuite subscribe - publish…