Widget d'état remis par défaut

Tags: #<Tag:0x00007f38543a25d0>

Salut @mika-nt28

J’ai constaté que le widget perso appliqué sur “Etat volet” (je mets multi-ouvrants) est systématiquement remplacé par celui du core => shunter. Dès que je resauvegarde le volet, le widget “actuel” n’est pas repris en compte. Y-a-il moyen de corriger celà ?
Dans le même genre, masquer le nom de la commande “Etat activation” n’a pas d’effet

Tout ça sur la dernière beta 2019-11-19 02:38:42

Merci

Bonjour,

J’ai le même soucis que toi pour le widget avec la dernière version du plugin stable (V4 stable), alors que ça marchait avant. Pourtant il y a eu une correction du core récemment à ce sujet : Perte d'icone du Widget "Téléphone" du plugin -freebox_os
Pour l’état d’activation, il ne sert qu’à connaître son état, pour afficher le cadenas c’est les commandes activé/désactivé qu’il faut utiliser.

Merci pour ton retour.
Concernant l’affichage de la commande d’activation, entendons nous bien, je veux garder le cadenas MAIS pas le nom
image => image
Si je masque la commande, je n’aurai plus rien…ça marche ailleurs, par exemple sur l’état par exemple
image

EDIT : OK, j’ai trouvé pour le nom ! Merci

Ah oui excuses moi, j’ai mal lu, j’ai cru que tu parlais de la commande elle même, j’aurais du me douter qu’un bêta-testeur savait utiliser la commande “lock”. :grinning:
Je viens de tester et ça fonctionne chez moi en décochant bien le nom sur les deux commandes :
Annotation%202019-12-14%20140359

Non en fait tu as tout à fait raison. Je ne changeais pas l’option au bon endroit.
Comme quoi même beta-tester, hein …

Alors, je croise les doigts pour que @mika-nt28 nous trouve une petite solution sur le widget (et ajouter les commandes avec les heures jour/nuit), avec ça je simplifierai bien ma configuration en faisant sauter 9 virtuels et en reprenant ceux qu’il y a dans le plugin à la place. Et par la même occasion, je vire quelques scénarios de synchro

Pour info, je viens de tester avec un autre plugin de @mika-nt28 (#plugin-voletprop) et j’arrive bien à enregistrer et appliquer un widget “code” ce qui me laisse penser que le soucis vient du plugin et non du core…
Bon courage @mika-nt28!

Je regarde ça je le force peut-être dans le code

Merci! Toujours aussi réactif! :slightly_smiling_face:

J’ai poussé une mise à jour car je forçait le generic type
Mais le plugin ne gère pas de widget

1 J'aime

En fait, c’est la fin de la dernière commande qui pose problème ici

	public function postSave() {
		$this->AddCommande("Ratio Vertical","RatioVertical","info", 'numeric',1,'DONT','core::shutter');
		$this->AddCommande("Ratio Horizontal","RatioHorizontal","info", 'numeric',1,'DONT','core::shutter');
		$this->AddCommande("Gestion Active","gestion","info", 'string',1,'GENERIC_INFO',"core::default");
		$this->AddCommande("Etat du volet","position","info","numeric",1,'GENERIC_INFO','core::shutter');

Plus qu’à attendre la dispo de la màj pour voir

Merci par contre il me propose une MAJ du #plugin-voletprop, nous on parlait du #plugin-volets, je disais que ça fonctionnait avec le #plugin-voletprop justement, désolé hein.

Qu’entends tu par là? Je ne suis pas sûr de comprendre…

Ha pardon je suis fatigué.
C’est pour ça que je n’ai rien trouvé.

Édit
La correction est sur le market

ça fonctionne au poil chez moi !
PS: J’avais pas vu la mauvaise position de la } !!

Bonjour,

C’est OK pour moi aussi, merci @mika-nt28.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.