[VM PROXMOX] Audio par le port Jack du NUC

Bonjour,

Je suis passé d’un Jeedom sur RPI2 à la virtualisation et cela s’est globalement bien passé.

Ma configuration :

  • NUC Intel NUC8 i3-8109U
  • Proxmox
  • 1 VM dédiée à JEEDOM V3.3.51 sur Debian 10 (buster)
  • PassThrough d’un port USB pour RFxCom
  • PassThrough fait pour la carte audio : device=intel-hda, driver=spice

Lorsque j’étais sur mon Rpi, j’arrivais à utiliser le port Jack pour faire parler Jeedom sur une enceinte amplifiée. J’utilisais PlayTTs.

Désormais que je suis sur le NUC avec Proxmox et une VM pour Jeedom, cela ne fonctionne plus.

Il y a sans doute des drivers à installer : sur le Debian de Proxmox et sur la Debian de Jeedom ?

Est-ce que quelqu’un aurait réussi à se servir du port Jack (carte audio) du NUC dans cette configuration (VM Proxmox) ?

Si cela ne fonctionne pas, je suis disposé à acheter une carte audio USB. Est-ce qu’il y a un modèle en particulier ? Est-ce que cela fonctionnera bien en passant au travers des Debian pour arriver à Jeedom et sortir un son par PlayTTs ?

Merci de vos conseils

Salut j’ai un peut le même problème je cherche a avoir de l’audio sur l’interface console graphique …
j’ai essayer pas mal de choses mais pas d’audio.

Bonjour,

Je me permets un petit « up ».
Personne n’a essayé de faire parler Jeedom par le port Jack ?

Idéalement par le port Jack du NUC, sinon par une carte audio USB.

Merci à tous

Bonjour,

Exactement même situation pour moi. D’après ce que j’ai pu lire à droite à gauche sur le forum officiel proxmox, l’hyperviseur tournant sur une base de debian, il ne comporte pas les drivers intel et il faudrait rajouter le dépôt des sources « non free » … ce que j’ai fait mais sans grand succès car à l’install des fameux drivers, incompatibilité avec les drivers d’orgine PVE.

Bref, si quelqu’un a trouvé une solution, je suis preneur aussi.

Merci

Bonjour,

Pour ma part je passe désormais par une carte audio usb.
Il serait idéal de pouvoir utiliser directement le port Jack du NUC tout comme le Bluetooth sans avoir à ajouter des cartes USB.

Il y a probablement un moyen de le faire mais je manque de connaissances. C’est pour cela que j’ai fait appel à la communauté :slight_smile:

Bonjour
Pour ma part je suis également sur un Intel NUC.
J avais installé debian 9 puis ensuite jeedom manuellement, et le port Jack du nuc fonctionnait parfaitement (pour le TTS etc…)
Puis hier j’ai tout réinstaller en utilisant l image disque fournie sur le site jeedom, avec debian 10… et là effectivement le port Jack ne fonctionne plus…
Donc probablement un problème de driver qui ne sont pas fournis avec l image officielle jeedom

Bonjour,

Vous pouvez faire une installation avec l’image de Debian et voir si c’est bien la source du problème.
- et faire un retour ici pour avoir de vos nouvelles sur ce sujet.

Merci.

1 J'aime

Bonjour Fabrice,
alors euh… non je ne peux (veux) pas tout ré-installer encore une fois !
Mais j’ai réussi à faire fonctionner ce satané port jack, je poste ma solution si ça peut aider d’autres personnes…
alors voici :

  1. aller dans réglages => système => configuration => _OS/DB => >_Administration Système => >_Ouvrir
  2. là on va pouvoir taper des commandes linux, on commence par installer alsa :
sudo apt-get install alsa-utils -y

Si un message d’erreur, on peut essayer de faire d’abord :

wget https://www.alsa-project.org/alsa-info.sh

puis re-tenter la 1ère commande ensuite.
on peut après lister les cartes sons pour voir si elles sont bien détectées :

aplay -l

puis pour finir … il faut monter le son :sweat_smile: eh oui, parce que apparemment il peut être par défaut sur « mute », donc on fait un petit +100% :

amixer set Master 100%+

Voilou !
alors on peut aussi tenter un re-démarrage du système ça peut toujours faire du bien, et on peut agrémenter le tout de quelques petits :

sudo apt-get update -y
sudo apt-get upgrade -y

Je ne suis absolument pas spécialiste linux donc je comprends à peine ce que je fais, mais il semble qu’à un moment donné quelque chose a marché :grinning:

1 J'aime

Bonsoir et merci pour le retour.

Vous auriez pu faire ces commandes en SSH :wink:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.