Unifi - Insights is still not an array, there is something strange

Tags: #<Tag:0x00007fcbb87cab38>

Tout est dans le titre… depuis la dernière mise à jour du plugin unifi il y a 2 jours j’ai des milliers d’alertes dans les logs Unifi « Insights is still not an array, there is something strange »

Effectivement, il y a quelque chose d’étrange…

Merci de votre aide.

Bonjour,

Veux tu bien fournir le log (en debug) et me dire sur quel controleur tu es ?

J’ai ajouté cette ligne quand un résultat ne correspondait pas à quelque chose d’attendu… avant tu n’avais juste pas le message mais ce n’est pas plus grave. Ça m’intéresse de connaître les circonstances qui donner ce resultat

Merci.

voici une partie du debug (il y a un message toutes les 2 secondes environ)

[2021-02-16 10:33:46][DEBUG] : Insights is not an array, relogging... 
[2021-02-16 10:33:46][ERROR] : Insights is still not an array, there is something strange... 
[2021-02-16 10:33:50][DEBUG] : Insights is not an array, relogging... 
[2021-02-16 10:33:50][ERROR] : Insights is still not an array, there is something strange... 
[2021-02-16 10:33:53][DEBUG] : Insights is not an array, relogging... 
[2021-02-16 10:33:53][ERROR] : Insights is still not an array, there is something strange... 
[2021-02-16 10:33:57][DEBUG] : Insights is not an array, relogging... 
[2021-02-16 10:33:57][ERROR] : Insights is still not an array, there is something strange... 
[2021-02-16 10:34:00][DEBUG] : Insights is not an array, relogging... 
[2021-02-16 10:34:00][ERROR] : Insights is still not an array, there is something strange... 
[2021-02-16 10:34:03][DEBUG] : Insights is not an array, relogging...

J’ai relancé les dépendances, arrêté le plugin et relancé mais pas de chnagements.

Le seul point particulier, peut être, est que j’utilise la toute nouvelle version du controleur Unifi pour laquelle l’URL du controleur est différente :

https://192.168.1.231/network/site/default/dashboard/

Je suis sur cloud key 2+ version 2.0.27

Pour autant cette adresse fonctionnait avant la mise à jour du plugin.

Merci d’avance.

Ca fonctionne pour @Dark et @openhomeautomation pourtant… ils ont aussi une cloudkey gen 2

peux-tu mettre à jour el plugin, j’ai ajouté du log il doit donné le résultat des insights

Hello,
J’ai mis à jour le plugin Unifi aujourd’hui et j’ai maintenant également ce message « Insights is still not an array, there is something strange… » qui revient trèèèèèèèèès fréquemment toutes les 3 à 4 secondes.

Mon controleur est en version 6.0.43 sur un UDM PRO en version 1.8.5.

Hello, Tu peux lire le message avant le tien ?

1 J'aime

Hello,

Merci de ton retour, j’ai lu tous les messages précédents, mais auquel fais tu allusion exactement?.

Moi je ne suis pas sur une cloud key, c’est mon UDM Pro qui porte le Unifi controler

Celui juste au dessus de ton premier message

Ok, plugin mis à jour à l’instant, ce qui a eu pour effet de réinstaller les dépendances.
Je l’ai relancé.

Et la log unify commence à se re-remplir:

[2021-02-16 16:02:42][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:02:45][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:02:49][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:02:52][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:02:56][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:00][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:03][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:07][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:10][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:14][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:03:18][ERROR] : Insights is still not an array, there is something strange...

Je ne vois pas plus d’informations…

Edit: après avoir passé le niveau de log en DEBUG et relancé, voici ce que j’ai:

[2021-02-16 16:06:08][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:10][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:10][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:10][DEBUG] : Insights received :
[2021-02-16 16:06:14][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:14][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:14][DEBUG] : Insights received :
[2021-02-16 16:06:17][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:18][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:18][DEBUG] : Insights received :
[2021-02-16 16:06:21][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:21][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:21][DEBUG] : Insights received :
[2021-02-16 16:06:25][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:25][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:25][DEBUG] : Insights received :
[2021-02-16 16:06:28][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:29][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:29][DEBUG] : Insights received :
[2021-02-16 16:06:32][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:32][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:32][DEBUG] : Insights received :
[2021-02-16 16:06:35][DEBUG] : Insights is not an array, relogging...
[2021-02-16 16:06:36][ERROR] : Insights is still not an array, there is something strange...
[2021-02-16 16:06:36][DEBUG] : Insights received :

J’aurais besoin d’avoir accès à ton jeedom…

Désolé, mais je ne suis pas vraiment ouvert pour ça.

Si tu veux que je passe des commandes et que je te donne les résultats, pas de soucis, mais t’ouvrir un accès sur mon réseau…

On peut le faire en teamviewer comme ça tu vois tout ce que je fais.

Pourquoi pas, mais en tout cas pas ce soir, là je dois me concentrer sur autre chose.
On en reparle demain?

@nebz c’est ok pour moi si tu veux prendre la main sur mon jeedom en tw

ok tu peux m’envoyer en privé ?

voilà, résolu chez Tristan :

3 erreurs :

  1. un / à la fin de l’ip dans le champ ip
  2. un login non local, (nécessaire comme indiqué dans la doc)
  3. le champ site qui contenait une url à la place de default comme indiqué dans le champ en dessous en rouge et la doc

Mille merci de ton intervention et bravo pour le plugin.

Pour la configuration cloud, ils ont changé ca en même temps que de passer du port 8443 -> 443 je pense… depuis leur problème de secu aussi peut-etre… moi j’ai activé MFA sur mon compte cloud, donc il faut absolument passer par un compte local !