Trop d’exécutions du scénario

Tags: #<Tag:0x00007f3851aa3df0>

Bonjour

J’ai souhaité domotiser mon ouverture de portail. J’ai connecté un Fibaro sur la sortie OGI de mon portail. Cette sortie OGI retourne un +24v 0v (mode clignotant) pendant l’ouverture du portail puis se stabilise à +24v tant qu’il est ouvert.

J’ai un scénario qui se base sur ce déclencheur pour allumer un éclairage.

Tout fonctionne bien sauf que pendant toute l’ouverture le déclencheur passe de 1 à 0 ce qui lance le scénario ‹ trop › de fois.

Auriez vous une idée ? Le top serait d’avoir une consigne inverse du timeout qui dit que ce scenario ne peut pas se lancer plus de X fois par minutes par exemple

Une idée ?

Normalement ton scénario doit être déclenché au changement à 1, il ne devrait pas être relancé s’il reste à 1.
Peux tu montrer ton scénario ? Le déclencheur ?

tu veux qu’il se déclenche forcement au premier clignotement ou quand tu reste a 1 ça te va aussi?

si la 2eme solution te va, declenche le par action sur valeur (parametres avancés de la commande), tu peux y definir quand telle valeur depuis plus de x minutes.

je rentre chez moi ce soir et je vous montre le déclencheur (le scénario en lui même est un SI qui regarde l’heure pour voir si indispensable d’allumer la lumiere) c’est le déclencheur (j’ai associé la commande ETAT du fibaro)) qui doit lancer le scénario pleins de fois de suite (je le vois dans les logs), et à chaque clignotement (1 . 0 . 1 … 0 )

mon probleme c’est que je ne peux pas attendre 1 minute devant mon portail pour allumer la lumiere, la lumiere est là pour faciliter l’entrée du véhicule, du coup ton idée est bonne si je peux dire 'si valeur = 1 depuis 5 secondes) mais là ca veut dire que j’allume que lorsque le portail est totalement ouvert (ce qui ne serait pas idiot non plus)

Si c’est pour une lumière,pas sur que le problème soit le déclenchement du scénario mais ce qu’il y a à l’interrieur Du coup…

Si c’est juste pour allumer la lumière x minutes tu peux faire un truc du genre

Déclenchement: valeur =1

Allumer lumière
Remove inat
Dans 5 minutes éteindre lumière

Du coup le fait qu’il se déclenche plusieurs fois ne pose pas de soucis

A voir avec la capture du scénario pour voir ce que tu veux faire exactement.

Moi je chercherais plutôt à modifier le comportement du portail, il y a parfois un jumper (cavalier) qui permet de choisir le mode de ces sorties 24v (j’ai ca sur ma porte de garage)
par exemple au lieu de faire un « clignotant » il resterait allumer en permanence. Vérifie si tu peux changer cela non?
Évidement tu perds l’info « en mouvement »

Ah oui, j’ai pas pensé que c’etait Une option…

J’avais pas vu le clignotant, en effet @mips a bien compris le problème.
En alternative un déclencheur du style :
stateduration(commande, [valeur]) ; si ton clignotement est de 3s, en mettant valeur à 5s cela s’allume lorsque c’est ouvert uniquement.
Si tu veux que ça s’allume immédiatement?
Il y a d’autres fonctions similaires ici

Pas sûr que ça passe en déclencheur, j’ai jamais testé mais il me semble avoir lu que non…

Salut, j’ai installé chez un ami un moteur nice et il y a aussi une sortie OGI si ton moteur et un nice alors tu peux modifier ogi dans les paramètres du moteur en deuxième niveau et tu peux le passer en actif à l’ouverture.

Tu peux mettre le déclencheur sur la commande et démarrer ton scénario avec si stateduration …

Ben non…

Le stateduration du déclencheur sera forcément à 0 au moment du déclenchement.

Et passera à 1 lorsque le portail sera totalement ouvert.

Toujours pas…

Si le déclencheur est le passage à 1 de la valeur, commencer le script par un stateduration te donnera toujours 0 puisque la valeur vient juste de passer à 1

Je vais regarder sur la documentation :slight_smile:

Capture

Voici le scénario. Je vais regarder la proposition de Loustic03 pour changer le paramètre mais cela depend de la version de la carte et je crois que la mienne ne peux pas.
Bien entendu j’ai contacté NICE et forcement ‹ on sait pas ›

J’ai eu l’idée de me mettre sur le contact sec OPEN mais ca ne passe pas (surement le voltage pas assez fort)

C’est plus le contenu du scénario qui m’intéresse :grin:

Ha ? le problème ne vient pas du scénario pour moi , cela vient du déclencheur qui le lance trop de fois. Mais bon le voici, je dois pas chercher où il faut :slight_smile:

Capture2

Mon moteur est un nice Robus 400

Voici le parametre OGI, je suis sur L1 par défautCapture

Et voila l’explication de la fonction L1 (c’est pour les sorties SCA mais la sortie OGI se comporte pareil)

20012609315224200416618138