#statusText# inopérant

Tags: #<Tag:0x00007f753cae0778>

Bonsoir,
client android tout à jour
Si je comprends bien , la valeur « #statusText# » permet de récupérer la commande que nous mettons dans « Statut » , si je suis logique, à des fins de duplication ,je pense. Ce qui est très bien.
J’ai remarqué dans le widget volet que cela ne faisait pas le job lors d’« images sous condition »
image

aperçu dans l’appli :
image

si je remplace par la vraie commande dans l’appli :
image

image

c’est ok
merci

As tu lu ce qui est indiqué dans la colonne de gauche en bleu !?

#statusText# permet donc de récupérer au format texte le statut du widget. Soit « ouvert » ou « fermé ». Comme indiqué sur la gauche.

Donc rien d anormal sur le fait que tes img sous conditions ne « fonctionnent pas », ouvert ne pouvant pas etre inférieur a une valeur !
(soit dit en passant tu n as pas besoin de mettre des bornes, il suffit de trier les conditions par ordre croissant ‹ xxx <= Y ›, a la 1er conditon vérifiée l appli s arrete).

Donc ca n etait pas…
Par contre ce sujet est traité ici

Ok
j’ai vu mais je croyais que c’était un exemple, parti dans « ma logique » de traduction
Dans mon cas le statut est une valeur entre 0 et 100
Comment le logiciel sait que 0 est fermé et 100 ouvert dans mon cas , et non 0 ,1 par ex, même si c’est un volet roulant
Après si je peux donner mon avis « logique » :slight_smile: , je ne sais pas si vous vous êtes pas compliqué la chose. Le réel intérêt n’est il pas de pouvoir réutiliser la valeur dans les images sous condition, ou dans le cas de volet roulant pour gérer les valeurs intermédiaires à l’instar de #value# ?
autre ex :
J’ai des volets battants motorisés ,pilotés avec un fibaro.
J’ai fait avec le widget volet de cette façon :
image
J’ai pas d’état ouvert fermé sur mon moteur, il y a un état 2 qui gère l’ouverture, et un état 1 qui gère la fermeture , d’où le scène dans le statut
J’avais commencé à faire des #status text# dans les conditions vu que j’ai 5 volets à dupliquer. A tort du coup, ça me paraissait « logique »
Voilà pourquoi ma question originale.
Cette valeur , du coup ça sert à quoi ? car le statut « ouvert » ou « fermer » pour un volet , vous le gérer directement en natif non ? Si on met aucune condition, ça change tout seul d’état.
Attention, je ne critique pas, j’essaie de comprendre, je trouve cette appli merveilleuse :slight_smile:
Ps t’as vu mon message sur les « groupes » .Y a u truc que j’ai pas du comprendre là aussi ? :slight_smile:
https://community.jeedom.com/t/probleme-affichage-groupe-dans-menu/67402n

Merci en tout cas de répondre sur le forum, avec tout ce boulot du plugin

c’est quand même écrit noir sur blanc « variables disponibles », et pas « voici un exemple ». :slight_smile:

et puis tu parles beaucoup de « logique », mais où est la logique de faire un test numérique (=100, >50) sur une variable qui s’appelle xxxTEXT !?!? :thinking: :thinking:

le développeur serait quand même ultra mauvaise de proposer ça … !

avec le type de ta commande !
si binaire : 0-1
si numérique : 0-100

par convention : 0 fermé, 1/100 : ouvert

je crois que je commence à le voir avec tes derniers posts :upside_down_face: :upside_down_face: :upside_down_face:

est ce que tu as lu le post que je t’ai donné dans mon précédent msg ?
si tu poses cette question, c’est que la réponse doit etre encore « non » :slight_smile: vas y faire un tour !

a mettre l’info en texte (donc « Ouvert » ou « Fermé » dans le titre / le sous-titre ? à s’en servir dans les images sous conditions ? … )

oui mais pas encore pris le temps de m’y pencher dessus. je te laisse regarder encore un peu :slight_smile:
les groupes existent depuis le début, et ca fait un bout de temps que personne n’a rien remonté dessus. du coup ca serait étonnant (mais pas exclus!) qu’il y ait une anomalie :slight_smile:
autre solution : efface tout et essaie de créer ces groupes directement depuis l’application pour voir ce que ca donne.

OK j’ai noté

Tu peux aussi le traduire par contenu de ce que tu mets dans statut
Bien sur que j’ai lu ton dernier post ’ et le lien qui yest dedans, je ne faisais que te donner mon avis qui n’est pas si illogique que ça.
Concernant les groupes, je fais bien de l’appli à partir de jeedom. J’essaierai de les refaire. Mais mettre un titre et cocher 2 cases j’y arrive.:laughing:. Je ne sais pas trop d’oû ça vient. Je me suis dit la même chose que toi, personne n’a posté le pb sur le forum, je dois faire un truc qui va pas.mais là je vois pas.
C’est vrai que je ne fais pas de dev mais j’ai 30 ans d’infra. J’ai un peu la logique informatique même si tu en doutes

oui … mais non ! :slight_smile:
si en sous-titre tu mets ce que tu as derrière l’information de statut tu verras 0 (voir rien car l’appli considerera comme a ne pas afficher) ou 1 (ou 100), tu n’auras pas l’info en texte « Ouvert » ou « Fermé »
que toi tu peux peut etre deviner, mais peut etre moins ta femme ou tes enfants ! :wink:

je n’ai pas dit que c’était illogique.
je t’indique à travers l’autre post que la demande d’avoir la variable #value# disponible dans les img sous condition, pour permettre de dupliquer un widget plus facilement, a été faite et est prise en compte.
(faire un ‹ simple › test sur ouvert/fermé a peu d’intérêt puisque l’appli le fait déjà de base)

mais là on pinaille ! :slight_smile:

le sujet semble clos, penses à solutionner :wink:


pour l’autre sujet, rdv le sujet concerné histoire de ne pas polluer ici pour rien … :slight_smile:

@xav31190 la solution plutot sur mon tout 1er msg !
car ce dernier msg n’apporte pas de reponse à la question initiale :slight_smile:

si c’est waf :slight_smile:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.