Soucis sur mon réseau z-wave

Tags: #<Tag:0x00007f3850d7c5f0>

Tu teste comment le retour de fil d’attente à 0 pour le coup ?
Si ta un bout de code PHP je suis preneur :slight_smile:

Il faut bien insister en commençant comme indiqué dans l’onglet du module par “Soigner le nœud”, “Mise à jour des nœuds voisins” puis si ça ne va pas “Rafraîchir les infos du nœud”, “Récupérer les CC dynamiques”, “Rafraîchir les valeurs nœud”, entre temps on réveille plusieurs fois les modules piles, on attend, on recommence…

Le Z-Wave, réputé fiable et robuste, c’est comme un grand malade, il faut bien le soigner :laughing:

Concernant le module Fibaro Motion Sensor (Eye), j’en avait analysé un en particulier car dès fois le ON ou le OFF ne passait pas. En fait, il y avait bien des infos remontées dans tous les cas sauf que la valeur du “Burglar” n’était pas la même lorsque le true (ou false) fonctionnait et lorsque le true (ou false) ne fonctionnait pas. En clair, la valeur “Burglar” remontait à chaque détection ou fin de détection mais pas l’info du capteur “Sensor”. Pourquoi ? ==> Exclusion puis inclusion en non sécurisée et enfin OK

J’ai mis cette fonction dans mes utilitaires

function WaitBusy($timer = 5) {
	$networkState = openzwave::callOpenzwave('/network?type=info&info=getStatus');
	$queueSize = $networkState['result']['outgoingSendQueue'];
	while ($queueSize > 0) {
		$networkState = openzwave::callOpenzwave('/network?type=info&info=getStatus');
		$queueSize = $networkState['result']['outgoingSendQueue'];
		sleep($timer);
	}
	return 'ok';
}

@m.georgein
Thx :slight_smile:

@Domatizer, mon fibaro eyes est effectivement en mode sécurisé, je vais le passer en mode non sécurisé ainsi que tt mes autres modules demain pour voir si j’ai des améliorations.

Sinon j’ai passer en mode “aucun” log, et j’ai toujours mon fichier /var/www/html/log/openzwave qui est spam de message de debug oO

Bon courage, c’est ce que je devrais faire aussi, mais c’est très long. En effet, les nouvelles inclusions ne se passent pas bien du premier coup et je me retrouve comme toi avec des modules sans infos, je dois cliquer, cliquer et re cliquer… Pour un module ça va, mais pour des dizaines de modules… En plus, je perds les réglages des paramètres des modules. Pour les dimmers, il y a beaucoup d’option a changer, il faut tout recalibrer, c’est vraiment lourd. Je ne parle du cas où le système d’inclusion plante à force d’en faire et refaire, là c’est le redémarrage obligatoire du réseau Z-wave pour continuer les inclusions (Alors ici problème Jeedom ou openzwave ?). J’ai des modules de porte pour compter les impulsions eau et gaz, donc je dois couper la chaudière gaz, ne pas cuisiner, ne pas tirer de l’eau pendant le reboot. Il faut donc personne dans la maison pendant ce temps là, le soir on ne bidouille pas les dimmers. Pour le chauffage, ce n’est pas trop la bonne période pour jouer. Bref, c’est très ch**nt tout ça !

1 - Pour que le changement de log soit efficient il faut RELANCER le daemon

2 - L’astuce pour se mettre la tête dans le sable c’est dans la page des logs de faire “supprimer tous” :slight_smile:

Plus le réseau est gros plus il est conseillé de n’avoir aucun module en sécurisé. LE plugin ne tient pas en sécurisé

Je rebondis sur ton message car j’avais cette information et je pense n’avoir pas réalisé les inclusions en sécurisé.
Par contre l’état du cadenas dans ma page santé m’interpelle : dans la doc on voit le symbole d’un cadenas vraiment ouvert, alors que chez moi le symbole est plutôt entrouvert

Symbole repris dans la doc du plugin openzwave :

Salut,
Ne prête pas attention à ce pictogramme.
Il y a des cas où le système ne sait pas s’il s’gait d’un module en mode sécurisé ou pas.
Dans ce cas, le pictogramme doit ressembler à ça.

Je suis en train de ré-inclure plusieurs modules pour les passer en mode insecure, et je voulais savoir si il est possible sous Jeedom de récupérer tt les endroits où celui-ci est défini pour pouvoir le switch sur la scénarion & co :stuck_out_tongue:

Il y a plus simple.
Sur l’équipement, il suffit de mettre à jour le nouveau “Node ID”.

1 J'aime

Euh j’ai jamais vu cette option, ta plus d’info ?

Je ne peux pas être plus explicite.
Regarde sur ta page “Équipement” d’un de tes modules z-wave.
En excluant et incluant ton module change de “Node ID”.
Il suffit de mettre le nouveau “Node ID” à la place de l’ancien.
Le nouvel équipement qui vient d’être créé, tu l’effaces.

1 J'aime

Oh punaise je viens de comprendre :stuck_out_tongue:
Par contre, je présume que je doit désactiver l’option “Supprimer automatiquement les périphériques exclus” de la configuration de mon plugin :smiley:

C’est exact

1 J'aime

juste pour info, je m’étais fait avoir avec un module acheté sur AMA. mais en provenance USA et la fréquence ZWAVE n’est pas la même

Z-Wave fonctionne dans la gamme de fréquences sous-gigahertz, qui dépend des régions (868 MHz en Europe, 908 MHz aux US, et d’autres fréquences suivant les bandes ISM des régions).

les erreurs de “drop commande” vous les voyez dans le log openzwave même en mode “erreur” ?

j’ai 45 modules et mes logs zwave sont vides. Je suis en Jeedom V3

Oui, en cas d’erreur, tu dois les voir dans les fichiers log

Tes fichiers sont vides ou supprimés ? ça change tout, voir ce qui a été dit précédemment

Tes commandes (lumière, chauffage, prise, …) passent-elles toutes bien au bon moment ?
Tes capteurs remontent bien leurs états (porte, détecteur présence) à tous les coups ?
Content pour toi si tout fonctionne bien avec 45 modules, alors qu’elle est ta config précisément ?

1 J'aime

Merci pour la réponse

Oui j’ai plus le log, je les supprime régulièrement

Oui la réactivité est là, parfois quelques widgets qui n’affichent pas la bonne info pour les prises électriques mais un appuis dessus les remets au bon état et j’ai un scénario qui les checks.

Je suis sur une smart avec dernière version V3

J’ai eu un soucis de réactivité mais c’était un module mal réglé qui envoyait trop souvent des infos et saturait le réseau zwave

Je viens ce soir d’avoir ( encore ) 1 changement d’état qui n’a pas fonctionné ( interruption réalisé a partir du bouton physique n’a pas été remonté dans jeedom et a laissé le level a 99 de ma lumière

Si on reboot la valeur ne change pas ( pourquoi ?!? )
Si je fais dans les options avancées du modèle forcer la mise à jour la curieusement la valeur est bien lu et passe a 0

En parallèle j’ai un scénario qui vient éteindre une prise électrique fibaro 1 h après et bim elle n’est pas éteinte ce soir ( alors oui ça marche 99% du temps … ) Mais bon sang comment il peut y avoir autant de rate ?

J’ai un maillage au top avec 23 modules soit en vert ou jaune au pire, un ping a moins de 100ms et pourtant il y a des ratés régulièrement ?!?

Comment peut-on avoir des outils pour faire une analyse complète ? ( Les logs vont être trop verbeux pour analyser LE message défaillant ) soigner un réseau n’est pas si parlant que ça sans son analyse ( il me dit toujours que tout va bien …)

Comment savoir si c’est saturé dans ce cas ?