Soucis avec suivi conso

Tags: #<Tag:0x00007fa7a3285c60>

Bonjour à tous

je sais pas si je suis bien sur le nouveau plugin « suivi conso » en collaboration avec @superbricolo ?

j’ai encore un soucis d’indice de mon module compteur electrique qui a sauté avec un pic de conso en avril.

et quand j’utilise la recherche, de la page « correcteur » en mettant

Date de début : 2020/04/01 00:00
Date de fin : 2020/04/30 23:55

je me retrouve avec un tableau allant du 2020-05-01 01:54:26 au 2020-04-01 02:34:11

est-ce normal ?

@superbricolo, suite à un précédent soucis avec un indice qui avait aussi sauté, devait faire un correctif, je sais pas si il a été fait ?

et dans la partie « Correction », serait il possible d’avoir « Je souhaite SUPPRIMER une période », car je préfère ne pas avori de chiffre en avril, qu’un pic
ou il faudrait pouvoir faciliement indiquer une conso manuellement pour un mois donné.

merci

Hello,

J’ai pas tout compris. Quel est le problème avec suivi conso ?

Cdt
Thibaut

désolé

premier problème, j’ai de temps en temps l’index qui fait un saut sur mon module de compteur EDF, je me retrouve avec un pic de consommation, ce serait bien de pouvoir l’éviter, @superbricolo avait parlé d’ajouter une limitation dans la conso, un truc comme ca, pour éviter ce problème

et en essayant de trouver quand se produit ce pic, j’ai testé la recherche dans la page « Correcteur » et le résultat ne me semble pas correcte

Recehrche :
Date de début : 2020/04/01 00:00
Date de fin : 2020/04/30 23:55

il affiche un tableau allant du 2020-05-01 01:54:26 au 2020-04-01 02:34:11

Le contrôle dont j’avais parlé, n’est toujours pas publié.
En ce qui concerne ton problème, j’ai également fait un correctif dans les bornes du correcteur qui étaient inversées. C’est peut-être ça ton problème.
Tu peux aussi regarder dans les données pour cibler ton anomalie

Ok @superbricolo merci, je vais attendre ta maj, tu sais quand il y aura une sortie en béta ?

C’est justement en essayant de trouver la période qui pose soucis que j’ai vu ce problème dans la recherche, c’est pas évident car il y a beaucoup de donnée, les critères de filtrage sont très limités

Une fonction qui permettrait de supprimer un mois entier et de mettre manuellement une conso pour ce mois serait super pratique :slight_smile:

Je peux t’aider à corriger ton pic. Soit tu me donnes accès à ton Jeedom, ou sinon je te guide pour exécuter des requêtes pour trouver et corriger l’anomalie.

Salut, désolé je viens juste de voir ton message @superbricolo

Je t’enverrai un accès demain si tu veux jetter un œil, merci

Ok mais je le ferais dans la soirée

Pas d’urgence :slight_smile:

Bonjour @superbricolo

Vu mes graphs je dois avoir eu un saut au niveau du compteur, peut être suite à la MAJ Buster/Jeedom V4.1

tu n’avais pas mis en place une pastille pour éviter ca ?

Screenshot 2021-01-17 at 16.19.44

Il y a certain contrôle, mais je ne peux pas contrôler les écarts trop importants sans référence.
Il faut juste corriger la journée à problème

quand j’avais eu ce soucis la dernière fois, tu m’avais dit avoir une idée pour éviter ce problème :

message du 20 juin :
Le contrôle dont j’avais parlé, n’est toujours pas publié. En ce qui concerne ton problème, j’ai également fait un correctif dans les bornes du correcteur qui étaient inversées. C’est peut-être ça ton problème. Tu peux aussi regarder dans les données pour cibler ton anomalie

tu avais d’ailleurs pris la main sur mon jeedom pour corriger le problème, car perso je galère toujours autant à le faire :frowning:
Si tu utilises des commandes SQL pour identifier le saut et le corriger, je suis preneur car par l’interface jeedom c’est galère

merci @superbricolo

j’ai pas l’impression que c’est le même soucis que la fois précédente, je ne trouve pas de saut d’index important sur la journée du 15/01, mais des choses comme ca :

1579088325	2020-01-15	12:38:45	573980	0	HP	1	0	null	218	1492	12.8
1579088423	2020-01-15	12:40:23	573990	0	HP	1	0	null	196	1492	12.8
1579088521	2020-01-15	12:42:01	574000	0	HP	7	0	null	1673	1492	12.8
1579088619	2020-01-15	12:43:39	574030	0	HP	0	0	null	122	1492	12.8
1579088718	2020-01-15	12:45:18	574030	0	HP	0	0	null	122	1492	12.8
1579090587	2020-01-15	13:16:27	574140	0	HP	0	0	null	87	1492	11.8
1579090686	2020-01-15	13:18:06	574140	0	HP	6	0	null	1471	1492	11.8
1579090784	2020-01-15	13:19:44	574190	0	HP	6	0	null	1492	1492	11.8
1579090882	2020-01-15	13:21:22	574190	0	HP	6	0	null	1492	1492	11.8
1579090980	2020-01-15	13:23:00	574240	0	HP	0	0	null	127	1492	11.8
1579091078	2020-01-15	13:24:38	574250	0	HP	6	0	null	1444	1492	11.8
1579091177	2020-01-15	13:26:17	574280	0	HP	0	0	null	133	1492	11.8
1579091275	2020-01-15	13:27:55	574290	0	HP	0	0	null	131	1492	11.8

est-ce normal ?

J’ai bien ajouté un contrôle pour le paramétrage type FGD212: Variation max autorisée entre 2 mesures
image

Pour chercher le problème, tu peux regarder dans configuration/donnée tableur teleinfo et filtrer avec l’idée de l’équipement et vérifier les index min et max. Pour commencer

Tu conseils quoi comme valeur pour la variation max ?

c’est ce que j’ai fait en SQL :

select * from conso_teleinfo where rec_date=« 2020-01-15 » and id_equipement=1492

et je vois pas de saut d’index, juste les 2 exemples que je t’ai mis au dessus, mais je sais pas si c’est normal ou pas

en image c’est peut être plus lisible

image

image

Ce n’est pas la puissance qu’il faut regarder mais l’index. Et vu l’écart tu doit avoir un grand saut.
Essaies cette requête pour voir les écarts:

select min(hchp), min(hchc) from conso_teleinfo where rec_date = '2021-01-15' and id_equipement = 1492

Pour la variation max, on voit que l’écart entre 2 index est d’environ 50 W. Je te propose de mettre une valeur de 1000. C’est quoi ton matériel mesuré.

Merci @superbricolo, je test ca

c’est un AEOTEC GEN5, une pince de mesure

Non je voulais dire: tu mesures quoi? La conso de ta maison?

ok ;-), c’est la conso globale EDF de la maison

La requête retourne

min(hchp) min(hchc)
9092580 0

Bon ma requête n’était pas tout à fait correctes. A refaire:

select min(hchp), max(hchp) from conso_teleinfo where rec_date = '2021-01-15' and id_equipement = 1492

Par contre j’ai compris pourquoi tu ne trouves pas d’anomalie. Tu regardes les données du 15/01/2020 alors que l’anomalie est au 15/01/2021