Souci avec version typing-extensions, certaines pages du plugin ne se chargent pas

image

image

ça fait un moment que j’ai pas mis à jour le plugin zigbee, grand mal m’en a pris, c’est comme avec openzwave à la bonne époque de la V3… :open_mouth:

après réinstallation des dépendances sans erreurs, le démon se relance, les équipements fonctionnent, mais l’onglet « Réseau Zigbee » sort une erreur sans rien afficher :

image

l’onglet action est presque vide :

image

les 2 autres onglets fonctionnent.

je ne vois pas ce qui bloque, le log sur toutes les occurrences d’installation montre :

  Attempting uninstall: typing_extensions
    Found existing installation: typing_extensions 4.4.0
    Uninstalling typing_extensions-4.4.0:
      Successfully uninstalled typing_extensions-4.4.0

je précise qu’il n’y a pas l’ombre de module en béta sur cette install de prod et que des modules officiels pour la pluspart, sauf JMqtt installé récemment.

complément, le package en question n’est pas référencé proprement dans la partie OS/DB :

image

du coup je ne sais même pas qui s’en sert peut être à côté :slight_smile:

zigbee_packages.txt (25,6 Ko)

Salut,

On est quelques uns à avoir le problème. Il y a poste déjà ouvert à ce sujet :

Lien

Rien de tout ça dans mon zigbee

image

effectivement, le moteur de recherche ne m’a pas sorti ce post… sinon j’aurai alimenté. à merger potentiellement si un modérateur passe par là.

on est sur python 3.7, ce truc en principe ne sert à rien d’après les docs :

This is a backport of the standard library typing module to Python versions older than 3.5. (See note below for newer versions.)
[…]
NOTE: in Python 3.5 and later, the typing module lives in the stdlib, and installing this package has NO EFFECT, because stdlib takes higher precedence than the installation directory […] For package maintainers, it is preferred to use typing;python_version<« 3.5 » if your package requires it to support earlier Python versions. This will avoid shadowing the stdlib typing module when your package is installed via pip install -t . on Python 3.5 or later.

Hello,
j’ai le même problème suite a la mise a jour du plugin zigbee.

image

la réinstallation des dépendances ne change rien.

zigbee_packages.txt (52,6 Ko)

bon donc c’est pas moi qui est fou :slight_smile:

Idem, même message d’erreur depuis maj du plugin.

réglé par mise à jour actuelle déployée ce midi.

effectivement, résolu avec la mise a jour . :+1:

Salut @neurall

Il faudrait que tu passes le post en résolu maintenant.
Merci :relaxed:

oui, merci de l’avoir fait aux modérateurs, en même temps j’attendais que les autres confirmes car je suis pas seul dans ce cas :slight_smile:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.