SNZB-02 + conbee2 Humidité 0%

Tags: #<Tag:0x00007f3f2b73b880>

Bonjour,

Étant un jeune utilisateur de Jeedom, je fait face a un petit problème.

J’ai fait l’installation de Déconz avec une clef Conbee2 avec 4 capteurs température/humidité de la marque sonoff SNZB-02. Via phoscon le retour d’information température et humidité est ok, en revanche sur jeedom le retour température est ok mais le retour humidité est constamment a 0% sur mes 4 capteurs.
Je vient vous demandez votre aide parce que j’ai rien trouvé comme réponse en recherche sur le web.

Merci d’avance

Hello, c’est bizarre car jeedom utilise la même API que phoscon, pas normal d’avoir des résultats différents, une histoire de synchronisation ?

pour la commande humidité dans ton équipement généré as-tu bien la valeur suivante :

image

chez moi ce type de capteur fonctionne bien et renvoie bien température et humidité

image

voila ce que j’ai d’affiché. je vient de réinstallé mon installation pour repassé sur buster, mais toujour le meme probleme

Tu peux jeter un oeuil dans les « données brutes », pour comparer ?

{
    "2": {
        "config": {
            "battery": 100,
            "offset": 0,
            "on": true,
            "reachable": true
        },
        "ep": 1,
        "etag": "4cbd9d1976bffd7212fe4ce8786fd237",
        "lastannounced": "2022-06-23T17:42:20Z",
        "lastseen": "2022-06-23T18:04Z",
        "manufacturername": "eWeLink",
        "modelid": "TH01",
        "name": "Temp. Salon\/Cuisine",
        "state": {
            "lastupdated": "2022-06-23T18:02:31.190",
            "temperature": 2719
        },
        "swversion": "20211103",
        "type": "ZHATemperature",
        "uniqueid": "00:12:4b:00:25:03:3a:d4-01-0402"
    },
    "3": {
        "config": {
            "battery": 100,
            "offset": 0,
            "on": true,
            "reachable": true
        },
        "ep": 1,
        "etag": "ebf225f724c4dbfeea1febd422e6814e",
        "lastannounced": "2022-06-23T17:42:20Z",
        "lastseen": "2022-06-23T18:04Z",
        "manufacturername": "eWeLink",
        "modelid": "TH01",
        "name": "Temp. Salon\/Cuisine",
        "state": {
            "humidity": 5850,
            "lastupdated": "2022-06-23T18:04:12.689"
        },
        "swversion": "20211103",
        "type": "ZHAHumidity",
        "uniqueid": "00:12:4b:00:25:03:3a:d4-01-0405"
    }
}
{
    "ieee": "**:**:**:**:**:**:**:**",
    "nwk": 38573,
    "status": 2,
    "lqi": "255",
    "rssi": "-64",
    "last_seen": "1656007325.665549",
    "node_descriptor": "02:40:80:00:00:50:a0:00:00:00:a0:00:00",
    "endpoints": [
        {
            "id": 1,
            "status": 1,
            "device_type": 770,
            "profile_id": 260,
            "manufacturer": "eWeLink",
            "model": "TH01",
            "output_clusters": [
                {
                    "id": 3,
                    "name": "Identify",
                    "attributes": []
                }
            ],
            "input_clusters": [
                {
                    "id": 0,
                    "name": "Basic",
                    "attributes": [
                        {
                            "id": 0,
                            "name": "zcl_version",
                            "value": 1
                        },
                        {
                            "id": 1,
                            "name": "app_version",
                            "value": 5
                        },
                        {
                            "id": 3,
                            "name": "hw_version",
                            "value": 1
                        },
                        {
                            "id": 4,
                            "name": "manufacturer",
                            "value": "eWeLink"
                        },
                        {
                            "id": 5,
                            "name": "model",
                            "value": "TH01"
                        },
                        {
                            "id": 6,
                            "name": "date_code",
                            "value": "20201026"
                        },
                        {
                            "id": 7,
                            "name": "power_source",
                            "value": 3
                        }
                    ]
                },
                {
                    "id": 3,
                    "name": "Identify",
                    "attributes": []
                },
                {
                    "id": 1026,
                    "name": "Temperature Measurement",
                    "attributes": [
                        {
                            "id": 0,
                            "name": "measured_value",
                            "value": 2368
                        }
                    ]
                },
                {
                    "id": 1029,
                    "name": "Relative Humidity Measurement",
                    "attributes": [
                        {
                            "id": 0,
                            "name": "measured_value",
                            "value": 5906
                        }
                    ]
                },
                {
                    "id": 1,
                    "name": "Power Configuration",
                    "attributes": [
                        {
                            "id": 32,
                            "name": "battery_voltage",
                            "value": 29
                        },
                        {
                            "id": 33,
                            "name": "battery_percentage_remaining",
                            "value": 129
                        }
                    ]
                }
            ]
        }
    ],
    "signature": {
        "manufacturer": "eWeLink",
        "model": "TH01",
        "node_desc": {
            "logical_type": 2,
            "complex_descriptor_available": 0,
            "user_descriptor_available": 0,
            "reserved": 0,
            "aps_flags": 0,
            "frequency_band": 8,
            "mac_capability_flags": 128,
            "manufacturer_code": 0,
            "maximum_buffer_size": 80,
            "maximum_incoming_transfer_size": 160,
            "server_mask": 0,
            "maximum_outgoing_transfer_size": 160,
            "descriptor_capability_field": 0
        },
        "endpoints": {
            "1": {
                "profile_id": 260,
                "device_type": 770,
                "input_clusters": [
                    0,
                    3,
                    1026,
                    1029,
                    1
                ],
                "output_clusters": [
                    3
                ]
            }
        }
    },
    "class": "zigpy.device"
}

Ça c’est pour le plug in Zigbee. Ici le pb est coté Deconz.

Positionne les options min(0) et le max (100) pour le % humidité puis relance le démon Deconz… Si le sinfos sont OK sous Phoscon alors le pb vient de l’interface websocket.
Peux tu montrer la page des noeuds du réseau deconz et la page résumé du réseau deconz ?

Aucun changement de plus je vient de me rendre compte que même les valeur de temperature ne ce mettent pas a jour.

Ok, donc je pense qu’il a raison, probleme de websocket, regardes la page de santé, ou relances le demon.

Après avoir désactivé deconz, reinstallé les MAJ en root, reappairé les modules un par un avec un lancement des demons après chaque appairage, ca a l’air de fonctionné. Je mettrai des nouvelles dans les prochains jours pour voir si tous fonctionne dans le temps.

Bon tout a l’air ok. Merci pour votre aide