[RTEX] Aeotec Door/Window Sensor 7 (ZWA008) - capteur magnétique & inclinaison - Magnet & Tilt Sensor

Tags: #<Tag:0x00007f3855710248>

Bonjour à tous, c’est akenad :slight_smile: ,

Aujourd’hui je vais vous présenter un retour d’expérience sur la mise en œuvre du capteur Aeotec Door/Window Sensor 7 (ZWA008-C) avec le plugin Z-Wave.

(Le «-C » veut juste dire que c’est la version Europe.)

Documentation Aeotec : https://aeotec.freshdesk.com/support/solutions/articles/6000218764-door-windows-sensor-7-user-guide

Référence z-wavealliance : https://products.z-wavealliance.org/products/3472

Inclure le module, en mode non sécurisé (appuyer 3 fois rapidement sur le bouton de protection).

Les commandes sont créées automatiquement sauf la commande d’inclinaison (“Tilt”) que nous allons créer manuellement.

Le plugin Jeedom Z-Wave récupère l’Etat de l’aimant à partir de la valeur de l’index « Access Control » de la classe de commande « ALARM ».

Le capteur d’inclinaison effectue un rapport sur la manière dont une fenêtre est ouverte. Le reporting est réalisé via la classe de commande «BINARY_SENSOR » (type Tilt).

  • Si la fenêtre est fermée ou ouverte sans inclinaison → Report : « OFF »
  • Si la fenêtre est inclinée → Report : «ON».

L’angle d’inclinaison de la fenêtre doit être au moins de 5 degrés.

Nous allons simuler le fonctionnement pour vérifier que le capteur fonctionne dans Jeedom.

Au départ les valeurs dans la configuration du module sont les suivantes:

ZWA008-valeurs-sensorOFF-AccessControl-23-CLOSE

En particulier :

  • Sensor = OFF (=> pas d’inclinaison, Tilt = 0)
  • Access Control = 23 (=> l’aimant est « collé » au capteur, Etat « fermé »)

et les commandes sont les suivantes :

ZWA008-commande-Tilt-0-sensorOFF

La commande « Tilt » à été ajoutée manuellement à partir des informations de Valeurs du tableau précédent (ligne « Sensor »).

Pour la commande « Etat », cliquer l’icône roue crantée à droite, puis cliquer onglet « Configuration » et renseigner le champ :

Calcul et arrondi / Formule de calcul (#value# pour la valeur) : #value#==22

ainsi :

  • si sensor = 22 => 0 et inverser => Etat = 1 ouvert
  • si sensor = 23 =>1 et inverser => Etat = 0 fermé

Pour la commande « Tilt », cliquer sur le bouton « Tester » à droite, renvoie dans la bande verte en haut :

« Résultat de la commande : 0 »

Pour simuler le fonctionnement nous allons effectuer les étapes suivantes :

ZWA008-tilt-sensor

  1. au départ :
  • Sensor = OFF (=> pas d’inclinaison, Tilt = 0)
  • Access Control = 23 (=> l’aimant est « collé » au capteur, Etat « fermé »)
  1. Éloigner le capteur de l’aimant jusqu’à ce que la led rouge s’allume.
  2. puis dès que la led rouge s’allume, pivoter le capteur de 90 degrés.

(10 degrés d’ouverture suffit mais 90 degrés c’est pour poser le capteur sur la table dans une position stable.)

Les valeurs dans la configuration du module deviennent les suivantes:

ZWA008-valeurs-sensorON-AccessControl-22-OPEN

En particulier :

  • Sensor = ON (=> détection inclinaison, Tilt = 1)
  • Access Control = 22 (=> l’aimant est « loin » au capteur, Etat « Ouvert »)

et dans les commandes :

ZWA008-commande-Tilt-1-sensorON

Pour la commande « Tilt », cliquer sur le bouton « Tester » à droite, renvoie dans la bande verte en haut :

« Résultat de la commande : 1 »

Pour revenir dans l’état de départ, manipulation inverse :

pivoter le capteur de 90 degrés et Rapprocher le capteur de l’aimant jusqu’à ce que la led rouge s’allume.

A nouveau :

  • Sensor = OFF (=> pas d’inclinaison, Tilt = 0)
  • Access Control = 23 (=> l’aimant est « collé » au capteur, Etat « fermé »)

A noter que le capteur d’inclinaison n’est pas prévu pour fonctionner sans l’aimant.

Voila j’espère que ce retour d’expérience sera utile aux membres Jeedom.

akenad :slight_smile:

4 J'aimes

Merci pour ce partage

Salut, merci pour ce retour !
Concernant ta phrase ci-dessus, ça veut dire qu’on peut savoir à peu près à quel degré se trouve l’objet incliné ? (ça peut être bien pour ma porte de garage basculante que je compte motoriser).

Et non, c’est du tout ou rien, c’est binaire, c’est 0 ou 1, c’est ON/OFF.
A partir d’un décollement de l’aimant associé à une inclinaison du capteur (d’au moins 5 degrés) il y a détection.

akenad :slight_smile:

Ok merci, bon je reste avec mes FGK :sweat_smile:

Super, merci @akenad

Merci @akenad pour ce RTEX et la découverte de ce produit.

Ce capteur sera parfait pour mes fenêtres oscillo-battantes, cela me permettra de faire la distinction entre les 2 états sans mettre 2 capteurs

Bonjour et merci pour toutes ces infos, juste une petite question, je ne trouve pas dans la doc si ce capteur peut se mettre en extérieur ? J’ai vu une IP20 (pas top pour l’extérieur), ce serait pour avoir un retour d’état de mon portail ?
Merci d’avance

Bonjour @Woualy,
IP20 : aucune protection contre l’intrusion d’eau : https://fr.m.wikipedia.org/wiki/Indice_de_protection
Autrement dit pas étanche
Autrement dit pas en extérieur

akenad :slight_smile:

Bonjour,

Petite demande d’aider je m’arrache les cheveux avec ces capteurs, j’en arrive a la conclusion suivante :
Tous fonctionne bien à moins de 2m du contrôleur dé que je dépasse cette barrière des 2m j’ai des trames qui arrivent 1x/4… surtout les callback (voir log) du coup le status n’est jamais mis à jour.
J’en ai 2 dans une même pièce, 1 à 4m l’autre à 5m.
Inclus en mode sécurisé.

Voici le log d’un wakeup d’un capteur (le pire c’est que ça réveille le contrôleur mais plus rien apres) :

2020-05-26 06:23:27.331 Info, Node031, Received Wakeup Notification from node 31
2020-05-26 06:23:27.331 Info, Node031,   Node 31 has been marked as awake
2020-05-26 06:23:27.331 Detail, Node031, Queuing (WakeUp) WakeUpCmd_NoMoreInformation (Node=31): 0x01, 0x09, 0x00, 0x13, 0x1f, 0x02, 0x84, 0x08, 0x25, 0xa4, 0xf5
2020-05-26 06:23:27.331 Detail, Node031, Notification: Notification - Node Awake
2020-05-26 06:23:27.337 Detail,
2020-05-26 06:23:27.338 Info, Node031, Sending (WakeUp) message (Callback ID=0xa4, Expected Reply=0x13) - WakeUpCmd_NoMoreInformation (Node=31): 0x01, 0x09, 0x00, 0x13, 0x1f, 0x02, 0x84, 0x08, 0x25, 0xa4, 0xf5
2020-05-26 06:23:27.404 Detail, Node031,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-05-26 06:23:27.405 Detail, Node031,   ZW_SEND_DATA delivered to Z-Wave stack
2020-05-26 06:23:31.338 Error, Node031, ERROR: Dropping command, expected response not received after 1 attempt(s)
2020-05-26 06:23:31.344 Detail, Node031, Removing current message
2020-05-26 06:23:31.344 Detail, Node031, Notification: Notification - TimeOut
2020-05-26 06:23:33.734 Detail,   Received: 0x01, 0x07, 0x00, 0x13, 0xa4, 0x01, 0x02, 0x7f, 0x33
2020-05-26 06:23:33.734 Detail,   ZW_SEND_DATA Request with callback ID 0xa4 received (expected 0x00)
2020-05-26 06:23:33.734 Warning, WARNING: Unexpected Callback ID received

Avez vous aussi ce genre de soucis ?
J’en ai 6 autres a mettre en place…

Ah oui oui oui

Bah cherche pas trop longtemps. LE conseil : tout ré-inclure en non sécurisé !
Pour t’en convaincre, regardes mes posts ici Soucis sur mon réseau z-wave et là Optimisation du temps de démarrage du réseau Z-Wave Bonne lecture :smile:

Impossible d’avoir le tilt de façon fiable.

Pour revenir à la fonction Tilt, cela marche bien à la main sur une table. Mais je trouve que c’est mission impossible de positionner correctement le module pour que la fonction Tilt marche à tous les coups. Il y a une distance min et max à respecter pour que le capteur soit en « tilt ». Si l’aimant dépasse le max, la fenêtre sera malheureusement considérée comme ouverte sans possibilité de faire fonctionner le tilt. Dans la doc, ce n’est pas très clair pour avoir un positionnement précis.

Mon objectif est de différencier l’ouverture de la boîte aux lettre avec ce module.

  • L’inclinaison du clapet doit activer le tilt et signaler une ouverture pour une lettre (en plaçant l’aimant au niveau de la charnière du clapet, l’aimant pivote sans trop s’éloigner)
  • Ouverture de la porte doit signaler une ouverture pour un colis

Avez-vous une méthode ?

Là tu en demande bcp à la boîte au lettre :slight_smile:
Pour les soucis zwave j’ai lu rapidement tes retours et les autres, la réponse est simple depuis 2 ans que Nechry à arrêté de développer le plugin zwave sur Jeedom plus rien n’est fait, résultats les bugs et autres corrigés avec les nouvelles versions de openzwave ne sont pas intégré à Jeedom…
Je vais essayer d’inclure un aeotec avec la dernière carte zwave sur un rpi4 antenne, voir si mieux, sinon ça m’embêterai mais passer sur Zwave2Mqtt

@Knoppix1

Pour ton problème WakeUpCmd_NoMoreInformation (je l’ai eu aussi avec un autre module Aeotec assez éloigné qui posait souci lors des réveils), refaire l’inclusion en non sécurisé (même s’il semble fonctionner en non sécurisé car pas de cadenas après une inclusion faite en sécurisé). Bien mettre à jour les voisins puisque ton module fonctionne près de la box. Remarque, le réveil c’est toutes les 24 heures par défaut avec ce module.

Tu peux aussi remplacer cette ligne dans le fichier de config zwa008.xml avant de faire l’inclusion.

<!-- Basic set as report -->
<CommandClass id="32" setasreport="true"/>

par ceci

<!-- COMMAND_CLASS_BASIC (0x20) BasicCmd_Get not supported -->
<CommandClass id="32" getsupported="false"/>

Cela fera un Dropping command et un timeout inutile de moins. La classe 32 n’est pas exploitée dans les commandes Jeedom.

J’en demande au capteur et surtout à sa doc :grinning:
Sur la table de mon salon avec mes doigts, le tilt est aléatoire.
Comment positionner cet aimant ?
==> Comme je ne sais pas, j’utilise ce module pour compter les impulsions des compteurs gaz et eau.

L’aimant dans le capteur est en forme de U il épouse le contour du bas quand quand l’ouverture est en haut, effectivement pour le tilt je pense que c’est mort car il doit rester dans la position incliné et dans ton cas c’est pas possible, t’aura que la fonction ouverture de porte;

Pour mon soucis j’ai un peu avancé, il s’avère que sur mon 2eme Pi 4 avec le « nouveau » module RaZberry (2016) ça fonctionne nickel à 10m remontée instantané en sécurisé etc.

Je vais donc pour mon premier réinstaller tout Jeedom, car la 1ere fois j’avais du installé manuellement OpenZave et je pense que ça a foutue la zone dans les dépendance etc j’espere sinon je suis bon pour changer de contrôleur Zwave ! J’airai sur la clé Aeotec

Je veux bien un dessin. :pencil2:

Là, je joue avec dans mon salon sur la table. Je peux le mettre dans toutes les positions. C’est la distance dans la position incliné qui est dur à déterminer. Ensuite, je fixerai le module en fonction.
Mais, je ne trouve pas que l’indication du Tilt soit stable.

« Pour moi » ce capteur ne peux pas être dans les états que tu veux faire,
L’inclinaison est détecté par le capteur (via sa polarité par rapport a l’aiment - pas de capteur gyro) une fois que l’aiment est collé au capteur avec une inclinaison il va passer dans l’état incliné mais quand il se décolle l’état pour lui est tjs en incliné mais ouvert pour repasser en non incliné faut qu’il recolle parallèlement à l’aiment.
Donc je vois pas comment tu peux faire ça avec l’ouverture de la porte et l’ouverture de la fente, ou tu positionnerai ton aiment et ton capteur ?

Pour faire un retour sur ce capteur,
J’ai deux maison dans l’une (plus récente) aucuns soucis avec une portée d’une dizaine de mètres avec 3 murs a traverser et un étage. RAS
Dans l’autre (une grange refait a neuf dans les année 90) avec le contrôleur en face du module, qui est lui a peine à 5m mais sous un encadrement de porte dans un mur de pierre (et surement un porte avec du fer dedans) impossible de récupérer un état, et dans la même pièce une baie vitrée en alu (de 90 aussi surement…) A 3m du contrôleur impossible non plus…par contre si je test a l’étage dans la même maison ça fonctionne nickel… c’est a s’arracher les cheveux !
J’ai donc essayé pleins de positionnements rien a faire, j’ai fini par acheter en reconditionné un Fibaro et lui fonctionne bien sur l’encadrement de porte. (MAJ) idem pour la baie vitrée
Du coup j’en arrive a la conclusion que ce Aeotec doit être assez sensible a certaines perturbations.

Petite question. J’ai suivi ta config, et merci pour ce partage, mais je n’ai pas les bonnes valeurs d’état.
image
image

Ca ne marche que pour la représentation de la commande, semble-t-il. Dans l’histoire ou avec les plugins, l’état vaut 0 et donc il ne déclenche pas les scénarios. Je suis le seul dans ce cas, j’ai fait un truc de travers ?

Les scénar et histo chez moi sont bons
Cette conf n’est plus a faire elle est intégré dans les conf par défaut
Je conseil d’exclure, mettre a jour les conf Zwave sur le plugin et ré-inclure en attribuant bien la conf recommandée. Et c’est tout

Je vais tenter ça, il me semblait l’avoir fait il y a quelques semaines pourtant …