RFLink Adruino ne fonctionne pas

Tags: #<Tag:0x00007fa7a94ce390>

Bonjour à tous,
J’ai construit un RFLink en m’aidant de cette page. J’ai pris les SRX882 et STX882.
Le flashage de l’Adruino s’est bien passé, je l’ai connecté à mon Jeedom avec le câble fourni.
Je souhaiterai ajouter une télécommande Dio 54791, deux boutons, pour commencer.

Dans le plugin rflink, je me met en inclusion et j’appuie sur le bouton « ON » jusqu’à temps qu’il ne clignote plus (comme je le ferais avec une commande de prise par exemple), mais la télécommande ne remonte pas dans Jeedom. Idem avec une prise commandée.

Voici les logs en debug :
rflink :

[2021-03-23 14:18:09][INFO] : Arrêt du service rflink
[2021-03-23 14:18:09][INFO] : Lancement du démon rflink
[2021-03-23 14:18:09][DEBUG] : Lancement démon rflink : nice -n 19 nodejs /var/www/html/plugins/rflink/resources/rflink.js http://127.0.0.1:80/plugins/rflink/core/api/rflink.php?apikey=**************5sufDdfba1ZhurDVb*********** /dev/ttyACM0 none debug
[2021-03-23 14:18:09][INFO] : Démon rflink lancé
[2021-03-23 14:18:14][INFO] : 10;STATUS;
[2021-03-23 14:18:15][DEBUG] : Status 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;

rflink_node :

Tue Mar 23 2021 14:18:10 GMT+0100 (Central European Standard Time) - Jeedom url : http://127.0.0.1:80/plugins/rflink/core/api/rflink.php?apikey=**************5sufDdfba1ZhurDVb***********, gwAddress : /dev/ttyACM0
Tue Mar 23 2021 14:18:10 GMT+0100 (Central European Standard Time) - server bound on 8020
Port open
Tue Mar 23 2021 14:18:11 GMT+0100 (Central European Standard Time) - 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Tue Mar 23 2021 14:18:11 GMT+0100 (Central European Standard Time) - Send Value : 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Tue Mar 23 2021 14:18:11 GMT+0100 (Central European Standard Time) - Got response Value : 200
Tue Mar 23 2021 14:18:14 GMT+0100 (Central European Standard Time) - Server connected
Tue Mar 23 2021 14:18:14 GMT+0100 (Central European Standard Time) - 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Tue Mar 23 2021 14:18:14 GMT+0100 (Central European Standard Time) - Send Value : 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Tue Mar 23 2021 14:18:15 GMT+0100 (Central European Standard Time) - Got response Value : 200

J’ai re-vérifié les soudures, tout semble OK.

Que dois-je vérifier d’autre pour que cela fonctionne ?

Merci par avance

Ne sachant pas d’où vient le problème, je te conseillerais de vérifier ton rflink avec le programme rflink loader ( fourni avec les sources).
Et si tu n’as rien comme sur jeedom, c’est que le problème vient de ton rflink, après une photo de ton montage semble le minimum pour t’aider.

Hello, là le plugin ne reçoit aucune trame.

Normalement tu devrais voir des trames qui arrivent comme les 2 dernières lignes.
Aurais-tu une sonde (genre température) qui envoie régulièrement des trames ?

Fri Mar 26 2021 22:56:36 GMT+0100 (Central European Standard Time) - Jeedom url : http://127.0.0.1:80/plugins/rflink/core/api/rflink.php?apikey= gwAddress : /dev/ttyACM0
Fri Mar 26 2021 22:56:36 GMT+0100 (Central European Standard Time) - server bound on 8020
Port open
Fri Mar 26 2021 22:56:37 GMT+0100 (Central European Standard Time) - Send Value : 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Fri Mar 26 2021 22:56:40 GMT+0100 (Central European Standard Time) - Server connected
Fri Mar 26 2021 22:56:40 GMT+0100 (Central European Standard Time) - Send Value : 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Fri Mar 26 2021 22:57:02 GMT+0100 (Central European Standard Time) - Send Value : 20;02;Prologue;ID=9190;TEMP=00b8;HUM=39;
Fri Mar 26 2021 22:57:16 GMT+0100 (Central European Standard Time) - Send Value : 20;03;Oregon TempHygro;ID=2D37;TEMP=00ce;HUM=32;HSTATUS=2;BAT=OK;

Tu peux trouver la doc là: rflink loader

et la doc pour la « soudure »: wiring

@Tab je n’utilise pas le même emetteur/recepteur que toi mais dans la doc sur rflink.nl je lis:

### Pullup on RF data in pin:

Connect Arduino PIN 7 to ground in order to disable an internal pullup on the RF data pin.
This is required for some RF modules like the SRX882.