Réveille de model 3

Tags: #<Tag:0x00007f38523782c8>

Bonjour,

J’aimerais savoir si certains rencontre le même problème que moi, j’ai créé le scénario pour calculer la fin de charge.
Mon scénario se déclenche sur la condition suviante : #[Exterieur][LinkyWifi][PTEC]#==« HC… »

Donc quand mon compteur passe en heure creuse ca déclenche mon scénario jusque là pas de problème. Je réveille la voiture alors là apparement la voiture se réveille bien car elle enclenche la charge. Par contre le bug c’est la variable #[Exterieur][Eveuuh!][Info réveillée]# == 1 qui n’est pas correctement actualisée du coup le scénario ne suit pas son déroulement correctement.

Je tiens à signaler aussi que de mettre le SI dans la première action ne fonctionne pas et idem j’ai tenté de déclencher le scénario via l’info câble connecté comme dans le tuto mais la ca marche quand ca veut et parfois le scénario se déclenche quand je retire le câble.

image

Voici le log de mon scénario.

[2020-08-04 03:04:09][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Exterieur][LinkyWifi][PTEC].
[2020-08-04 03:04:09][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-04 03:04:09][SCENARIO] Suppression des blocs DANS et A programmés du scénario 
[2020-08-04 03:04:09][SCENARIO] Exécution de la commande [Exterieur][Eveuuh!][Réveiller] avec comme option(s) : {"background":"0","select":"1"}
[2020-08-04 03:04:13][SCENARIO] Exécution du sous-élément de type [condition] : if
[2020-08-04 03:04:13][SCENARIO] Evaluation de la condition : [0 == 1 && "NoPower" != "Disconnected"] = Faux
[2020-08-04 03:04:13][SCENARIO] Exécution du sous-élément de type [action] : else
[2020-08-04 03:04:13][SCENARIO] Fin correcte du scénario

J’ai l’impression qu’il y a un problème avec les temps d’attentes dans le réveil de la voiture avant mon déménagement j’avais le même type de scénario qui fonctionnait parfaitement sur la V3.
Là depuis début juin je suis parti sur un truc tout neuf pour le moment j’ai juste le plugin Tesla et caméra qui tourne.
J’ai mis le plugin en mode debug pour cette nuit je ferais un retour ici.

Salut

Cite l’auteur du plugin, @vercors, pour augmenter tes chances de réponses.

Je n’utilise pas la fonction réveillée mais elle semble assez peu fiable. Ce n’est pas la faute du plugin mais plutôt de Tesla.

Antoine

1 J'aime

Hello @yoyo,

Dans ton scénario, ça fait quoi « remove_inat » ?
J’ai jeté un oeil à mon code, et je fais peut-être une mise à jour de trop sur « info réveillé » qui a potentiellement l’effet de bord que tu décris. Je vais corriger et pousser une béta.
A+
Nicolas

@vercors merci !!
remove_inat ca enlève toutes les actions programmées quand le scénario ce lance c’est pour éviter d’avoir plusieurs tâches de programmés quand je relance le scénario à la mano parfois.

@Tonio16 merci j’avais zappé !

Bonjour,
Le tag du plug-in est mis, donc non pas la peine de tag la personne en plus.

Il n’est peut être pas le seul à pouvoir répondre non plus.

Voici le log de cette nuit.

Log du plugin en mode debug :

[2020-08-05 03:04:08][DEBUG] : 'Eveuuh!' Exécution de la commande 'wakeup(Array (     [background] => 0     [select] => 1 ) )'
[2020-08-05 03:04:11][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [#         ]
[2020-08-05 03:04:11][INFO] : 'Eveuuh!' La voiture est maintenant réveillée après 1 tentative
[2020-08-05 03:04:11][DEBUG] : set mode NORMAL
[2020-08-05 03:04:11][INFO] : 'Eveuuh!' Suivi de l'autonomie en mode NORMAL

Log de mon scénario :

[2020-08-05 03:04:08][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Exterieur][LinkyWifi][PTEC].
[2020-08-05 03:04:08][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-05 03:04:08][SCENARIO] Exécution de la commande [Exterieur][Eveuuh!][Réveiller] avec comme option(s) : {"background":"0","select":"1"}
[2020-08-05 03:04:11][SCENARIO] Suppression des blocs DANS et A programmés du scénario 
[2020-08-05 03:04:11][SCENARIO] Exécution du sous-élément de type [condition] : if
[2020-08-05 03:04:11][SCENARIO] Evaluation de la condition : [0 == 1 && "NoPower" != "Disconnected"] = Faux
[2020-08-05 03:04:11][SCENARIO] Exécution du sous-élément de type [action] : else
[2020-08-05 03:04:11][SCENARIO] Fin correcte du scénario

Je mets à jour le plugin en beta nouveau test cette nuit avec la version suivante :
Version: 2.1.1-beta-2-g099908b

@vercors Avec la version beta Version: 2.1.1-beta-2-g099908b toujours pareil.
Voici le log scénario :

------------------------------------
[2020-08-06 03:04:07][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Exterieur][LinkyWifi][PTEC].
[2020-08-06 03:04:07][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-06 03:04:07][SCENARIO] Exécution de la commande [Exterieur][Eveuuh!][Réveiller] avec comme option(s) : {"background":"0","select":"1"}
[2020-08-06 03:04:15][SCENARIO] Suppression des blocs DANS et A programmés du scénario
[2020-08-06 03:04:15][SCENARIO] Exécution du sous-élément de type [condition] : if
[2020-08-06 03:04:15][SCENARIO] Evaluation de la condition : [0 == 1 && "Complete" != "Disconnected"] = Faux
[2020-08-06 03:04:15][SCENARIO] Exécution du sous-élément de type [action] : else
[2020-08-06 03:04:15][SCENARIO] Fin correcte du scénario

Voici le log plugin :

[2020-08-05 22:00:04][DEBUG] : 'Eveuuh!' Exécution de la commande 'refresh()'
[2020-08-05 22:00:07][INFO] : 'Eveuuh!' Synchronisation horaire avec les serveurs Tesla
[2020-08-06 03:04:07][DEBUG] : 'Eveuuh!' Exécution de la commande 'wakeup(Array (     [background] => 0     [select] => 1 ) )'
[2020-08-06 03:04:11][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [#         ]
[2020-08-06 03:04:15][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [##        ]
[2020-08-06 03:04:15][INFO] : 'Eveuuh!' La voiture est maintenant réveillée après 1 tentative
[2020-08-06 03:04:15][DEBUG] : set mode NORMAL
[2020-08-06 03:04:15][INFO] : 'Eveuuh!' Suivi de l'autonomie en mode NORMAL
[2020-08-06 05:00:04][DEBUG] : 'Eveuuh!' Exécution de la commande 'refresh()'
[2020-08-06 05:00:07][INFO] : 'Eveuuh!' Synchronisation horaire avec les serveurs Tesla
[2020-08-06 06:00:05][DEBUG] : 'Eveuuh!' Exécution de la commande 'refresh()'
[2020-08-06 06:00:08][INFO] : 'Eveuuh!' Synchronisation horaire avec les serveurs Tesla
[2020-08-06 07:00:04][DEBUG] : 'Eveuuh!' Exécution de la commande 'refresh()'
[2020-08-06 07:00:07][INFO] : 'Eveuuh!' Synchronisation horaire avec les serveurs Tesla

@vercors Je viens de tester la beta : Version: 2.1.2-beta-2-gb7ed23a c’est bon ca marche j’ai bien le statut que la voiture est bien réveillé qui remonte correctement dans mon scénario.

Merci.

@vercors Désolé de revenir mais non ca ne marche pas quand la voiture mets trop de temps à répondre comme si le scénario s’éxécutait quand même avant que la voiture soit réveillée.
J’ai regardé dans les log du plugin quand la voiture mets plus de 2s à se réveiller ca marche.
Quand la voiture se réveille dans la seconde ca fonctionne parfaitement j’ai bien le retour.
Normal en faite.

Tu as du changer un truc dans le plugin sur la fonction réveille qui ne le rend plus bloquant pour les scénarios.

j’ai mis à charger ma voiture cette nuit voici le log de mon scénario.
Je ne veux pas utilisé le plugin pour suivre ma conso etc… je ne veux pas qu’il réveil ma voiture j’ai l’impression que plus rien ne fonctionne du coup !

[2020-08-21 03:04:24][SCENARIO] Evaluation de la condition : [0 == 1 && "Driving" != "Disconnected"] = Faux
 

Je vous jure que je ne conduisais pas ma voiture à 3h du mat :rofl: :joy: :grin:

@yoyo : je regarde

EDIT: je viens de pousser une version béta. « Info Réveillée » pouvait ne pas être mis à jour correctement.

Je garde un oeil sur tout ça de mon coté, aussi.

Merci
Nicolas

Salut,
J’aimerais savoir si il y a besoin d’activer le demon car j’ai l’impression que cela n’actualise pas les données quand la voiture est réveillé sans le demon d’activé mon problème viendrait de là avant il n’ y avait pas besoin d’activer le demon.

Une autre remarque également quand je clique sur les petites fleches pour actualiser le widget avant ca réveillait la voiture maintenant ca ne fonctionne plus obligé de réveiller la voiture à la main et ensuite d’actualiser le widget.

Hello,

Oui c’est le tracking qui maintient les données « Info » le plus à jour.
Sans ça, c’est le cronHourly qui ira faire une mise à jour toutes les heures (quand la voiture est réveillée).
Donc, je recommande d’activer le tracking en mode Auto !
Nicolas

Franchement c’est pas top cette histoire d’être obligé d’activer le tracking maintenant.

Pour mon scénario cela ne fonctionne toujours pas, si je peux faire quelque chose pour t’aider n’hesite pas car je suis un pressé de retrouver cette fonction :grin: :grin:

[2020-08-25 12:04:15][DEBUG] : 'Eveuuh!' Exécution de la commande 'wakeup(Array (     [background] => 0     [select] => 1 ) )'
[2020-08-25 12:04:20][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [#         ]
[2020-08-25 12:04:24][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [##        ]
[2020-08-25 12:04:27][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [###       ]
[2020-08-25 12:04:27][INFO] : 'Eveuuh!' La voiture est maintenant réveillée après 1 tentative
[2020-08-25 12:04:27][DEBUG] : set mode NORMAL
[2020-08-25 12:04:15][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Exterieur][LinkyWifi][PTEC].
[2020-08-25 12:04:15][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-25 12:04:15][SCENARIO] Exécution de la commande [Exterieur][Eveuuh!][Réveiller] avec comme option(s) : {"background":"0","select":"1"}
[2020-08-25 12:04:28][SCENARIO] Suppression des blocs DANS et A programmés du scénario
[2020-08-25 12:04:28][SCENARIO] Exécution du sous-élément de type [condition] : if
[2020-08-25 12:04:28][SCENARIO] Evaluation de la condition : [0 == 1 && "Complete" != "Disconnected"] = Faux
[2020-08-25 12:04:28][SCENARIO] Exécution du sous-élément de type [action] : else
[2020-08-25 12:04:28][SCENARIO] Fin correcte du scénario

Je suis le seul à rencontrer ce genre de problème ? Personne utilise cette fonctionnalité.

Stp remet une ancienne version celle ou tu n’avais pas obligatoirement besoin du tracking en plus :sob: :sob: :sob:

@vercors plus personne ??

Salut @yoyo,
Désolé pour le silence… :disappointed:
Tu as toujours le problème, même avec la dernière version béta qui met à jour le status indépendamment du tracking ?

Je viens de sortir pour tester la apparemment ca fonctionne je suis en version : 2.1.2-beta-9-gcebcc8e
Il y a toujours l’erreur de charge dans les logs aussi c’est pas blocant mais un peu bizarre voir ci-dessous.

[2020-09-28 22:50:39][INFO] : 'Eveuuh!' L'équipement a été mis à jour
[2020-09-28 22:53:55][DEBUG] : 'Eveuuh!' Exécution de la commande 'wakeup(Array (     [background] => 0     [select] => 1 ) )'
[2020-09-28 22:53:58][INFO] : 'Eveuuh!' Tentative de réveil 1/10 [#         ]
[2020-09-28 22:53:58][INFO] : 'Eveuuh!' La voiture est maintenant réveillée après 1 tentative
[2020-09-28 22:53:58][DEBUG] : set mode NORMAL
[2020-09-28 22:53:58][INFO] : 'Eveuuh!' Suivi de l'autonomie en mode NORMAL
[2020-09-28 22:53:58][DEBUG] : 'Eveuuh!' Exécution de la commande 'charge_limit(Array (     [background] => 0     [slider] => 70 ) )'
[2020-09-28 22:54:00][INFO] : 'Eveuuh!' La limite de charge est déjà réglée à 70%
[2020-09-28 22:54:00][DEBUG] : 'Eveuuh!' Exécution de la commande 'set_charge_end_time(Array (     [background] => 0     [slider] => 755 ) )'
[2020-09-28 22:54:01][INFO] : 'Eveuuh!' L'heure de fin de recharge a été réglée à 7h55
[2020-09-28 22:54:01][DEBUG] : 'Eveuuh!' Exécution de la commande 'charge_onoff(Array (     [background] => 0     [select] => 3 ) )'
[2020-09-28 22:54:02][INFO] : 'Eveuuh!' Estimation du temps de charge...
[2020-09-28 22:54:03][ERROR] : 'Eveuuh!' Impossible de démarrer la recharge
[2020-09-28 22:56:08][DEBUG] : 'Eveuuh!' Le calcul indique un début de recharge à 6h05 pour finir à 7h55
[2020-09-28 22:56:09][INFO] : 'Eveuuh!' Recharge arrêtée

On voit impossible de démarrer la charge alors que la voiture charge correctement c’est bizarre. Je crois qu’il faudrait faire la différence si jamais la voiture charge déjà.
Je pense que c’est cause de ma borne qui est en attente des heures creuses, du coup la voiture se met en charge dès que je rentre en heure creuse et mon scénario se déclenche quand les heures creuses arrive mais la voiture charge déjà au moment de l’action de charge du scénario.

super !

Ah oui. c’est sûr que si la voiture est en cours de charge et que le plugin demande une charge, ce genre de message doit s’afficher. Je vais modifier ça.

Merci pour ton retour!
A+

Un énorme merci ca marche nickel avec la version beta mentionné plus haut !
Trop cool !
Je suis soulagé :grin: :rofl: :joy: car l’hiver arrive du coup mon scénario de température avec mes capteurs xiaomi va pouvoir déclenché le dégivrage automatiquement le matin ^^

1 J'aime