Réveil des appareils Google Cast/Spotify Connect

Tags: #<Tag:0x00007f59312a9950>

Bonjour,

j’utilise depuis quelques semaines le plugin Spotify et je suis confronté à un problème assez important (en tout cas si on souhaite faire de l’automatisation) : seuls les appareils sur lesquels il y a eu un cast assez “récent” apparaissent dans la liste des devices.
De ce fait, impossible de faire par exemple un scénario qui se déclenche au réveil pour lancer une playlist sur un Google Nest Hub, car il n’est tout simplement pas dans la liste. Alors oui ça c’est possible avec les routines Google, mais c’est juste un exemple, un autre serait de pouvoir lancer de la musique quand j’arrive chez moi, sans avoir à lancer une routine Google à la voix.

J’ai essayé quelques trucs avec le plugin Google Cast (faire mute/unmute, pause/play, etc.) pour tenter de réveiller l’appareil et faire en sorte qu’il apparaisse dans la liste des devices du plugin Spotify, mais sans succès. Aussi, le plugin Google Cast permet de lancer une playlist Spotify via une commande mais apparemment c’est via un token temporaire donc uniquement à des fins de tests, ce n’est pas viable.

Si jamais quelqu’un aurait une idée (probablement une bidouille) pour faire en sorte de réveiller l’appareil, ce serait top !
Merci d’avance.

Hello,

J’espère que ma dernière modif de mon plugin pourra répondre ;-), la discussion continue sur le fil [Plugin Tiers] Spotify

Merci

sbarre35

Ahah oui effectivement, c’est d’ailleurs moi qui t’ai posé la question sur l’autre sujet. Je teste ça ce soir !

J’espère que l’évolution cast te conviens :slight_smile: , si tu utilises mon plugin n’hésite pas à le noter sur le market (https://www.jeedom.com/market/index.php?v=d&p=market&type=plugin&&name=spotify) et à faire un don paypal (https://paypal.me/sbarre35)

Bonjour, dans la config du plugin Spotify, je n’ai pas de champs “Cast devices” qui apparaît. Je ne peux donc pas déclarer mes devices :frowning:

Il faut installer la bêta du plugin

Passage en release bienôt, faites moi vos retour pour savoir si comme chez moi c’est stable chez vous :slight_smile:

Pas eu de soucis de stabilité, mais plutôt d’exécution. Par exemple, si je met à la suite la commande pour sélectionner l’appareil puis régler le volume, parfois j’ai une erreur “appareil non sélectionné”, un sleep de 1 ou 2s suffit à résoudre le soucis

Bonjour,
J’ai installé le plugin depuis quelques temps. C’est du super boulot et top de pouvoir piloter son Spotify depuis Jeedom.
J’utilise un ampli-video Denon compatible Spotify et j’ai le même problème que celui décrit plus haut : L’appareil disparaît de la liste des devices après 24h de non utilisation.
Voici les log du script :

[2020-01-25 09:12:51][SCENARIO] Exécution de la commande [Salon][Spotify][Device Id Set] avec comme option(s) : {"background":"0","select":"8910f14041af2155e621f4aa186a67feba99961f"}
[2020-01-25 09:12:51][SCENARIO] Device not found
[2020-01-25 09:12:51][SCENARIO] Pause de 5 seconde(s)
[2020-01-25 09:12:56][SCENARIO] Exécution de la commande [Salon][Spotify][Playlist Id Set] avec comme option(s) : {"background":"0","select":"spotify:user:xxxxxxxxx:playlist:7iUSkB9bCOoEdLsGHWxbvj"}
[2020-01-25 09:12:56][SCENARIO] Player command failed: No active device found
[2020-01-25 09:12:56][SCENARIO] Exécution de la commande [Salon][Spotify][Device Volume Set] avec comme option(s) : {"background":"0","slider":30}
[2020-01-25 09:12:56][SCENARIO] Player command failed: No active device found
[2020-01-25 09:12:56][SCENARIO] Pause de 10 seconde(s)
[2020-01-25 09:13:06][SCENARIO] Exécution de la commande [Salon][Spotify][Play]
[2020-01-25 09:13:06][SCENARIO] Player command failed: No active device found

J’ai regardé sur l’appli Web Spotify : L’appareil a également disparu de la liste.
Par contre, mon ampli est bien visible sur l’appli iPhone. Si je m’y connecte via l’iPhone, l’ampli réapparaît dans la liste du plugin pour 24h/48h puis redisparaît !
Comment fairer pour que l’appareil reste enregistré dans la liste des devices ?
J’ai installé la version béta qui doit traiter le cas des appareils GoogleCast mais le problème persiste pour mon ampli.
Merci de votre aide.