[RÉSOLU] Utilisation bouton IKEA TRADFRI ON/OFF

Tags: #<Tag:0x00007fe31a574ef0>

Bonjour,

Je débute sous Jeedom. J’utilise Jeedom sur une machine virtuelle VirtualBox avec Debian sur un PC sous Linux Mint 19.3. J’utilise la passerelle ConBee 2 et le plugin deConz

J’ai acheté pour commencer 2 lots de prises commandées avec les boutons on/off chez IKEA TRADFRI.

J’ai réussi à ajouter une prise et un bouton via deConz. Je pilote la prise via un bouton virtuel et un scénario.

Par contre, je n’arrive pas à utiliser le bouton pour piloter la prise. J’ai crée un simple scénario pour éteindre la prise avec comme déclencheur le bouton IKEA mais il ne se passe rien.

Voici les détails du bouton sous deConz :

Equipement_tradfri

Commande

config_avvanc%C3%A9e

Le retour de la commande est toujours 2002, quand je test la commande.

Dans les logs, je vois bien l’appui du bouton.

15:14:49:369 button 2002 Off
15:14:49:373 rule event: /sensors/2 state/lastupdated num (0 -> 0)
15:14:53:387 button 1002 On
15:14:53:390 rule event: /sensors/2 state/lastupdated num (0 -> 0)
15:14:55:375 button 2002 Off
15:14:55:379 rule event: /sensors/2 state/lastupdated num (0 -> 0)
15:14:57:283 button 1002 On
15:14:57:287 rule event: /sensors/2 state/lastupdated num (0 -> 0)

Quelqu’un a t il réussi à utiliser ce bouton?

Merci d’avance

Il semble que non puisque dans le log on voit bien 1002 et 2002. Tu peux aussi essayer des appuis longs qui devraient te donner une valeur différente, ça fonctionne avec ce switch.

Pour info, on peut aussi faire directement le lien dans Phoscon. Il faut mettre le switch et la prise dans un même groupe, puis cliquer sur Edit puis Switch Editor.

image

L’avantage c’est que même en cas de problème avec Jeedom cela fonctionnera à condition que la partie Deconz derrière tourne toujours. Normalement, il est même possible de faire un lien direct bouton / prise mais je n’ai pas réussi à le faire avec ce switch sans perdre le contrôle par Deconz (cela fonctionne avec la télécommande Ikea à 5 boutons par contre).

Bonjour seb821,

Merci pour ta réponse.

J’ai déjà essayé les appuis long mais le retour est toujours le même 2002.

J’avais déjà mis en place le plan B avec Phoscon et il fonctionne mais je veux utiliser le bouton avec Jeedom pour appliquer d’autres règles (contrainte horaire, état de la prise, …).

Je suis bloqué avec ce bouton qui ne change pas d’état. Je l’ai aussi supprimé de deconz et ajouté de nouveau mais même problème.

J’ai résolu mon problème. J’ai relancé le demon de deconz et je vois vivre la valeur du bouton en testant la commande.

J’en profite pour partager les différents retour fait par le bouton :

  • Appui court sur ON : 1002
  • Appui long sur ON : 1001
  • Fin de l’appui long sur ON : 1003
  • Appui court sur OFF : 2002
  • Appui long sur OFF : 2001
  • Fin de l’appui long sur OFF : 2003

Je passe le sujet sur RESOLU

Bonjour à tous !
J’ai pour ma part un souci avec la télécommande tradfri 5 boutons. Elle est reconnue comme tel sur phoscon, mais sur jeedom elle est reconnue comme une télécommande 2 boutons… Mais le soucis est que lorsque j’appuie sur les différents boutons rien ne change au niveau des logs de deconz…alors que mes ampoules Ikea fonctionnent correctement avec jeedom…
Quelqu’un a une idée ?

Voici mes logs deconz:


Toggle navigation

Gestion

Ajouter

Mode inclusion

Réseau Deconz

Synchronisation

Configuration

Mes équipement Zigbee


Aucun
Léontine


Maison
Configuration tool 1


Maison
TRÅDFRI remote control


Salle de Bain
salle de bain droite


Salle de Bain
salle de bain Gauche


Salon
Vibration meuble

Configuration du plugin

Deconz (deconz) - stable

Rafraichir Documentation Changelog Détails Supprimer

Etat

Logs et surveillance Sauvegarder

Dépendances

Nom Statut Installation Dernière installation
Local OK Relancer 2020-03-22 20:39:20

Démon

Nom Statut Configuration (Re)Démarrer Arrêter Gestion automatique Dernier lancement
Local OK OK Désactiver 2020-03-23 07:49:33

Configuration Sauvegarder

Fonctionnalités Sauvegarder

Log du plugin

Reprendre Télécharger Vider Supprimer

sudo: unable to send audit message: Unknown error -1 Usage: kill [options] […] Options: […] send signal to every listed -, -s, --signal specify the to be sent -l, --list=[] list all signal names, or convert one to a name -L, --table list all signal names in a nice table -h, --help display this help and exit -V, --version output version information and exit For more details see kill(1). [2020-03-22 13:55:27.620][ERROR] : ‹ name › sudo: unable to send audit message: Unknown error -1 sudo: unable to send audit message: Unknown error -1 sudo: unable to send audit message: Unknown error -1 sudo: unable to send audit message: Unknown error -1 [2020-03-23 12:40:18][ERROR] : Erreur exécution de la commande [Salle de Bain][salle de bain Gauche][Luminosité 01] : Erreur lors de la requete : 192.168.1.33:32771/api/77777777E9/lights/3/state(PUT), data : {« bri »:0,« on »:false} erreur : 3 => resource, /lights/3, not available [2020-03-23 12:40:31][ERROR] : Erreur exécution de la commande [Salle de Bain][salle de bain Gauche][Off 01] : Erreur lors de la requete : 192.168.1.33:32771/api/77777777E9/lights/3/state(PUT), data : {« on »:false} erreur : 3 => resource, /lights/3, not available [2020-03-23 14:35:03][ERROR] : Erreur exécution de la commande [Salle de Bain][salle de bain droite][Luminosité 01] : Erreur lors de la requete : 192.168.1.33:32771/api/7777777E9/lights/2/state(PUT), data : {« bri »:0,« on »:false} erreur : 3 => resource, /lights/2, not available

Les erreurs sur les lights sont dues au fait que l’interrupteur physique était éteins.

Merci par avance !!

Bonjour. Fais en un sujet à part. Ici, avec le titre qui ne correspond pas et le sujet en Résolu, tu as moins de chance d’avoir des réponses :wink:.

Merci je fais ça de suite !!